Bug 122557 - No sound in FC2T3
No sound in FC2T3
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 15:13 EDT by Eelco Hoekema
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 08:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eelco Hoekema 2004-05-05 15:13:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
Sound won't work in FC2T3, whereas it works in FC2T2.
Here's the console output when running system-config-soundcard:

[root@lafbek eelco]# system-config-soundcard
amixer: Unable to find simple control 'Master',0
 
amixer: Unable to find simple control 'PCM',0
 
sox: Can't open output file '/dev/dsp': No such device
-9
[root@lafbek eelco]#

Rhythmbox says:
Could not pause playback
Alsa device "default" is already in use by another program.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Play sound file
2.
3.
    

Actual Results:  No sound

Expected Results:  Sound

Additional info:

========================================
modprobe.conf in FC2T3:
========================================
alias eth0 sk98lin
alias scsi_hostadapter sata_via
alias snd-card-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias char-major-81 bttv
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias snd-card-1 audio
install audio /sbin/modprobe --ignore-install audio &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove audio


========================================
modprobe.conf in FC2T2:
========================================
alias char-major-81* bttv
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias usb-controller2 uhci-hcd
alias ieee1394-controller ohci1394
alias scsi_hostadapter sata_via
alias eth0 sk98lin
 
# ALSA portion
alias char-major-116* snd
alias snd-card-0 snd-via82xx
 
# OSS/Free portion
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
 
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
 
install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && {
/usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-card-0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; };
/sbin/modprobe -r --ignore-remove
 
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && {
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>>/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove


========================================

========================================

I tried copying the lines from the T2 modprobe.conf to the T3 one, but
that didn't help.
Comment 1 Muhammad Alkarouri 2004-05-11 07:39:47 EDT
More or less same problem.
Clean install of FC2T3 (Dunno about test 2)
system-config-soundcard works and tests playing sound _correctly_. You
hear the sound.

Rhythmbox says:
Could not pause playback
Alsa device "default" is already in use by another program.

/usr/bin/play file.ogg works, even under X/GNOME.

gstreamer-properties fails.
Comment 2 Bill Nottingham 2004-05-21 13:44:13 EDT
Does this behave better in the final release? (A fix went into
modutils for this.)
Comment 3 Eelco Hoekema 2004-05-29 13:59:23 EDT
I've been running FC2 for one week now. Seems sound works perfectly
fine in the final release.
Comment 4 Alan Lehman 2004-05-29 22:03:07 EDT
After upgrade from FC1 to FC2 final release, sound does not work at all.
Comment 5 Bill Nottingham 2004-06-01 00:43:32 EDT
Can you post your config files (/etc/modprobe.conf*)?
Comment 6 Christopher Beland 2004-06-08 02:17:15 EDT
Bug 122557, 122953, bug 123389, bug 123586, bug 123631, and bug 124497
all seem to be describing the same problem.  Some of these are already
assigned.  Bug 123631 seems to be the best-documented, so I am putting
additional diagnostic info there.  Someone with the right permissions
should probably mark the others as duplicates as appropriate.

Note You need to log in before you can comment on or make changes to this bug.