Bug 123631 - Sounds doesn't work after upgrade FC1 > FC2 with AC97 audio
Sounds doesn't work after upgrade FC1 > FC2 with AC97 audio
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
: 122953 124125 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-05-19 14:55 EDT by Gregory Gulik
Modified: 2015-01-04 17:06 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 00:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
modprobe.conf from Knoppix 3.4 with the 2.6.5 kernel (6.97 KB, text/plain)
2004-05-26 12:54 EDT, Gregory Gulik
no flags Details
Report on sound system woes (7.30 KB, text/plain)
2004-06-08 02:43 EDT, Christopher Beland
no flags Details

  None (edit)
Description Gregory Gulik 2004-05-19 14:55:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
Sound worked perfectly on this system with Fedora Core 1.  The upgrade
to FC2 was done through CDs and appeared normal and other problems
thus far have been minimal and easy to fix.

After the upgrade sound appears to work but no sound ever comes out. 
I've tried it under Gnome, KDE as well as the command line.  I use a
TV tuner card to watch TV which routes the sound through the cards
line-in and that doesn't work either.

The sound device is:

00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

When I run system-config-sound it shows:
The following audio device was detected.
Vendor: VIA Technologies
Model: VT8233/A/8235/8237 AC97 Audio Controller
Module: snd-via82xx 

/etc/modules.conf contains the following relevant bits:
alias sound-slot-0 via82cxxx_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :

/etc/modprobe.conf contains the following bits:
alias snd-card-0 snd-via82xx
install sound-slot-0 /sbin/modprobe --first-time --ignore-install
sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time
--ignore-remove sound-slot-0 

The volume control app shows entries for both "Analog Devices AD1980
[Audio Mixer (OSS)]" as well as "VIA 8235 [Alsa Mixer]"

After a reboot almost all the volumes are very low. I turn them all up
and still no sound.

I've tried removing the audio card from /etc/sysconfig/hwconf and
forcing kudzu to re-configure it and still that didn't work.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot
2. Attempt to play something that causes a sound via any means you choose.

Actual Results:  No sound is produced.

Expected Results:  Expecting sound to come blasting out of my speakers.

Additional info:
Comment 1 Gregory Gulik 2004-05-19 15:51:44 EDT
I just noticed the following errors in /var/log/messages:
May 19 13:39:04 penguin modprobe: FATAL: Error running install command
for sound_slot_1
May 19 14:38:54 penguin modprobe: FATAL: Error running install command
for sound_slot_1

Not sure if that helps.
Comment 2 Brian Wheeler 2004-05-20 01:00:43 EDT
Same problem here except with i810 audio.  I removed the sound_slot_0
lines from both modules.conf and modprobe.conf

system-config-soundcard outputs:
Vendor: Intel Corp.
Model: 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
Module: snd-intel8x0

Manually installing the snd-intel8x0 module via modprobe works as
expected (I think -- I'm not at the machine at the moment, but
system-config-soundcard doesn't fail and prints out helpful information:
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
which seems like a success.)

Though neither modules.conf nor modprobe.conf were modified (don't
know if they should have been since the module was already loaded, but
I thought I'd mention it)

If it makes any difference, this is an FC1 -> FC2 upgrade.

Comment 3 Callum Wilson 2004-05-20 15:16:08 EDT
same here.  The sound worked fine in FC1, I reinstalled the system 
from scratch to FC2 and the soundcard appears to work but no sound 
comes out.  Like the first post above, I also have a BT878 video 
capture card with the sound jumper cable plugged into the line-in on 
the sound card. 
I have the VIA Technologies VT8233/A/8235/8237 AC97 Audio Controller.  
Soundcard detection sees it fine.  Note that an lspci -v reports 
"Unknown device 80a1" in the report. 
00:11.5 Multimedia audio controller: VIA Technologies, Inc. 
VT8233/A/8235/8237 AC97 Audio Controller (rev 50) 
        Subsystem: Asustek Computer, Inc.: Unknown device 80a1 
        Flags: medium devsel, IRQ 5 
        I/O ports at e000 
        Capabilities: [c0] Power Management version 2 
modprobe.conf has the following: 
alias eth0 via-rhine 
alias snd-card-0 snd-via82xx 
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx 
&& /usr/sbin/alsactl restore >/dev/null 2>&1 || : 
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 
|| : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx 
alias char-major-81 bttv 
alias usb-controller ehci-hcd 
alias usb-controller1 uhci-hcd 
uname -a: Linux animal 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004 
i686 athlon i386 GNU/Linux 
can't see any errors in /var/log/messages.  
Comment 4 Samuel Bérubé 2004-05-20 19:03:58 EDT
Seems to be the same bug here that i've already comment on bug
#122953, i have intel8x0 with AC97 also...
Comment 5 Gregory Gulik 2004-05-26 12:54:23 EDT
Created attachment 100597 [details]
modprobe.conf from Knoppix 3.4 with the 2.6.5 kernel

To make sure there wasn't a hardware problem I tried the Knoppix 3.4 live-cd
with the 2.6.5 kernel and sound works just fine there.	I will attach the
modprobe.conf that the Knoppix installation came up with for this system.
Comment 6 J Spells 2004-05-26 16:31:46 EDT
Same hardware as comment #3.

After GNOME desktop starts, I have no sound.  After running soundcard
detection, I can hear the test sound and then the sound works. 
Switching to KDE desktop, back to no sound and soundcard detection
does not work.

Back to GNOME, sound never works until after running soundcard
detection manually.
Comment 7 Harlan Harris 2004-05-30 13:51:57 EDT
For what it's worth, I've been watching this bug, but think I found
out it was something more trivial! I opened the audio mixer. There are
two tabs, one for OSS (Analog Devices AD1981B) and one for Alsa (Intel
82801DB-ICH4). For the OSS mixer, I get sound if I move up the "PCM-2"
levels. The main "volume" has no effect. For the Alsa mixer, I get
volume if I move up the "PCM" levels. AGain, the master levels have no

I hope this helps whomever is working on this bug... 

Comment 8 Callum Wilson 2004-06-06 04:54:20 EDT
I opened aumix and kmix but only had one pcm tab (VIA 8235).  have
tried moving all levels up.  I think the line-in also does not work.
(it did with FC1)
Comment 9 Christopher Beland 2004-06-08 02:22:52 EDT
Bug 122557, 122953, bug 123389, bug 123586, bug 123631, and bug 124497
all seem to be describing the same problem.  Some of these are already
assigned.  Bug 123631 seems to be the best-documented, so I am putting
additional diagnostic info there.  Someone with the right permissions
should probably mark the others as duplicates as appropriate.
Comment 10 Christopher Beland 2004-06-08 02:41:06 EDT
I did some systematic testing to try to define the scope of the
problem and give the developers more information to work with.  My
report includes pre-formatted output, so as not to make it unreadable,
I'm including it as an attachment.

Quick summary: I can mostly fix the problem by hitting the Master
Volume in OSS (not PCM), but some programs (like aplay and xmms) still
can't use ALSA.  OSS works fine everywhere after the fix, and esound
works but has heavy skipping.  At login time, I am getting the
modprobe error reported elsewhere, as well as various gconf and bonobo
errors which may or may not be related.  Using xmms with ALSA before
or after the fix hangs "ps" and forces an unclean reboot.  Some other
things I tried didn't help.

Comment 11 Christopher Beland 2004-06-08 02:43:56 EDT
Created attachment 100953 [details]
Report on sound system woes
Comment 12 Harlan Harris 2004-06-15 15:20:51 EDT
My comment #7 above only seems relevant for some applications, not
all. Most sounds fail to work for my system.

Is someone actually working on this collection of bugs? If not, I
suspect I will start using a Linux distribution other than Fedora.
Sound is not a trivial issue, and no one that I have seen has posted
any comments that would suggest work is underway.

Oh, and thanks to Christopher Beland for his work! I hope someone with
the necessary resources and skills can use his report!
Comment 13 Brent Fox 2004-06-17 14:51:27 EDT
*** Bug 122953 has been marked as a duplicate of this bug. ***
Comment 14 Brent Fox 2004-06-17 14:55:40 EDT
*** Bug 124125 has been marked as a duplicate of this bug. ***
Comment 15 Dawid Gajownik 2004-06-18 09:54:04 EDT
I had similar problem with my card (VIA VT8233A southbridge, Soltek
SL-75DRV5 motherboard, module snd-via82xx). Actually not only me, also
other people with that hardware. The card was detected correctly, but
there was no sound. After some (well, it took me few weeks :/ )
investigation I found in the file
funny option: ac97_quirk. I put in /etc/modprobe.conf line:

options snd-via82xx ac97_quirk=0

Yeah, after that I could hear the music once again :) Note that this
option applies to the snd-via82xx and snd-intel8x0 modules.

Well, I wonder now if this should be set up by kudzu or made a list of
broken devices in modules sources :/ If needed, I can attach the
output of lspci -vv

Hope that this will help someone...
PS Sorry for my English. If I have made stupid mistakes, please
correct me :)
Comment 16 Harlan Harris 2004-06-21 14:41:49 EDT
Ah. I don't have the kernel docs installed, but I added:

options snd-intel8x0 ac97_quirk=0

to /etc/modprobe.conf and rebooted, and now I (mostly) have sound.
Some really weird things still going on, though. For example, in the
Volume Control mixer (OSS tab), the main Volume has no effect, but PCM
works. Likewise, on the Alsa tab, the Master volume has no effect, but
both Headphone and PCM work. In one case, but not repeatably,
modifying volumes on the Alsa tab breaks sound completely until I go
back to the OSS tab and modify the volume there.

Clearly there are remaining problems, but this patch at least lets me
do the work I need to do! Thanks Dawid, and your English was great.
Comment 17 Dawid Gajownik 2004-06-21 15:49:37 EDT
Hi, that's me again :-)

Harlan, you can try other settings. In the documentation there is such
a text:

"ac97_quirk - AC'97 workaround for strange hardware (-1 = default)
              -1 = default, don't override
               0 = disable
               1 = use headphone control as master
               2 = swap headphone and master controls
               3 = for AD1985, turn on OMS bit and use headphone
               4 = for ALC65x, turn on the jack sense mode


    The ac97_quirk option is used to enable/override the workaround
    for specific devices.  Some hardware have swapped output pins
    between Master and Headphone, or Surround.  The driver provides
    the auto-detection of known problematic devices, but some might
    be unknown or wrongly detected.  In such a case, pass the proper
    value with this option."

I presume that number 1 or 2 will resolve your problem 8)
Comment 18 jwm hogenboom 2004-06-21 17:17:19 EDT
Additional Comment #18 from jwm hogenboom (jaguariuna1@msn.com) on
2004-06-21, 14:31
Same problems with Intel Corp. 82801DB (ICH4) AC'97 Audio Controller,
under FC2, old kernel 2.5 and new kernel 2.6.

Had no problem with FC1, and still have no problem with Knoppix 3.4....

Why not copy the Knoppix 3.4 parts, which make this soundcard work??
Comment 19 Matt Thompson 2004-06-22 18:49:58 EDT
Folks, I don't know if this is the bug to add to, but I actually have
this problem with an EMU10K1 (SB Live!) card.  I start up FC2 and no
sound in Gnome/XFce4.  This isn't AC'97, but the problem seems
identical to the above ones.
Comment 20 jwm hogenboom 2004-06-23 12:47:22 EDT
Additional Comment #20 From jwm hogenboom on 2004-06-23 09:36

For whatever it is worth!!!

I finally "solved" the problem on my box, by "irrationally, and 
illogically", switching to the KDE desktop, and accessing the volume 
control icon, under "root" -> right bottom icon on the screen.

I "turned on and up" ALL functions on this rather complex volume 
control.....After that there was sound, in KDE as well as GNOME. And 
it kept that way, seemingly forever.

How about them apples????  Hallelujah!!!
Comment 21 Gregory Gulik 2004-06-25 13:19:17 EDT
I don't know if this is a co-incidence but based on the suggestions to
try ac97_quirk a mentioned above I removed the SoundBlaster card I had
installed to have working sound.  I re-enabled the on-board sound in
the BIOS and rebooted into the latest 2.6.6-1.435 kernel.

I was shocked to find that sound no works!  I didn't even need to try
the ac97_quick settings.
Comment 22 Harm Verhagen 2004-07-05 18:34:20 EDT
I was having similar problems after upgrading from RH9 to FC2.
Sound didn't work after reboot untill I executed the application

Changing the following lines in /etc/modprobe.conf fixed the problem
for me.

I replaced:
install sound-slot-0 /sbin/modprobe --first-time --ignore-install
sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time
--ignore-remove sound-slot-0

install snd-ens1371 /sbin/modprobe --first-time --ignore-install
snd-ens1371  && /usr/sbin/alsactl restore >/dev/null 2>&1 || : 
remove snd-ens1371 {/usr/sbin/alsactl store >/dev/null 2>&1 || : ; } ;
/sbin/modprobe -r --first-time --ignore-remove snd-ens1371

Comment 23 Callum Wilson 2004-07-06 19:00:51 EDT
you'll be glad to know that the ac97_quirk=0 in the modprobe.conf file
worked for me.  however,  I had left the speakers up at full volume
and crikey, I'd forgotten how loud they were!

(VIA Technologies VT8233/A/8235/8237 AC97 Audio Controller)

thanks to all for investigating this.
Comment 24 J Hecker 2004-07-06 19:08:17 EDT
After installing FC2 on a machine with an SBLive Value card my digital
output no loger worked.  The Value card doesn't break out the SPDIF
signals to any of the 2.5mm jacks so I had to find which header pins
on the back of the card had the relevant SPDIF signals to make my
Gateway/Boston 4 channel speakers work.  Anyway, this setup has work
for years, including and up to FC1 and OSS.  FC2 found the soundcard
and there was no audio, in spite of playing with every mixer slider I
could find.  Eventually I found this page: 


I have uncommented the install and remove sound_slot_0 lines from
modprobe.conf and just inserted this line:

options snd-emu10k1 extin="0x0003" extout="0x1f0f"

This corresponds to a Live with Digital Out.

It works now and only the "Wave Surround" volume slider works to
control the volume (which is all I need in the kmix applet).   This
might be a dirty hack but it works flawlessly for SPDIF output.  I
don't have much time to muck with ALSA to get a more general solution

ALSA seems like a great sound API but it FC2 needs some work to make
it "just work" without having to finger the /etc/* entrails.

Comment 25 Bryan Berndt 2004-08-17 01:28:27 EDT
The following worked for me, on a NEW FC 2 install. My sound is a
built in chip, detected as "82801BA/BAM AC'97 Audio" on an Intel i815

 <i>Additional Comment #7 From Harlan Harris  on 2004-05-30 13:51 -------

For what it's worth, I've been watching this bug, but think I found
out it was something more trivial! I opened the audio mixer. There are
two tabs, one for OSS (Analog Devices AD1981B) and one for Alsa (Intel
82801DB-ICH4). For the OSS mixer, I get sound if I move up the "PCM-2"
levels. The main "volume" has no effect. For the Alsa mixer, I get
volume if I move up the "PCM" levels. AGain, the master levels have no

I hope this helps whomever is working on this bug... </i>

Comment 26 s 2004-08-28 22:08:06 EDT
In fc2 sound was working in kernel-smp-2.6.5-1.358, but when i
upgraded(+set grub default to 0+rebooted) to kernel-smp-2.6.8-1.521 my
sound no longer worked(no sound, test sound was instantly done when
attempted), i could go back to the old kernel from the boot menu and
the sound would work fine again.

laptop, toshiba, satellite A65-S1762
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97
Audio Controller
Comment 27 Dawid Gajownik 2004-09-09 06:29:23 EDT

If someone had resolved the problem with ac97_quirk option, (s)he
should report it to ALSA bugtracking system. I did it an my soundcard
works now out-of-the-box without any additional editing of
/etc/modprobe.conf :D 'lspci -nv' output is needed.

Comment 28 Dave Jones 2005-04-16 00:43:06 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.