Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 124497 - Sound does not work: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller.
Sound does not work: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 20:06 EDT by John Bunch
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Bunch 2004-05-26 20:06:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After selecting System Settings > Soundcard Detection, and clicking
"Play test sound," no sound is heard from either speaker.  Neither
does it work when visiting a web site that plays music.  The soundcard
previously worked with Fedora Core 1 and still works with Windows XP.
 The details from the Soundcard Detection utility are:
     Vendor:  Intel Corp.
     Model:  82801DB (ICH4) AC'97 Audio Controller
     Module:  snd-intel8x0


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
1.  Execute System Settings > Soundcard detection.
2.  Click "Play test sound."

    

Actual Results:  Nothing.

Expected Results:  Sounds should have been heard.

Additional info:
Comment 1 Jerry Stevers 2004-05-27 20:35:29 EDT
Same on a Dell Dimensions 2350
Comment 2 Jerry Stevers 2004-06-02 23:12:13 EDT
I installed Kernel 2.6.6 from source and it fixed this problem.
Comment 3 John Bunch 2004-06-05 14:38:32 EDT
I also installed kernel 2.6.6 from source, but the problem persisted
with exactly the same behavior.
Comment 4 Jerry Stevers 2004-06-05 22:25:31 EDT
Check your modprobe.conf file.  Below is mine.

modprobe.conf:

alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
Comment 5 John Bunch 2004-06-06 15:07:02 EDT
The soundcard portion of my modprobe.conf is identical to what you
posted, except for the line breaks (when posting files to bugzilla in
the future, please create an attachment to prevent this type of
confusion).  The only other things in my modprobe.conf are one line
for Ethernet and two lines for USB.
Comment 6 Christopher Beland 2004-06-08 02:22:23 EDT
Bug 122557, 122953, bug 123389, bug 123586, bug 123631, and bug 124497
all seem to be describing the same problem.  Some of these are already
assigned.  Bug 123631 seems to be the best-documented, so I am putting
additional diagnostic info there.  Someone with the right permissions
should probably mark the others as duplicates as appropriate.
Comment 7 Gabriel M. Elder 2004-07-20 18:10:15 EDT
Just some additional info which may or mayn't help everyone else.

Possible quick fix here, read further for details:

Once you've completed the install, log into GNOME as root, open up the
mixer. Check ALL the volume levels. If you have a "PCM-2" in the mixer
and it is zero, be sure to bring that one up. Now do a sound check.
This may fix it for you, especially if you are using the snd-intel8x0
driver module and the mixer/sound detection apps report the device as
being an Analog Devices AD1885. On these devices, the mixer appears to
be routing the main volume control under the heading of "PCM-2", which
is set to zero by default at install time (hence not hearing the test
sound, even though everything appears to be working properly). This
may or may not be the case for other devices that are handled.

Details here:

Over the course of a set of FC2 installs on a bunch of different
systems that i set up, there were a few that were having an almost
identical "no sound" problem. All of those motherboards, if i recall
correctly, were the on-board intel chipset, using the snd-intel8x0
driver module. The module was loading fine. I looked at various tweaks
or driver options, still no sound. Finally, after getting a little
frustrated, i did something that i probably should've done almost
right away: check the software volume controls in the mixer. After
playing with the volume controls, i discovered that the sound WAS
working, i just wasn't hearing it because the main volume control was
handled as "PCM-2" in the mixer, and that was zero by default... :&#254

This appears to be a bit of an annoying bug; i'd offer to fix the
underlying problem, but am not sure how to offhand (although i suspect
it's a bug in the audio mixer subsystem or app) and don't have time to
dig into it right now. Sorry, but i hope this all helped regardless.
Comment 8 John Bunch 2004-07-22 11:51:35 EDT
I ran alsamixer as root, but there is no "PCM-2" setting, even when I
scrolled all the way to the right.
Comment 9 Claude Walston 2004-08-03 16:36:43 EDT
I have an 82801BA/BAM AC'97 (as found on a moderately recent intel
mother board).
The "PCM-2" trick worked like a charm for me.

Thanks much!
Comment 10 Dave Jones 2005-04-16 00:50:57 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.