Bug 123389 - No audio at all
No audio at all
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-17 18:14 EDT by Sean Bruno
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 14:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Bruno 2004-05-17 18:14:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I updated my machine(clean install) from FC1 to FC2T3.  I fully
patched the machine and I have no audio.

The soundcard-detection applet detects an Intel 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller.

It appears to use module: snd-intel8x0

After playing around, I opened the mixer and found PCM2 set to the
lowest possible slider position.  I moved the slider to the mid-point
and I got audio again.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.3a-2

How reproducible:
Always

Steps to Reproduce:
1.  Run soundcard detection applet
2.  Play test sound
3.
    

Actual Results:  No audio detected due to initial configuration of
PCM2 to 0

Expected Results:  Standard audio playback.

Additional info:

/etc/modprobe.conf

alias eth0 e1000
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
Comment 1 Bill Nottingham 2004-05-24 16:32:38 EDT
Please try the final release.
Comment 2 Sean Bruno 2004-05-24 16:51:55 EDT
Yes.  It still is an issue in the release.  I have updated this to
reflect this information.
Comment 3 Allen Kistler 2004-06-05 22:15:21 EDT
I also see this bug on a clean FC2-final install.  My modprobe.conf is
identical to the op's.  However system-config-soundcard detects "Intel
82801DB (ICH4) AC'97 Audio Controller," which is how lspci -vv reports
it, too.  system-config-soundcard also says on stdout...

Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]

...although the real mixer control is PCM-2 on the OSS mixer tab,
labeled "Analog Devices AD1981B [Audio Mixer(OSS)," of
gnome-volume-control.  This slider is the only one which has any
effect.  In particular, the master volume slider has no effect.  None
of the sliders on the Alsa mixer tab, labeled "Intel 82801DB-ICH4
[Alsa Mixer],"  have any effect, either.

I haven't had any success at all with CD audio as a source. 
(Curiously the Alsa tab has two sets of CD sliders.  There's only one CD.)

Possibly related is this snippet from /var/log/messages:

bonobo-activation-server (root-2464): iid OAFIID:BrokenNoType:20000808
has a NULL type
bonobo-activation-server (root-2464): invalid character '#' in iid
'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
modprobe: FATAL: Error running install command for sound_slot_1 
modprobe: FATAL: Error running install command for sound_slot_1
Comment 4 Allen Kistler 2004-06-05 22:36:53 EDT
BTW: Bugs 123631 and 124497 appear to be duplicates of this one.
Comment 5 Allen Kistler 2004-06-06 14:52:51 EDT
Oops.  I lied.  The PCM slider on the Alsa mixer _does_ work.  The
masters still have no effect, though.
Comment 6 Bill Nottingham 2004-06-07 11:04:20 EDT
If the volume sliders in the alsa mixer aren't having an effect, that
sounds like an alsa driver bug.
Comment 7 Christopher Beland 2004-06-08 02:21:59 EDT
Bug 122557, 122953, bug 123389, bug 123586, bug 123631, and bug 124497
all seem to be describing the same problem.  Some of these are already
assigned.  Bug 123631 seems to be the best-documented, so I am putting
additional diagnostic info there.  Someone with the right permissions
should probably mark the others as duplicates as appropriate.
Comment 8 Allen Kistler 2004-06-24 14:27:02 EDT
Bug 123631 Comment #17 lists the options to snd-intel8x0.
options snd-intel8x0 ac97_quirk=2
appears to have solved most of my mixer-related problems.
There are still two sets of CD sliders on the Alsa mixer, despite
there being only one CD channel.  (At least there's only one CD
connector on the motherboard.)
Comment 9 Sean Bruno 2004-11-17 15:21:29 EST
I am moving this on to FC3.  

Just did a clean install of FC3 and I had zero audio during the "sound
card" detection portion of the firstboot.  When I logged in, I
adjusted the "Line" volume to resolve this issue.

Do we acutally want to fix this in the installer, or just put
something in a FAQ and close it?
Comment 10 Christopher Beland 2004-12-28 23:05:12 EST
I actually did a fresh install of FC3 on a different laptop (a
Toshiba) and got zero sound...though it turns out that was because
there's a volume control manifested as a physical knob on the outside
of the laptop that was set too low.  It would be nice, at the part of
the install when the sound is tested, to remind users to check any
hardware volume controls.  And perhaps show them the software volume
settings and allow them to turn up the volume (or to better detect
settings and do this automatically). -Beland
Comment 11 Joe Acosta 2005-04-23 20:08:56 EDT
I'm experienceing the same thing with the default kernel in FC3 

Just updated everything today using the default kernel-2.6.11-1.14_FC3.  My
sound is completely hozed thanks!

system-config-sound come up with:

amixer: Unable to find simple control 'Master',0

amixer: Unable to find simple control 'PCM',0

ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such
file or directory
aplay: main:508: audio open error: No such file or directory

I know my sound card is an SB Live and work with kernel 2.6.10, as I have
compiled a custom kernel and it works with my custom kernel but not 2.6.11 ( the
fc3 kernel, not a custom fc3 kernel[ I cound'nt get FC3 2.6.11 to compile, but
thats an issue I know you guys don't deal with ]).

lsmod shows 
snd_seq_midi            8545  0
snd_seq_oss            37057  0
snd_emu10k1_synth       8513  0
snd_emux_synth         42817  1 snd_emu10k1_synth
snd_seq_virmidi         6721  1 snd_emux_synth
snd_seq_midi_event      9025  3 snd_seq_midi,snd_seq_oss,snd_seq_virmidi
snd_seq_midi_emul       7233  1 snd_emux_synth
snd_seq                62033  8
snd_seq_midi,snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
snd_emu10k1           110149  6 snd_emu10k1_synth
snd_ac97_codec         71097  1 snd_emu10k1
snd_util_mem            4801  2 snd_emux_synth,snd_emu10k1
snd_hwdep               9185  2 snd_emux_synth,snd_emu10k1
snd_usb_audio          65153  6
snd_pcm_oss            51953  0
snd_mixer_oss          18241  7 snd_pcm_oss
snd_pcm                99657  4 snd_emu10k1,snd_ac97_codec,snd_usb_audio,snd_pcm_oss
snd_timer              33093  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc          9669  2 snd_emu10k1,snd_pcm
snd_usb_lib            13121  1 snd_usb_audio
snd_rawmidi            28641  4 snd_seq_midi,snd_seq_virmidi,snd_emu10k1,snd_usb_lib
snd_seq_device          8781  7
snd_seq_midi,snd_seq_oss,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
snd                    56741  24
snd_seq_oss,snd_emux_synth,snd_seq_virmidi,snd_seq,snd_emu10k1,snd_ac97_codec,snd_hwdep,snd_usb_audio,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device
soundcore              10785  7 snd


xmms does not play simple wave files and has an error message:

ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such
file or directory
ALSA lib pcm_hw.c:1155:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: No such
file or directory

and tells me to make sure my sound card is configured correctly?

mplayer and xine both have problems as well. However they play the sound. 
Rosegarden plays midi.

However all of these programs have one thing in common:  The sound is so low you
can barely hear it.    

Gnome mixer has all levels up as high as they can go, but still none play loud
enough to hear, unless your ear is next to the speakers.

I'm not sure why sound is so soundless.  All the modules look like they are right.

Guess I'm downgrading to 2.6.10 to get sound, but I'll test this out to see what
else it breaks. 





Comment 12 Dave Jones 2005-07-15 14:18:00 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 13 Sean Bruno 2005-07-15 14:20:48 EDT
I did not experience this issue with FC4.  This ticket can be closed.
Comment 14 Dave Jones 2005-07-15 14:53:53 EDT
thanks. as the FC3 & FC4 kernels are pretty much identical now, this should be
fixed in both.

Note You need to log in before you can comment on or make changes to this bug.