Bug 1250716 - Duplicate content view entries are shown in composite content view -> Add page
Duplicate content view entries are shown in composite content view -> Add page
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.2
: --
Assigned To: Walden Raines
sthirugn@redhat.com
Russell Dickenson
http://projects.theforeman.org/issues...
: Regression, ReleaseNotes, Triaged
: 1230430 1247621 (view as bug list)
Depends On:
Blocks: sat61-release-notes
  Show dependency treegraph
 
Reported: 2015-08-05 15:59 EDT by sthirugn@redhat.com
Modified: 2017-02-23 14:48 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Issue: If you navigate to Content -> Content View -> Create New View, enter a name for the view and check the Composite View? checkbox, you may find the list of content views contains duplicates. This issue is cosmetic only and does not affect the operation of views. Workaround: Navigate to another screen, then navigate to Content -> Content View the duplicates are no longer visible.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 03:22:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (97.27 KB, image/png)
2015-08-05 15:59 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11315 None None None 2016-04-22 11:09 EDT

  None (edit)
Description sthirugn@redhat.com 2015-08-05 15:59:09 EDT
Created attachment 1059625 [details]
Screenshot

Description of problem:
Duplicate content view entries are shown in composite content view -> Add page

Version-Release number of selected component (if applicable):
Sat 6.1 GA Snap 15

How reproducible:
Always

Steps to Reproduce:
1. Create a new composite content view using following steps:
2. Navigate to Content -> Content View -> Create New View
3. Enter Name, Check Composite View? checkbox
4. Click Save.  This brings the Content Views -> Add tab

Actual results:
Content views are duplicated in this page (see screenshot)

Expected results:
No duplicates in the content views

Additional info:
This happens only during the creation of composite content view.  It works fine after creation.
Comment 3 Walden Raines 2015-08-07 12:26:40 EDT
I cannot reproduce this in 6.1.1 given the steps in the description.  Please include additional necessary steps to reproduce.
Comment 4 Walden Raines 2015-08-07 12:32:44 EDT
(In reply to Walden Raines from comment #3)
> I cannot reproduce this in 6.1.1 given the steps in the description.  Please
> include additional necessary steps to reproduce.

Disregard.
Comment 5 Walden Raines 2015-08-07 12:58:57 EDT
Created redmine issue http://projects.theforeman.org/issues/11315 from this bug
Comment 6 Walden Raines 2015-08-10 10:03:52 EDT
Merged to master with:

commit 494068c7c9b18950df035b4844877115349c9f03
Author: Walden Raines <walden@redhat.com>
Date:   Fri Aug 7 13:40:19 2015 -0400

    Fixes #11315:  ensure CVs are only shown once BZ 1250716.
    
    In the composite content view list CVs were being shown multiple
    times because we were appending the results of a nutupane.refresh().
    This commit ensures the rows will be replaced with the results of the
    second call to nutupane.load().
    
    http://projects.theforeman.org/issues/11315
    https://bugzilla.redhat.com/show_bug.cgi?id=1250716
Comment 7 Christine Fouant 2015-08-24 11:46:10 EDT
*** Bug 1230430 has been marked as a duplicate of this bug. ***
Comment 8 Brad Buckingham 2015-08-24 15:56:12 EDT
*** Bug 1247621 has been marked as a duplicate of this bug. ***
Comment 15 sthirugn@redhat.com 2015-08-31 10:54:04 EDT
Verified in Sat 6.1.2 z-stream build.  I dont see duplicates anymore.
Comment 17 errata-xmlrpc 2015-09-15 03:22:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1786

Note You need to log in before you can comment on or make changes to this bug.