Bug 1230630 - MediaWiki fails with "requires the PSR-3 logging library to be present"
Summary: MediaWiki fails with "requires the PSR-3 logging library to be present"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mediawiki
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1231318 1231351 1231353 1231354 1231355 1231356 1264179 1264191 1264199 1264209 1264213
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-11 09:13 UTC by Tom Hughes
Modified: 2015-11-18 22:41 UTC (History)
6 users (show)

Fixed In Version: mediawiki-1.25.3-1.fc23 mediawiki-1.25.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-05 22:25:16 UTC


Attachments (Terms of Use)

Description Tom Hughes 2015-06-11 09:13:31 UTC
Description of problem:

After updating to the new mediawiki 1.25 package wiki sites are broken and just display a message:

"MediaWiki requires the PSR-3 logging library to be present. This library is not embedded directly in MediaWiki's git repository and must be installed separately by the end user. Please see mediawiki.org for help on installing the required components."

Installing php-PsrLog does not help.

Version-Release number of selected component (if applicable):

mediawiki-1.25.1-1.fc22.noarch

Comment 1 Michael Cronenworth 2015-06-12 15:45:00 UTC
1.25 requires a bunch of libraries.

http://www.mediawiki.org/wiki/Download_from_Git#Fetch_external_libraries

I will include need to create some new packages to remove this manual step.

Comment 2 Tom Hughes 2015-06-12 15:54:19 UTC
Except that the Fedora package is presumably built from a release tar ball, not from git?

Certainly that library appears to be in the rpm in /usr/share/mediawiki/vendor/psr along with various other vendored things - now that may well be a bundling violation that should be fixed, but it suggests something more complicated is going on...

In this case as I say it is already packaged separately as php-PsrLog but that doesn't seem to help.

Comment 3 Michael Cronenworth 2015-06-12 16:01:22 UTC
I am aware of the package source...

Yes, they are bundled, but they have always been bundled. Now they are localized in one place and a few new ones have been added (Psr).

Installing "php-PsrLog" doesn't help you due to the fact MediaWiki doesn't look for it in the global include_path.

Quick fix: ln -s /usr/share/mediawiki/vendor /foo/bar/wiki

Replace /foo/bar/wiki with your wiki root installation path.

Comment 4 Tom Hughes 2015-06-12 18:19:21 UTC
Thanks - I can confirm that fixes the problem.

Comment 5 Michael Cronenworth 2015-06-12 19:26:23 UTC
Package reviews created. If you can provide some reviews (or want to swap) that would be a big help. Thanks.

Comment 6 Lameire Alexis 2015-06-24 11:37:27 UTC
this package don't work. Until the review is done, you should consider repush the 1.24.2 and incress the epoch of your package.

I incress the severity as urgent.

Comment 7 Michael Cronenworth 2015-06-24 18:09:07 UTC
Lameire, please read comment 3.

I have created a 1.25 update that performs this workaround as the reviews are taking longer than expected.

https://admin.fedoraproject.org/updates/mediawiki-1.25.1-3.fc22

Comment 8 Fedora Update System 2015-10-22 04:48:17 UTC
mediawiki-1.25.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ec6d598d3d

Comment 9 Fedora Update System 2015-10-22 04:57:16 UTC
mediawiki-1.25.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-24fe8b66c9

Comment 10 Fedora Update System 2015-10-24 12:08:24 UTC
mediawiki-1.25.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mediawiki'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ec6d598d3d

Comment 11 Fedora Update System 2015-10-26 18:29:38 UTC
mediawiki-1.25.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mediawiki'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-24fe8b66c9

Comment 12 Fedora Update System 2015-11-05 22:25:08 UTC
mediawiki-1.25.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-11-05 23:25:04 UTC
mediawiki-1.25.3-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Frank Ch. Eigler 2015-11-18 22:36:32 UTC
On my installation, where the vendor/ tree is managed by compose.phar (since we also run semanticwiki etc.), the symlink trick from comment #3 doesn't work; nor does "php compose.phar update" in the wiki/ directory.

Comment 15 Michael Cronenworth 2015-11-18 22:41:37 UTC
If you're going to use your own vendor directory you need to regenerate the autoload.php file inside it.

The latest mediawiki update provides all the necessary dependencies, symlinks, and autoload.php file to not have any bundled libraries.


Note You need to log in before you can comment on or make changes to this bug.