Bug 1238791 - Fix build on Mac OS X, gfapi symbol versions
Summary: Fix build on Mac OS X, gfapi symbol versions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1229446 1238793 1238796 1238798 1238811 1249391 1254850
Blocks: 1238788
TreeView+ depends on / blocked
 
Reported: 2015-07-02 15:56 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 13:19 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1229446
Environment:
Last Closed: 2016-06-16 13:19:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2015-07-02 15:56:04 UTC
+++ This bug was initially created as a clone of Bug #1229446 +++

Description of problem:

broken symbol versions in libgfapi


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-06-08 15:18:02 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 20:58:48 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 22:02:24 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-09 10:43:54 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-18 14:09:56 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:23:55 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:31:50 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 1 Anand Avati 2015-07-02 18:11:58 UTC
REVIEW: http://review.gluster.org/11514 (build: Mac OS X build issues, gfapi symbol versions) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2015-07-04 16:59:26 UTC
COMMIT: http://review.gluster.org/11514 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit adcc9495f93db24f9bff08ea21eb86e8905b0f07
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Jul 2 12:12:53 2015 -0400

    build: Mac OS X build issues, gfapi symbol versions
    
    fix broken symbol versions
    
    Change-Id: I153b87d80895ddd4718d0a9e51b4c0712b178bd4
    BUG: 1238791
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11514
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Niels de Vos 2016-06-16 13:19:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.