Bug 1238796 - Fix build on Mac OS X, configure(.ac)
Summary: Fix build on Mac OS X, configure(.ac)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1229446 1238798 1238811 1249391 1254850
Blocks: 1238788 1238791 1238793
TreeView+ depends on / blocked
 
Reported: 2015-07-02 15:59 UTC by Kaleb KEITHLEY
Modified: 2016-06-16 13:19 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1229446
Environment:
Last Closed: 2016-06-16 13:19:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2015-07-02 15:59:43 UTC
+++ This bug was initially created as a clone of Bug #1229446 +++

Description of problem:

various and sundry build errors, some are applicable to other systems as well


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-06-08 15:18:02 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 20:58:48 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 22:02:24 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-09 10:43:54 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-18 14:09:56 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:23:55 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:31:50 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 1 Anand Avati 2015-07-02 18:20:07 UTC
REVIEW: http://review.gluster.org/11517 (build: Mac OS X build issues, configure.ac) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Anand Avati 2015-07-04 10:27:53 UTC
REVIEW: http://review.gluster.org/11517 (build: Mac OS X build issues, configure.ac) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Anand Avati 2015-07-06 21:20:52 UTC
COMMIT: http://review.gluster.org/11517 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 88a719648475a6bf8d83c69a3b63b3d8a9a338cb
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Jul 2 12:44:01 2015 -0400

    build: Mac OS X build issues, configure.ac
    
    Mac has sqlite3, but no sysconf pkgconfig
    
    Change-Id: I516613656ea3877c1a019438352b3ef8b62da1f5
    BUG: 1238796
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11517
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Niels de Vos 2016-06-16 13:19:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.