Bug 1249391 - Fix build on Mac OS X, booleans
Fix build on Mac OS X, booleans
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On: 1229446 1254850
Blocks: 1238788 1238791 1238793 1238796 1238798 1238811
  Show dependency treegraph
 
Reported: 2015-08-02 08:13 EDT by Kaleb KEITHLEY
Modified: 2016-06-16 09:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1229446
Environment:
Last Closed: 2016-06-16 09:28:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-08-02 08:13:44 EDT
+++ This bug was initially created as a clone of Bug #1229446 +++

Description of problem:

various and sundry build errors, some are applicable to other systems as well


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-06-08 15:18:02 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 20:58:48 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 22:02:24 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-09 10:43:54 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-18 14:09:56 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:23:55 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:31:50 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 1 Anand Avati 2015-08-02 08:17:24 EDT
REVIEW: http://review.gluster.org/11814 (build: export minimum symbols from xlators for correct resolution) posted (#17) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2015-08-02 08:28:22 EDT
REVIEW: http://review.gluster.org/11816 (build: Fix build on Mac OS X, boolean) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Anand Avati 2015-08-12 08:20:23 EDT
REVIEW: http://review.gluster.org/11816 (build: Fix build on Mac OS X, boolean) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Anand Avati 2015-08-14 15:19:15 EDT
REVIEW: http://review.gluster.org/11816 (build: Fix build on Mac OS X, boolean) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 5 Anand Avati 2015-08-18 21:12:49 EDT
REVIEW: http://review.gluster.org/11816 (build: Fix build on Mac OS X, boolean) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Anand Avati 2015-09-01 10:23:21 EDT
COMMIT: http://review.gluster.org/11816 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 8b7af53cb88ab75c0f15c89ce6867a9c6c8a4e67
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Sun Aug 2 08:25:45 2015 -0400

    build: Fix build on Mac OS X, boolean
    
    bool and true conflict with clang macros in clang on Mac OS X,
    possibly with newer (?) versions of clang on Linux
    
    Change-Id: Ia8c56ae68b4ebffb99b0684ac72d68ec50eaa7fa
    BUG: 1249391
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11816
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Susant Palai <spalai@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:28:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.