Bug 1254850 - Fix build on Mac OS X, glfs_h_lookupat symbol version
Fix build on Mac OS X, glfs_h_lookupat symbol version
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
Sudhir D
: Reopened, Triaged
Depends On: 1229446
Blocks: 1238788 1238791 1238793 1238796 1238798 1238811 1249391
  Show dependency treegraph
 
Reported: 2015-08-19 01:08 EDT by Kaleb KEITHLEY
Modified: 2016-06-16 09:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1229446
Environment:
Last Closed: 2016-06-16 09:32:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-08-19 01:08:18 EDT
+++ This bug was initially created as a clone of Bug #1229446 +++

Description of problem:

various and sundry build errors, some are applicable to other systems as well


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-06-08 15:18:02 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 20:58:48 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-08 22:02:24 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-09 10:43:54 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for multiple Mac OS X build issues) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Anand Avati on 2015-06-18 14:09:56 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:23:55 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Anand Avati on 2015-06-24 22:31:50 EDT ---

REVIEW: http://review.gluster.org/11130 (build: omnibus patch for Mac OS X build issues) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 1 Anand Avati 2015-08-19 01:25:49 EDT
REVIEW: http://review.gluster.org/11954 (build: fix build on Mac OS X, gfapi symbol versions) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2015-08-20 00:25:37 EDT
REVIEW: http://review.gluster.org/11954 (build: fix build on Mac OS X, gfapi symbol versions) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Anand Avati 2015-08-25 00:15:29 EDT
REVIEW: http://review.gluster.org/11954 (build: fix build on Mac OS X, gfapi symbol versions) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Vijay Bellur 2015-09-09 06:15:30 EDT
COMMIT: http://review.gluster.org/11954 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 4cd4a97e8410f0888c6b154a40279c143dc9f549
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 19 01:23:23 2015 -0400

    build: fix build on Mac OS X, gfapi symbol versions
    
    symbol versions for the handle apis are incorrect in glfs-handles.h
    
    Change-Id: I9f239a4e427ea236a6a837a7c7acc980da10ca79
    BUG: 1254850
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11954
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:32:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.