This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 124650 - Seg fault and/or no connection
Seg fault and/or no connection
Status: CLOSED DUPLICATE of bug 140567
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
: 125629 133283 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 04:01 EDT by John Morris
Modified: 2013-04-02 00:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Changes to gftpui.c to cover over segfault (1.77 KB, patch)
2004-09-05 00:15 EDT, Erich Hoover
no flags Details | Diff

  None (edit)
Description John Morris 2004-05-28 04:01:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
First couple of runs gftp wouldn't connect.  Tried several sites,
including one that I opened in Moz via ftp.  Third try it connected
and allowed me to browse directories and select a file.  When I
clicked the button to download it threw a segmentation fault.

Site being accessed when it segfaulted was updates.redhat.com. 
Repeated attempts produce reliable segfaults.  Assuming it has to be
x86_64 specific or it would be reported by now?

Version-Release number of selected component (if applicable):
gftp-2.0.17-2

How reproducible:
Always

Steps to Reproduce:
1.  Launch gftp, pick updates.redhat.com
2.  If it will connect, try to download something.
3.  Boom.
    

Additional info:
Comment 1 Warren Togami 2004-08-17 20:39:32 EDT
*** Bug 125629 has been marked as a duplicate of this bug. ***
Comment 2 Warren Togami 2004-08-17 20:40:02 EDT
We cannot possibly do anything without a backtrace.  You must install
the matching debuginfo RPM, and get a backtrace with gdb.
Comment 3 Erich Hoover 2004-09-01 22:57:39 EDT
I'm also having this problem (FC3T1 x86-64 gftp-2.0.17-3), I
downloaded the source RPM, compiled, installed and got the backtrace
(past 3 all the trace data is unknown so it is left off):

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1084225888 (LWP 9495)]
0x0000000000439203 in gftpui_common_transfer_files (tdata=0x7f)
    at gftpui.c:1318
1318                  tdata->tot_file_trans = gftp_transfer_file
(tdata->fromreq,
(gdb) bt
#0  0x0000000000439203 in gftpui_common_transfer_files (tdata=0x7f)
    at gftpui.c:1318
#1  0x000000000041dd29 in _gftpui_transfer_files (data=0x786e40)
    at transfer.c:607
#2  0x0000003df7705d74 in start_thread () from /lib64/tls/libpthread.so.0
#3  0x0000003df6ac2893 in thread_start () from /lib64/tls/libc.so.6
Comment 4 Erich Hoover 2004-09-05 00:15:26 EDT
Created attachment 103472 [details]
Changes to gftpui.c to cover over segfault

I needed to get gftp working to get some things done so I dug in a little and
covered over the problem (please note: this patch does not fix the problem, it
covers it up).	For some reason the gftp_transfer_file function is corrupting
the tdata variable and any long stored with the same pointer value, this covers
over the problem by storing the pointer value + 1 and retrieving it after
gftp_transfer_file exists (there's also a minimal return check on
gftp_transfer_file).
Comment 5 Warren Togami 2004-09-22 20:45:43 EDT
*** Bug 133283 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2004-09-22 20:47:06 EDT
I do not feel comfortable about accepting a patch that admittedly does
not solve the actual problem.  Please try to find a real solution. 
Ask for help on fedora-devel-list.  It would help if you could have
someone from gftp upstream OK the patch.
Comment 7 Warren Togami 2004-12-29 23:23:01 EST

*** This bug has been marked as a duplicate of 140567 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:03:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.