Bug 1251816 - [abrt] kf5-kinit: KNotification::flags() const(): kdeinit5 killed by SIGSEGV This was from konsole5. I was working in konsole.
[abrt] kf5-kinit: KNotification::flags() const(): kdeinit5 killed by SIGSEGV ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kf5-knotifications (Show other bugs)
22
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:2509d8f6d189a75060034bc7d2b...
: Patch, Triaged
: 1235791 1249479 1255236 1257189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-10 00:13 EDT by Robin Laing
Modified: 2015-11-01 20:39 EST (History)
11 users (show)

See Also:
Fixed In Version: kf5-knotifications-5.12.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-19 04:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (88.44 KB, text/plain)
2015-08-10 00:13 EDT, Robin Laing
no flags Details
File: cgroup (177 bytes, text/plain)
2015-08-10 00:13 EDT, Robin Laing
no flags Details
File: core_backtrace (9.79 KB, text/plain)
2015-08-10 00:13 EDT, Robin Laing
no flags Details
File: dso_list (20.76 KB, text/plain)
2015-08-10 00:13 EDT, Robin Laing
no flags Details
File: environ (9.25 KB, text/plain)
2015-08-10 00:13 EDT, Robin Laing
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details
File: maps (63.06 KB, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details
File: mountinfo (3.36 KB, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details
File: open_fds (5.66 KB, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details
File: proc_pid_status (880 bytes, text/plain)
2015-08-10 00:14 EDT, Robin Laing
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 348414 None None None Never

  None (edit)
Description Robin Laing 2015-08-10 00:13:53 EDT
Description of problem:
While moving files and sorting out archived data, the konsole5 crashed.  this is a very normal procedure and happens 10 or 20 times a day.

All crashes seem to be related to tab completion and possibly bell from the terminal.

It may run for 30 minutes between crashes or 1 minute.

Version-Release number of selected component:
kf5-kinit-5.12.0-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        'konsole [kdeinit5] --workdir /home/development'
crash_function: KNotification::flags() const
executable:     /usr/bin/kdeinit5
global_pid:     15340
kernel:         4.1.3-200.fc22.i686+PAE
runlevel:       N 5
type:           CCpp
uid:            1001
Comment 1 Robin Laing 2015-08-10 00:13:56 EDT
Created attachment 1060928 [details]
File: backtrace
Comment 2 Robin Laing 2015-08-10 00:13:57 EDT
Created attachment 1060929 [details]
File: cgroup
Comment 3 Robin Laing 2015-08-10 00:13:58 EDT
Created attachment 1060930 [details]
File: core_backtrace
Comment 4 Robin Laing 2015-08-10 00:13:58 EDT
Created attachment 1060931 [details]
File: dso_list
Comment 5 Robin Laing 2015-08-10 00:13:59 EDT
Created attachment 1060932 [details]
File: environ
Comment 6 Robin Laing 2015-08-10 00:14:00 EDT
Created attachment 1060933 [details]
File: limits
Comment 7 Robin Laing 2015-08-10 00:14:01 EDT
Created attachment 1060934 [details]
File: maps
Comment 8 Robin Laing 2015-08-10 00:14:02 EDT
Created attachment 1060935 [details]
File: mountinfo
Comment 9 Robin Laing 2015-08-10 00:14:03 EDT
Created attachment 1060936 [details]
File: namespaces
Comment 10 Robin Laing 2015-08-10 00:14:04 EDT
Created attachment 1060937 [details]
File: open_fds
Comment 11 Robin Laing 2015-08-10 00:14:05 EDT
Created attachment 1060938 [details]
File: proc_pid_status
Comment 12 Robin Laing 2015-08-10 01:04:44 EDT
FWIW, this is a constant issue.  I have submitted a bug report against Konsole5 which is the application that I am using when this crash report is created.

bug 1249479

This is at least the third crash tonight.  Must have been 10 yesterday.
Comment 13 Rex Dieter 2015-08-10 08:10:11 EDT
The problem seems to be down in kf5-knotification/phonon:


Thread 1 (Thread 0xb4565780 (LWP 15340)):
#0  0xffffffff in KNotification::flags() const (this=this@entry=0x0) at ../../src/knotification.cpp:233
#1  0xffffffff in NotifyByAudio::onAudioFinished() (this=this@entry=0x832af80) at ../../src/notifybyaudio.cpp:141
        m = 0x8445778
#2  0xffffffff in NotifyByAudio::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=0x832af80, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfffe0a8) at moc_notifybyaudio.cpp:82
        _t = 0x832af80
#3  0xffffffff in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x8445778, signalOffset=3, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3717
        receiverInSameThread = <optimized out>
        sw = {receiver = 0x832af80, previousSender = 0x0, currentSender = {sender = 0x8445778, signal = 9, ref = 1}, switched = true}
        callFunction = 0xb379f3e0 <NotifyByAudio::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>
        receiver = 0x832af80
        method_relative = <optimized out>
        c = <optimized out>
        locker = <optimized out>
        connectionLists = {connectionLists = 0x8472eb0}
        list = <optimized out>
        signal_index = <optimized out>
        empty_argv = {0x0}
        currentThreadId = <optimized out>
#4  0xffffffff in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x8445778, m=m@entry=0xb32833dc <Phonon::MediaObject::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x0) at kernel/qobject.cpp:3582
#5  0xffffffff in Phonon::MediaObject::finished() (this=this@entry=0x8445778) at /usr/src/debug/phonon-4.8.3/i686-redhat-linux-gnu-Qt5/phonon/moc_mediaobject.cpp:421
#6  0xffffffff in Phonon::MediaObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=0x8445778, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x8945f08) at /usr/src/debug/phonon-4.8.3/i686-redhat-linux-gnu-Qt5/phonon/moc_mediaobject.cpp:182
Comment 14 Rex Dieter 2015-08-10 08:15:04 EDT
May be related to
https://bugs.kde.org/show_bug.cgi?id=348414
Comment 15 Rex Dieter 2015-08-10 08:37:18 EDT
*** Bug 1249479 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2015-08-10 09:53:30 EDT
kf5-knotifications-5.12.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kf5-knotifications-5.12.0-2.fc22
Comment 17 Fedora Update System 2015-08-10 22:13:08 EDT
Package kf5-knotifications-5.12.0-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kf5-knotifications-5.12.0-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13175/kf5-knotifications-5.12.0-2.fc22
then log in and leave karma (feedback).
Comment 18 Rex Dieter 2015-08-15 13:20:27 EDT
*** Bug 1235791 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2015-08-19 04:27:50 EDT
kf5-knotifications-5.12.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Robin Laing 2015-08-19 23:39:28 EDT
Just a follow up.  I have tried and I have not had any issues with the pending release.
Comment 21 Rex Dieter 2015-08-20 07:59:58 EDT
*** Bug 1255236 has been marked as a duplicate of this bug. ***
Comment 22 Rex Dieter 2015-08-26 08:58:15 EDT
*** Bug 1257189 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.