This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 125349 - redhat-config-soundcard crash when launched. two soundcards
redhat-config-soundcard crash when launched. two soundcards
Status: CLOSED DUPLICATE of bug 81843
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
: 129225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 19:01 EDT by Andy Pengelly
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/hwconf (5.77 KB, text/plain)
2004-07-26 08:18 EDT, Andy Pengelly
no flags Details
simple workaround (559 bytes, patch)
2004-08-05 09:18 EDT, Olivier Andrieu
no flags Details | Diff

  None (edit)
Description Andy Pengelly 2004-06-04 19:01:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have upgraded from FC1 to FC2.  I have two sound cards installed. 
Both sound cards worked OK under FC1.  When I try to run
system-config-soundcard it crashes, as shown below.  I think it is a
re-occurance of bug 115198, but I couldn't re-open that bug.  I hope
the following is useful:

[root@localhost root]# rpm -q system-config-soundcard
system-config-soundcard-1.2.8-1
[root@localhost root]# cat /etc/modules.conf | grep sound
alias sound-slot-0 cmpci
alias sound-slot-1 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
[root@localhost root]# lspci | grep audio
00:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 0a)
02:04.0 Multimedia audio controller: C-Media Electronics Inc CM8738
(rev 10)
[root@localhost root]# system-config-soundcard
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 160, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list
[root@localhost root]#


Version-Release number of selected component (if applicable):
1.2.8-1

How reproducible:
Always

Steps to Reproduce:
1.Become root
2.Run system-config-soundcard
3.
    

Actual Results:  system-config-soundcard failed with ValueError

Expected Results:  I should have been able to configure one or both of
the soundcards.

Additional info:
Comment 1 Bastien Nocera 2004-07-21 12:57:47 EDT
Could you please attach your /etc/sysconfig/hwconf?
Comment 2 Andy Pengelly 2004-07-26 08:18:25 EDT
Created attachment 102200 [details]
/etc/sysconfig/hwconf

hwconf as requested.
Comment 3 Olivier Andrieu 2004-08-05 09:18:01 EDT
Created attachment 102446 [details]
simple workaround

Same symptoms for me (two soundcards)
Comment 4 Bill Nottingham 2004-09-17 17:49:15 EDT
Please test with 1.2.9-1.
Comment 5 Bill Nottingham 2004-09-17 17:49:31 EDT
*** Bug 129225 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2004-09-19 09:17:58 EDT

*** This bug has been marked as a duplicate of 81843 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:03:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.