This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1256739 - Detached volume loses its sparseness after Cinder side migration between different NetApp shares
Detached volume loses its sparseness after Cinder side migration between diff...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
unspecified Severity unspecified
: z5
: 5.0 (RHEL 7)
Assigned To: Eric Harney
lkuchlan
: ZStream
Depends On:
Blocks: 1256740 1256744 1256745
  Show dependency treegraph
 
Reported: 2015-08-25 07:14 EDT by Sergey Gotliv
Modified: 2016-08-29 11:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1.4-7.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1256740 1256744 (view as bug list)
Environment:
Last Closed: 2015-09-10 07:48:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Gotliv 2015-08-25 07:14:16 EDT
How reproducible:
100%

Steps to Reproduce:
1. Create a 1GB volume on the NetApp from the cirros image
2. Check that the volume size on the disk is around 20MB
3. Migrate that volume to another NetApp share
4. Check size again

Expected result:

The volume should remain the same size

Actual results:

The size is changed to 1GB which means the volume
lost the sparseness.

Additional info:

We have to backport the following patches to 5.0:

https://review.openstack.org/#/c/182473/
https://review.openstack.org/#/c/183633/
Comment 4 lkuchlan 2015-09-03 03:53:51 EDT
Tested using:
openstack-cinder-2014.1.5-1.el7ost.noarch
python-cinderclient-1.0.9-1.el7ost.noarch
python-cinder-2014.1.5-1.el7ost.noarch

Verification instructions:
1. Create a 1GB volume on the NetApp from the cirros image
2. Check that the volume size on the disk is around 20MB
3. Migrate that volume to another NetApp share
4. Check size again
Comment 7 errata-xmlrpc 2015-09-10 07:48:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1758.html

Note You need to log in before you can comment on or make changes to this bug.