Bug 125917 - (AnacondaProxy) RFE: Proxy support for http/ftp
RFE: Proxy support for http/ftp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
: 461471 479452 505118 (view as bug list)
Depends On:
Blocks: 141988 FC7Target 501496
  Show dependency treegraph
 
Reported: 2004-06-13 20:26 EDT by Ed K
Modified: 2010-07-01 16:56 EDT (History)
19 users (show)

See Also:
Fixed In Version: anaconda-13.0-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 501496 (view as bug list)
Environment:
Last Closed: 2010-07-01 16:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed K 2004-06-13 20:26:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Add proxy server support for installer

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Never propted for proxy ip/port

Additional info:

Has anyone thought about using a proxy server for installations?
Caching proxy servers could offer a lot of benefit for administrators.
Gaining the speed of a local repository without the difficulty of
setting one up.
Comment 1 Jeremy Katz 2004-06-14 12:11:35 EDT
A large chunk of it is someone writing the code, especially for the
loader (first stage) of the install process.
Comment 2 Donny Collins 2004-08-28 18:43:49 EDT
Can't some code be taken from another distribution? It's implemented
almost everywhere. There are many people in company/university
networks that have no direct acces to the internet, so it would be
nice if this worked in core3.
Comment 3 Chris Lumens 2005-02-03 14:52:16 EST
urlgrabber has support for HTTP and FTP proxies, which makes things on the
second stage a lot more simple, though that doesn't buy us anything in the loader.
Comment 4 Dave 2006-05-16 11:33:47 EDT
I've seen the option in Mandriva... it's a real shame we don't have this
functionality in Fedora.

Any news or movement on this RFE?
Comment 5 Stephan Dühr 2006-10-04 12:17:25 EDT
It already was there in RHL 6.0:
http://www.redhat.com/docs/manuals/linux/RHL-6.0-Manual/install-guide/doc046.html
Comment 6 Thorsten Leemhuis 2006-10-09 02:10:32 EDT
+1 for proxy support

I just hit a bug while installing rawhide via internet: I'm in a network
currently where ftp traffice is routed directly to the internet, but http
traffic is only allowed via proxy. So I tried to install rawhide via ftp. That
worked in general -- but then I activated "Fedora Extras" in the package
selection screen. It seems anaconda then tried to connect to a http server,
naturally failed, and forced me to re-start the installation process. :-(
Comment 7 Mark Heslep 2006-10-24 16:41:49 EDT
I tried a light kickstart file with simply:
-------------------------
%pre
http_proxy="http://myproxy:80"
export http_proxy
-----------------------

that I place on a local install server, intending that to get me extras. Problem
with this seems to be that Anaconda skips the additional repo section of the
installer when it detects kickstart.
Comment 8 Mark Heslep 2006-10-24 17:31:53 EDT
I tried a light kickstart file with simply:
-------------------------
%pre
http_proxy="http://myproxy:80"
export http_proxy
-----------------------

that I place on a local install server, intending that to get me extras. Problem
with this seems to be that Anaconda skips the additional repo section of the
installer when it detects kickstart.
Comment 9 Mark Heslep 2006-10-24 18:46:06 EDT
scratch the kickstart approach. It appears the environment variable does not get
picked up by anaconda; I suppose its too late w/ as Anaconda is already running.
Comment 10 Mark Heslep 2006-11-01 13:15:31 EST
See the quick Anaconda proxy patch over here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213109
Comment 14 Mark Heslep 2007-12-11 17:22:40 EST
Suggest marking this as a duplicate of 14988 "anaconda should query for proxy"
https://bugzilla.redhat.com/show_bug.cgi?id=141988
Comment 16 Jon Stanley 2008-04-23 16:29:08 EDT
Adding FutureFeature keyword to RFE's.
Comment 17 David Cantrell 2008-10-27 15:56:44 EDT
*** Bug 461471 has been marked as a duplicate of this bug. ***
Comment 18 David Cantrell 2009-01-19 13:52:07 EST
*** Bug 479452 has been marked as a duplicate of this bug. ***
Comment 19 Andy Lindeberg 2009-08-04 15:32:00 EDT
*** Bug 505118 has been marked as a duplicate of this bug. ***
Comment 20 Steve Schaeffer 2009-08-30 10:54:06 EDT
(In reply to comment #5)
> It already was there in RHL 6.0:
> http://www.redhat.com/docs/manuals/linux/RHL-6.0-Manual/install-guide/doc046.html
>   

This feature existed in F10 and prior, AFAIK, albeit one had to wait until the initial connection attempt timed out before being offered a chance to enter proxy information.

I found that attempting to use the Network Install CD with F11 is futile when behind a proxy server.

Please restore the F10 capability and provide a way to enter the proxy information before attempting connection to the repositories.
Comment 21 Chris Lumens 2009-09-30 13:31:56 EDT
This should finally (finally!) be fixed in the next build of anaconda for F13.  It won't be fixed in F12, and probably has a couple other bugs as well, but as soon as we start doing rawhide composes pulling from F13, it should be testable.

Note You need to log in before you can comment on or make changes to this bug.