This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 141988 - anaconda should query for proxy
anaconda should query for proxy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: FutureFeature, Reopened
: 324801 (view as bug list)
Depends On: AnacondaProxy
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2004-12-06 11:29 EST by Florian Effenberger
Modified: 2011-11-10 14:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 11:40:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian Effenberger 2004-12-06 11:29:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5)
Gecko/20041108 Firefox/1.0

Description of problem:
anaconda should query for proxy. If one is set, it could create the
file /etc/profile.d/proxy.sh with the following contents:

 #!/bin/bash
 declare -x ftp_proxy="http://proxy.domain:Port"
 declare -x http_proxy="http://proxy.domain:Port"
 declare -x https_proxy="http://proxy.domain:Port"

(or alternatively, something via /etc/sysconfig)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:
Comment 1 Chris Lumens 2005-04-19 15:19:33 EDT
The desktop has a network proxy configuration tool to set these things.
Comment 2 Nils Philippsen 2007-01-08 08:42:39 EST
I've reopened that bug because there is discussion about getting anaconda
proxy-enabled (and thus asking for the proxy servers/passwords/etc.) in bug
#125917. Once that is resolved, anaconda should set the GConf system defaults
(keys beneath /system/proxy) from the proxy information it already got from the
user. Bonus points for {http,https,ftp}_proxy environment variables being set
for "legacy" aka command line applications.

Having to provide this information twice or (even worse) more (if every user has
to configure this) is just nonsense.
Comment 3 Chris Lumens 2007-10-09 09:52:38 EDT
*** Bug 324801 has been marked as a duplicate of this bug. ***
Comment 4 Mark Heslep 2007-11-30 16:59:25 EST
Any progress or more consideration of this?  Currently additional repos can not
be  accessed behind network proxies, ruling out the especially nice ability to
catch the huge number of updates at install time.  I submitted an anaconda
updates patch (some related bug report, cant find it) a release or two ago -
only required a few lines of python to to at least take a proxy string from a
command line key.  The patch of course is broken now w/ current anaconda releases.
Comment 5 Mark Heslep 2007-12-03 14:29:58 EST
Ping?
Comment 6 Florian Effenberger 2007-12-03 14:38:10 EST
Have not tested so far, don't run Fedora at the moment
Comment 7 Chris Lumens 2007-12-03 14:48:39 EST
This is something I am looking at adding support for as part of the rework of
install method code for F9.  Currently it looks like we will be able to support
proxies for downloading packages, but probably not for grabbing the stage2
image.  If you are booting off a CD and installing from a website, this will
work just fine for you.
Comment 8 Mark Heslep 2007-12-03 16:27:42 EST
That makes sense and yes it would work for me.  My particular case is a PXE grab
of stage 1 & 2 inside the firewall and then of course the want to pull the
updates through the proxy at install time.  I vainly imagine that many of the
enterprise folks would have similar setups.

I note though that this bug, or at least its ancestors, is circa F6. Must it
wait for F9? 
Comment 9 Mark Heslep 2007-12-10 15:47:17 EST
Anyone care to comment on their favorite work around du jour for proxy support,
in lieu of the fix?
Comment 10 Mark Heslep 2007-12-10 15:55:52 EST
Also, recommend
https://bugzilla.redhat.com/show_bug.cgi?id=125917 assigned to David Cantrell
and
https://bugzilla.redhat.com/show_bug.cgi?id=213109  assigned to Peter Jones
which are all filed against Anaconda be combined with this report. Who is the
real honcho on Anaconda these days?
Comment 11 Mark Heslep 2007-12-10 16:23:07 EST
Also, recommend
https://bugzilla.redhat.com/show_bug.cgi?id=125917 assigned to David Cantrell
and
https://bugzilla.redhat.com/show_bug.cgi?id=213109  assigned to Peter Jones
which are all filed against Anaconda be combined with this report. Who is the
real honcho on Anaconda these days?
Comment 12 Chris Lumens 2007-12-10 16:27:10 EST
We don't issue anaconda updates for released versions of Fedora, so it will have
to wait to make its official appearance in F9.  That doesn't mean work will
start post-F9, but that it will be in rawhide in the lead up to F9.  I've been
thinking about how to do this from a UI perspective, since it appears to be
pretty simple to enable in the backend.  Hopefully I will have something working
fairly soon.
Comment 13 Chris Lumens 2008-02-08 16:07:30 EST
There's now code to do this in F9 Alpha, at least in the graphical installer. 
You won't be able to get the stage2 image via proxy, but once you get into
selecting your packages you can modify the base repo and set up a proxy.  Can
someone please give this a test and see how well it works for them?  Thanks.
Comment 14 Jeffrey C. Ollie 2008-02-28 12:48:28 EST
What's the reason that the stage2 image can't be downloaded via the proxy?  Is
it just a matter of 'round tuits' or is there something else getting in the way?
Comment 15 Chris Lumens 2008-02-28 17:48:41 EST
There's no code in the loader for handling HTTP proxies.  It could certainly be
added by someone with sufficient motivation, knowledge of HTTP, and free time
though.  I don't think it should be too terribly difficult.
Comment 16 Jon Stanley 2008-05-10 01:27:20 EDT
Adding to F10Target for stage2 retrieval via proxy.

Reporter - note, however. that the new boot.iso/netinst.iso contains stage2 on
them, so the need for this is lessened - the only boot method by which you don't
get stage2 for free is via PXE now (admittedly probably the environment in which
this would be most valuable).
Comment 17 Chris Lumens 2008-05-13 14:15:45 EDT
The likelihood of adding support for grabbing the stage2 image through a proxy
is pretty small unless we can find a nice lightweight library for fetching files
from a URL that also supports proxies.  I don't think anyone in anaconda land
has time for F10 to come up with proxy code on their own.

Of course, patches to anaconda-devel-list are always welcome too.
Comment 18 Mark Heslep 2008-05-13 15:05:24 EDT
My hope for adding this proxy capability was to get access to updates and other
repos out on the net _in_ stage 2 package installs.  That capability is still
not available in Fedora 9 which I have just loaded. The proxy seems to only give
access to stage images.
Comment 19 Chris Lumens 2008-05-29 18:20:26 EDT
In F9, you can select the base repo and enable a proxy on it.  The way this
works is as follows:

- On the task selection screen (the screen that lets you pick
Office/Server/Etc.) you should see a list of repos at the bottom.  One is
checked by default, and this one can't be unchecked.  It's the one you set up
when you answered the installation method question in the loader.  Highlight
that one and click "edit".
- The bottom half of the edit dialog has a proxy checkbox and then some entry
fields.  Check the box, fill it in, and click OK.

This should then mean that we'll use a proxy for fetching all files (including
the packages, which is the biggest part) from that repository.  Does this not work?

The screen in the loader really just needs to die, and probably will this time
around.
Comment 20 dfinken 2009-10-12 06:16:16 EDT
Hello

Fedora-11-i386-netinst.iso
anaconda 11.5.0.59

It would be better to ask for the proxy settings after the network settings.
Now we only get the Proxy settings mask/window if we disable DHCP and enter only a IP address and leave the Gateway and DNS empty.

I only come to select the packeges to be installed, but after that I get "Versuche Download erneut ..." and nothing happens.

A cancel button is missing too.
Comment 21 Felipe Contreras 2011-11-10 14:08:44 EST
Please reopen this, it is not working.

On Fedora 16, after being asked about the network connection, the NetworkManager dialog hangs for minutes, after a while, I get a notification that the repotree wasn't being found (of course, the proxy hasn't been configured).

The proxy has to be configured *before* any network checks, otherwise it's useless.
Comment 22 Chris Lumens 2011-11-10 14:12:37 EST
Please open a new bug describing your new problem.
Comment 23 Felipe Contreras 2011-11-10 14:54:08 EST
(In reply to comment #22)
> Please open a new bug describing your new problem.

Ok. Bug #752940.

Note You need to log in before you can comment on or make changes to this bug.