Bug 1259443 (brw_meta_fast_clear) - Add brw_meta_fast_clear crash workaround patch
Summary: Add brw_meta_fast_clear crash workaround patch
Keywords:
Status: CLOSED NEXTRELEASE
Alias: brw_meta_fast_clear
Product: Fedora
Classification: Fedora
Component: mesa
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1243741 1260382 1260395 1296632 1299310 1299598 1310211 1310405 (view as bug list)
Depends On:
Blocks: F23BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-09-02 15:33 UTC by Sandro Mani
Modified: 2016-07-12 16:16 UTC (History)
30 users (show)

Fixed In Version: 11.0.0-0.rc2.2.20150902.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 02:25:24 UTC


Attachments (Terms of Use)
List of patches updated (30.93 KB, text/plain)
2015-09-22 18:14 UTC, EMR_Fedora
no flags Details
File: backtrace (58.16 KB, text/plain)
2015-11-02 09:38 UTC, Paulo Fidalgo
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 86281 None None None Never

Description Sandro Mani 2015-09-02 15:33:45 UTC
Description of problem:
Would be nice to add the workaround patch posted at [1] to stop things from crashing with

#5  0x00007fc5e76df64c in brw_meta_fast_clear () at /usr/lib64/dri/i965_dri.so
#6  0x00007fc5e766c55c in brw_clear () at /usr/lib64/dri/i965_dri.so

(if you are unlucky, some core KDE services also crash this way, taking down the entire session with them). According to [2], a proper fix will take time to land, so in the meantime, applying this would be nice (have been using the patch for a while, and things improved noticeably).



[1] https://bugs.freedesktop.org/show_bug.cgi?id=86281#c39
[2] https://bugs.freedesktop.org/show_bug.cgi?id=86281#c44

Version-Release number of selected component (if applicable):
mesa-11.1.0-0.devel.2.60aea30.fc24.x86_64

How reproducible:
Pretty frequently during normal desktop use on Plasma 5 with Intel Gen3 (Ivy Bridge) graphics controller

Comment 1 Enrico Tagliavini 2015-09-04 11:12:27 UTC
I can confirm the named patch solved the problem for me on Fedora 22. I recompiled mesa-10.6.3-1.20150729.fc22.src.rpm with the patch and reinstalled mesa-dri-drivers-10.6.3-1.20150729.fc22.x86_64 . Plasma stopped crashing for now.

This is rather urgent I would say since with a recent Fedora 22 update Plasma 5 is not barely usable (the time scale of the frequency of the crashes is in minutes, sometimes many times a minute). Plasma is not the only application affected, it is just one of the many.

FYI the update introducing the bug in Fedora 22 seems to be:

    Upgraded xorg-x11-drv-intel-2.99.917-12.20150615.fc22.x86_64 @updates
    Upgrade                     2.99.917-15.20150729.fc22.x86_64 @updates

Comment 2 Kevin Kofler 2015-09-06 22:59:26 UTC
*** Bug 1260382 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Kofler 2015-09-06 22:59:44 UTC
*** Bug 1260395 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2015-09-08 19:07:24 UTC
See also,
http://news.softpedia.com/news/critical-intel-graphics-driver-bug-puts-kde-plasma-5-in-a-really-bad-light-488621.shtml

Unfortunate combination of bad timing, and recent xorg-x11-drv-intel apparently getting enough karma to skip -testing altogether:
https://bodhi.fedoraproject.org/updates/FEDORA-2015-13944


In a constructive vein, any objection to including the workaround referenced in the upstream report?

Direct reference here:
http://cgit.freedesktop.org/~ickle/mesa/commit/?h=brw-batch&id=e2a696a4cd93c2dbe445243de48ed478fbdb8009

Comment 5 Dan Mossor [danofsatx] 2015-09-10 13:04:01 UTC
Can we get this bug fixed please? The patch is confirmed working, now lets get it released.

Comment 6 Rex Dieter 2015-09-10 16:56:15 UTC
Per irc chat,
<ignatenkobrain> rdieter: busy last time =( can you apply patch?

So, I can help take care of it.

Comment 7 Fedora Blocker Bugs Application 2015-09-10 17:24:05 UTC
Proposed as a Blocker for 23-beta by Fedora user rdieter using the blocker tracking app because:

 Including this upstream workaround for common/frequent plasmashell crashes.  Otherwise, yields a very bad experience, see also some publicity on the issue:
http://news.softpedia.com/news/critical-intel-graphics-driver-bug-puts-kde-plasma-5-in-a-really-bad-light-488621.shtml
which would be nice to avoid if at all possible

Comment 8 Fedora Update System 2015-09-10 18:01:22 UTC
mesa-10.6.3-2.20150729.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15543

Comment 9 Fedora Update System 2015-09-10 18:04:08 UTC
mesa-11.0.0-0.rc2.2.20150902.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15544

Comment 10 Jason Tibbitts 2015-09-10 18:35:32 UTC
F22-using folks who want to test this immediately:

mkdir /tmp/whatever; cd /tmp/whatever
koji download-build mesa-10.6.3-2.20150729.fc22 --arch=x86_64 --arch=i686 --arch=noarch
sudo dnf upgrade *rpm

Comment 11 Adam Williamson 2015-09-10 19:38:59 UTC
Discussed at 2015-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a Beta blocker, as a conditional violation of criterion "No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional." (various parts of KDE's panel etc. may crash in many cases, it sounds like).

Comment 12 Fedora Update System 2015-09-11 03:49:28 UTC
mesa-11.0.0-0.rc2.2.20150902.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mesa'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15544

Comment 13 Fedora Update System 2015-09-11 19:54:11 UTC
mesa-10.6.3-2.20150729.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update mesa'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15543

Comment 14 Kevin Kofler 2015-09-12 23:54:51 UTC
> If you want to test the update, you can install it with
> su -c 'yum --enablerepo=updates-testing update mesa'.

Well, that will not work, because there is no package called "mesa" (it's only the SRPM's name).

Try:
yum-deprecated --enablerepo=updates-testing --advisory=FEDORA-2015-15543 update

Unfortunately, it looks like dnf does not support that yet. I filed bug #1262572.

Comment 15 Fedora Update System 2015-09-13 00:48:39 UTC
mesa-10.6.3-2.20150729.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-09-16 02:25:21 UTC
mesa-11.0.0-0.rc2.2.20150902.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 EMR_Fedora 2015-09-22 18:14:58 UTC
Created attachment 1075948 [details]
List of patches updated

Comment 18 EMR_Fedora 2015-09-22 18:16:30 UTC
After latest updates (see attached) looks like this bug came back.

Comment 19 Paulo Fidalgo 2015-11-02 09:38:06 UTC
Another user experienced a similar problem:

I have just started the computer (laptop) and the displayport screen was powered on, when the boot process was already ongoing.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        ksplashqml Breeze --pid
crash_function: brw_meta_fast_clear
executable:     /usr/bin/ksplashqml
global_pid:     1924
kernel:         4.2.3-200.fc22.x86_64
package:        plasma-workspace-5.4.2-4.fc22
reason:         ksplashqml killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 20 Paulo Fidalgo 2015-11-02 09:38:18 UTC
Created attachment 1088499 [details]
File: backtrace

Comment 21 Rex Dieter 2015-11-02 11:13:06 UTC
rpm -q mesa-libGL

please.

Comment 22 Oliver Sampson 2015-12-16 20:02:58 UTC
Another user experienced a similar problem:

When switching virtual desktops.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/libexec/kscreenlocker_greet --graceTime 25051 --ksldfd 39
crash_function: brw_meta_fast_clear
executable:     /usr/libexec/kscreenlocker_greet
global_pid:     7338
kernel:         4.2.7-200.fc22.x86_64
package:        plasma-workspace-5.4.3-3.fc22
reason:         kscreenlocker_greet killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 23 Rex Dieter 2016-02-21 11:49:52 UTC
*** Bug 1310405 has been marked as a duplicate of this bug. ***

Comment 24 Rex Dieter 2016-03-03 13:36:21 UTC
*** Bug 1296632 has been marked as a duplicate of this bug. ***

Comment 25 Rex Dieter 2016-03-03 13:36:48 UTC
*** Bug 1299598 has been marked as a duplicate of this bug. ***

Comment 26 Rex Dieter 2016-03-03 13:37:49 UTC
*** Bug 1310211 has been marked as a duplicate of this bug. ***

Comment 27 Rex Dieter 2016-03-03 13:38:08 UTC
*** Bug 1243741 has been marked as a duplicate of this bug. ***

Comment 28 Rex Dieter 2016-03-03 13:38:56 UTC
*** Bug 1299310 has been marked as a duplicate of this bug. ***

Comment 29 Oliver Sampson 2016-07-07 12:39:56 UTC
Similar problem has been detected:

The screen went to lock the lock screen, I grabbed the mouse so I wouldn't have to type in my password, and the screen momentarily froze.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/libexec/kscreenlocker_greet --graceTime 25000 --ksldfd 61
crash_function: brw_meta_fast_clear
executable:     /usr/libexec/kscreenlocker_greet
global_pid:     30197
kernel:         4.4.13-200.fc22.x86_64
package:        kscreenlocker-5.5.5-2.fc22
reason:         kscreenlocker_greet killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 30 Oliver Sampson 2016-07-12 16:16:56 UTC
Similar problem has been detected:

While logging in.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/libexec/kscreenlocker_greet --graceTime 25000 --ksldfd 60
crash_function: brw_meta_fast_clear
executable:     /usr/libexec/kscreenlocker_greet
global_pid:     10212
kernel:         4.4.13-200.fc22.x86_64
package:        kscreenlocker-5.5.5-2.fc22
reason:         kscreenlocker_greet killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.