Bug 1265359 - Add Client capability for windows monitor_config messsage
Add Client capability for windows monitor_config messsage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.8
All Windows
unspecified Severity medium
: rc
: 6.8
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On: 1202419 1244878 1248189 1265361 1265363
Blocks: 1210796 1244880 1248196
  Show dependency treegraph
 
Reported: 2015-09-22 14:19 EDT by Sandy Stutsman
Modified: 2016-06-02 09:02 EDT (History)
17 users (show)

See Also:
Fixed In Version: spice-gtk-0.26-5.el6
Doc Type: Bug Fix
Doc Text:
Cause: Api for managing monitor's position was not used. Consequence: Virtual monitors change position (coordinates). Fix: Use api for managing monitor position. Result: Monitors stay on expected position.
Story Points: ---
Clone Of: 1248189
Environment:
Last Closed: 2016-05-10 17:16:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Fabiano Fidêncio 2015-10-16 04:10:26 EDT
Following https://bugzilla.redhat.com/show_bug.cgi?id=1244878#c4, the upstream commit for spice-gtk is: 8b0cd321d5a4d08ccba5845c5f2206e6f8032c1d.
Moving to POST.
Comment 3 Fabiano Fidêncio 2015-12-08 09:38:26 EST
(In reply to Fabiano Fidêncio from comment #2)
> Following https://bugzilla.redhat.com/show_bug.cgi?id=1244878#c4, the
> upstream commit for spice-gtk is: 8b0cd321d5a4d08ccba5845c5f2206e6f8032c1d.
> Moving to POST.

Fabiano, you're wrong. The upstream commit is 
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=2dcadbc1d1a90b282724a5c0a9d8070c3f391f37 as mentioned in the bug description.
Comment 4 Jonathon Jongsma 2015-12-08 16:27:54 EST
(In reply to Fabiano Fidêncio from comment #3)

> Fabiano, you're wrong. The upstream commit is 
> http://cgit.freedesktop.org/spice/spice-gtk/commit/
> ?id=2dcadbc1d1a90b282724a5c0a9d8070c3f391f37 as mentioned in the bug
> description.

I think we would need both, no? But another issue is that the version of spice-gtk in rhel6 currently uses a bundled version of spice-protocol which does not yet define VD_AGENT_CAP_MONITORS_CONFIG_POSITION. So we'd need to include a patch for that as well.
Comment 5 Fabiano Fidêncio 2015-12-08 16:44:36 EST
(In reply to Jonathon Jongsma from comment #4)
> (In reply to Fabiano Fidêncio from comment #3)
> 
> > Fabiano, you're wrong. The upstream commit is 
> > http://cgit.freedesktop.org/spice/spice-gtk/commit/
> > ?id=2dcadbc1d1a90b282724a5c0a9d8070c3f391f37 as mentioned in the bug
> > description.
> 
> I think we would need both, no? 

We do need both, but 8b0cd321d5a4d08ccba5845c5f2206e6f8032c1d is the fix for Bug 1265361

> But another issue is that the version of
> spice-gtk in rhel6 currently uses a bundled version of spice-protocol which
> does not yet define VD_AGENT_CAP_MONITORS_CONFIG_POSITION. So we'd need to
> include a patch for that as well.

Yeah. I've patched the bundled spice-protocol. Probably will have to patch the spice-protocol package as well.
Comment 6 Jonathon Jongsma 2015-12-08 16:51:22 EST
Ah, Yes. I just noticed that there's two different bugs for this feature. Sorry.
Comment 12 errata-xmlrpc 2016-05-10 17:16:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.