Bug 1278576 - cinder-api is consuming around 10GB RAM when running a "snapshot-list" command on the large set of data
cinder-api is consuming around 10GB RAM when running a "snapshot-list" comman...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
All Linux
urgent Severity high
: async
: 5.0 (RHEL 7)
Assigned To: Jon Bernard
nlevinki
: GSSTriaged, ZStream
Depends On:
Blocks: 1283316
  Show dependency treegraph
 
Reported: 2015-11-05 15:21 EST by Sergey Gotliv
Modified: 2018-02-08 06:01 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1.5-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279543 1279547 1279561 1279562 1283316 (view as bug list)
Environment:
Last Closed: 2015-12-22 09:25:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey Gotliv 2015-11-05 15:21:50 EST
Description of problem:

Cinder is performing an inefficient query: when looking
for information about snapshots associated with a particular volume,
it loads all the rows from the database and then filters them in
memory.  


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Create a lot of snapshots
2. Run cinder snapshot-list command, use volume_id to return only snapshots related to that specific volume

Actual results:

1. cinder-api is consuming a lot of memory after performing cinder snapshot-list
2. query returns a lot of unrelated records from the database (snapshots of a different volumes)


Expected results:

memory usage should be normal, 
query should return only relevant records


Additional info:
Comment 2 Flavio Percoco 2015-11-06 08:10:19 EST
Added a reference to the patch. This is the link to the scratch build:

https://brewweb.devel.redhat.com/taskinfo?taskID=10073456
Comment 7 errata-xmlrpc 2015-12-22 09:25:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2689.html

Note You need to log in before you can comment on or make changes to this bug.