Bug 1301634 - oslo.messaging holds connections when replies fail
oslo.messaging holds connections when replies fail
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-messaging (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
high Severity high
: async
: 5.0 (RHEL 7)
Assigned To: Flavio Percoco
Udi Shkalim
: ZStream
: 1120310 (view as bug list)
Depends On: 1276166 1315842
Blocks: 1157848 1302852 1304073 1304080
  Show dependency treegraph
 
Reported: 2016-01-25 10:03 EST by Flavio Percoco
Modified: 2016-09-06 12:27 EDT (History)
16 users (show)

See Also:
Fixed In Version: python-oslo-messaging-1.3.1-6.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298264
: 1302852 1304073 1304076 1304079 (view as bug list)
Environment:
Last Closed: 2016-02-11 08:44:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2604791 None None None 2016-09-06 12:27 EDT

  None (edit)
Comment 8 Udi Shkalim 2016-02-07 12:27:01 EST
Verified on:
python-cinderclient-1.0.9-1.el7ost.noarch
python-cinder-2014.1.5-4.el7ost.noarch
openstack-cinder-2014.1.5-4.el7ost.noarch
python-oslo-messaging-1.3.1-7.el7ost.noarch



# mount | grep 'glance\|cinder'
10.35.64.11:/vol/vol_rhos_auto_nfs on /var/lib/cinder/mnt/b412ab27c39458e94f0027cd1aff3877 type nfs (rw,relatime,vers=3,rsize=65536,wsize=65536,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=10.35.64.11,mountvers=3,mountport=4046,mountproto=ud
p,local_lock=none,addr=10.35.64.11)

[root@puma08 ~(keystone_admin)]# glance image-list
+--------------------------------------+--------+-------------+------------------+----------+--------+
| ID                                   | Name   | Disk Format | Container Format | Size     | Status |
+--------------------------------------+--------+-------------+------------------+----------+--------+
| ef550f86-3ca5-45f8-8e00-b3836b698e24 | cirros | qcow2       | bare             | 13147648 | active |
+--------------------------------------+--------+-------------+------------------+----------+--------+

[root@puma08 ~(keystone_admin)]# cinder create 1 --image-id ef550f86-3ca5-45f8-8e00-b3836b698e24
+---------------------+--------------------------------------+
|       Property      |                Value                 |
+---------------------+--------------------------------------+
|     attachments     |                  []                  |
|  availability_zone  |                 nova                 |
|       bootable      |                false                 |
|      created_at     |      2016-02-07T17:24:39.284042      |
| display_description |                 None                 |
|     display_name    |                 None                 |
|      encrypted      |                False                 |
|          id         | 4fa1c71e-da55-43df-8fc2-6e015d5c593c |
|       image_id      | ef550f86-3ca5-45f8-8e00-b3836b698e24 |
|       metadata      |                  {}                  |
|         size        |                  1                   |
|     snapshot_id     |                 None                 |
|     source_volid    |                 None                 |
|        status       |               creating               |
|     volume_type     |                 None                 |
+---------------------+--------------------------------------+
[root@puma08 ~(keystone_admin)]# cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 4fa1c71e-da55-43df-8fc2-6e015d5c593c | available |     None     |  1   |     None    |   true   |             |
| b82c4be3-12e4-4e27-8385-48e2f4f61cab | available |     None     |  1   |     None    |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
Comment 10 errata-xmlrpc 2016-02-11 08:44:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0167.html
Comment 11 Peter Lemenkov 2016-07-26 07:25:18 EDT
*** Bug 1120310 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.