This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130317 - Some php tests at rebuilding time hangup or freeze the system
Some php tests at rebuilding time hangup or freeze the system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-18 20:29 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.3.8-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 10:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-08-18 20:29:26 EDT
Description of problem:
If I try rebuild php, some php tests freeze my system completely 
down at rebuilding time. The onliest, I can see is load > 7, then 
ca. 25-30 defunct processes, load > 15 - after that nothing happens 
for the next 15 minutes...okay then I did a hard reset :-(

That system is a Intel Pentium 1 GHz machine. At a AMD Athlon 2,4 
GHz I get a load of ~ 25 the system hangs up (soft freeze?) for ca. 
2 minutes, then the building goes on. I didn't try to reproduce that 
problem at other platforms, yet.

Version-Release number of selected component (if applicable):
php-4.3.7-4
php-4.3.8-3
php-4.3.8-4
(all Rawhide)

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. rpmbuild --rebuild php-4.3.8-4.src.rpm
2. Get the freeze (or hangup) at php tests
  
Actual results:
After a change like the following, the rebuild runs fine without
any problem (behaviour at php < 4.3.7-4):

--- snipp ---
--- php.spec       2004-08-19 00:26:27.000000000 +0200
+++ php.spec.rsc   2004-08-19 01:38:24.000000000 +0200
@@ -309,7 +309,6 @@
 # is not defined by C standard, so don't presume anything.
 rm -f ext/standard/tests/file/bug21131.phpt

-%if 0
 # Tests that fail.
 rm -f ext/standard/tests/file/bug22414.phpt \
       ext/session/tests/019.phpt \
@@ -317,7 +316,6 @@
       ext/standard/tests/math/round.phpt \
       ext/standard/tests/math/abs.phpt \
       ext/iconv/tests/bug16069.phpt
-%endif

 : Build for oci8=%{with_oci8} mssql=%{with_mssql} mhash=%{with_mhash}

--- snapp ---

Expected results:
Rebuild without system hangup or freeze at running php tests.
Comment 1 Joe Orton 2004-08-19 05:41:04 EDT
Which of the bugs is causing the system load - what's the last test
result printed before the issues?
Comment 2 Robert Scheck 2004-08-19 08:41:50 EDT
Oh sorry, I forgot it. The last 5 lines before the freeze:

--- snipp ---
PASS is_*() and file_exists() return values are boolean. [ext/standard/tests/file/003.phpt]
PASS Bug #12556 (fgetcsv() ignores lengths when quotes not closed) [ext/standard/tests/file/bug12556.phpt]
PASS Bug #20424 (stream_get_meta_data crashes on a normal file stream) [ext/standard/tests/file/bug20424.phpt]
PASS Bug #22362: combinations of fseek() and fwrite() produce unexpected results. [ext/standard/tests/file/bug22362.phpt]
PASS Bug #22382 (fgetcsv() does not handle escaped quotes correctly) [ext/standard/tests/file/bug22382.phpt]
--- snapp ---

So I guess, the hangup/freeze is caused by:

-rw-r--r--    1 root     root          642 Jul 15  2003 bug22414.phpt

which would be the next test (if I am right)...
Comment 3 Joe Orton 2004-08-19 08:45:15 EDT
Ah, that's probably right, that test is usually a problem.  It invokes
/usr/bin/php with lots of recursion; I'll disable it again.

Note You need to log in before you can comment on or make changes to this bug.