Bug 132917 - Navigation of text boxes doesn't correctly scope arrow keys in 10PR
Navigation of text boxes doesn't correctly scope arrow keys in 10PR
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 133363 133448 133702 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-19 12:38 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 21:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2004-09-19 12:38:24 EDT
Description of problem:
Trying to navigate through edittable text in a text box like
the Description box in bugzilla, and the arrow keys do not work
to move around the edittable text. Even though the edittable field
is in focus and i can type in it, the arrow keys are controlling the
scrollbar on the side of the box.

As a comparison the binary from mozilla.org lets me navigate the
textbox region as expected using the arrow keys.

Version-Release number of selected component (if applicable):
firefox-0.10.0-1.0PR1.0

How reproducible:
always... i even deleted .mozilla/firefox to make sure this is not a
usespace issue.. and compared with the binary from mozilla.org. Afaict
this is a bug specific to the rpm build.

Steps to Reproduce:
1. go to enter a new bug in bugzilla
2. try to edit the description box and navigate inside the edittable
text using the arrow keys
  
Actual results:
arrow keys are not moving the cursor inside the box.
up/down arrow keeys seem to be stuck scoped on the scrollbar and not
the text box itself.

Expected results:
I should be able to move up/down left/right with the arrow keys
while editting the text in the text box.

Additional info:


-jef
Comment 1 Warren Togami 2004-09-20 02:01:33 EDT
Additionally it seems Shift-Enter pasting is broken, while CTRL-V
pasting works.

Wow, CTRL-A Select-All within a text area finally works.
/me does the happy dance.
Comment 2 Fred New 2004-09-23 02:21:46 EDT
Besides the arrow keys, the Home key doesn't work when editing a URL
in the address box.
Comment 3 Christopher Aillon 2004-09-23 13:47:21 EDT
*** Bug 133363 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2004-09-24 11:32:22 EDT
*** Bug 133448 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Aillon 2004-09-24 23:42:43 EDT
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=132917
Comment 6 Christopher Aillon 2004-09-24 23:43:41 EDT
Whoops, meant to paste:
https://bugzilla.mozilla.org/show_bug.cgi?id=260290
Comment 7 Brian Ryner 2004-09-25 18:09:06 EDT
This seems to be caused by not having MOZILLA_OFFICIAL=1 set in the
environment when building.  That causes the build id to be 00000000,
and so components aren't re-registered as they should be when the
build id changes.
Comment 8 Christopher Aillon 2004-09-26 21:05:05 EDT
Fixed in firefox-0.10.0-1.0PR1.1 which should be available tomorrow
tomorrow morning.
Comment 9 Christopher Aillon 2004-09-26 22:31:47 EDT
*** Bug 133702 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.