Bug 13344 - AltGr doesn't work in unmanaged windows
AltGr doesn't work in unmanaged windows
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 18792 31810 31811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-03 07:51 EDT by Michael Redinger
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 03:12:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-07-03 07:51:10 EDT
Ok, I'll put this here, but there are different packages affected ... There
are also many other keyboard bug entries, but I didn't find something like
this (ie. keyboard works partially correct).

Using the latest (4.0-0.29 and 3.3.6-28) X packages (I have a ATI graphics
card which uses the 3.3.6 X server) there are some problems with german
keyboards:

backspace and delete do not work. Produce beep and ~

If the shells (xterm or konsole) are not started as login shells, the
german "umlaute" (dv ...) do not work. Therefore these programs should
always be invoked using -ls (eg. in the KDE panel or the KDE menu).

The right "Alt" key is called "AltGr" here. Necessary for things like "|",
"{" etc. This does not work either. Wenn used in a login shell it produces
"1/4", in a non login shell it brings you to the first entry in your
history (in the KDE "execute command" window it does not do anything).
Comment 1 Glen Foster 2000-07-18 15:56:19 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 2 Erik Troan 2000-07-21 12:56:20 EDT
Bero, can you verify this?
Comment 3 Bernhard Rosenkraenzer 2000-07-21 13:02:18 EDT
I can't on my installation - but this may be an issue with anaconda
and/or Xconfigurator creating wrong keyboard configs (I'm just copying
my old config files around every time, much too lazy to calculate new
optimal mode lines every time I reinstall ;) ).

Michael, can you attach your XF86Config please?
Comment 4 Michael Redinger 2000-07-21 13:07:44 EDT
I'm just downloading Beta 4. Will try to reproduce it this weekend and will put
a summary here.
Comment 5 Glen Foster 2000-07-21 14:09:06 EDT
This defect has been re-classified as MUST-FIX for Winston Gold-release
Comment 6 Michael Redinger 2000-07-26 05:56:49 EDT
This is mostly fixed in Beta 4. Only one issue is still remaining - kdm doesn't
treat "AltGr" correctly, therefore things like "~" don't work.
Moving this bug to kdebase.
Comment 7 Michael Redinger 2000-07-26 06:01:48 EDT
Just in case you'd like to have a look at it, here's the keyboard section of
XF86Config. I just left out the comments, the rest is unchanged, ie. just how
anaconda and Xconfigurator generate it.

Section "Keyboard"
    Protocol    "Standard"
    AutoRepeat  500 5
    LeftAlt         Meta
    RightAlt        Meta
    ScrollLock      Compose
    RightCtl        Control
     XkbRules    "xfree86"
     XkbModel    "pc104"
     XkbLayout   "de"
     XkbVariant  "nodeadkeys"
     XkbOptions  ""
EndSection
Comment 8 Glen Foster 2000-07-30 18:33:07 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 9 Bernhard Rosenkraenzer 2000-08-01 11:08:13 EDT
The kdm problem is fixed in rawhide; however, many people are still reporting X
keymap problems after fresh installations.

Looks like anaconda creates broken settings for German keyboards; running
Xconfigurator helped when this occurred. In particular, the Alt Gr key doesn't
seem to work in some installs (it's needed to produce important characters like
@ or | on German keyboards) with anaconda's X configuration.
Comment 10 Michael Redinger 2000-08-01 11:15:34 EDT
Ok, think we can close this, right?
There are other bugs that deal with that german keyboard problems.
I did some testing on that and made comments to the appropriate bug reports. 
For example, see bug 13525.
Comment 11 Trond Eivind Glomsrxd 2000-08-07 16:40:58 EDT
This works now, on an anaconda-GUI installed machine with a German keyboard.
Comment 12 Michael Redinger 2000-08-12 08:30:39 EDT
The kdm "AltGr" problem is still there in RC1 (text KDE workstation
installation). Reopening.
Comment 13 Preston Brown 2000-08-15 10:51:36 EDT
bero, please try and get this addressed before RC2.
Comment 14 Bill Nottingham 2000-08-15 11:34:21 EDT
What happens if you switch it to use pc101 instead
of pc104?
Comment 15 Michael Redinger 2000-08-15 11:41:33 EDT
Same problem.
The problem also exists with XFree86 4; the config file there only says
Xkblayout "de"
no model stpecified then.
Comment 16 Michael Redinger 2000-08-15 12:01:00 EDT
Just noted that this also happens in the KDE quick run ("run command") box,
again.
Comment 17 Glen Foster 2000-08-16 18:43:04 EDT
This defect has been re-classified as SHOULD-FIX for Winston Gold-release
Comment 18 Michael Fulbright 2000-08-17 16:46:12 EDT
Is this related to bug number 13600?
Comment 19 Michael Redinger 2000-08-17 17:15:40 EDT
Hm, don't think so. There where a number of bugs similar to bug #13600 (which I
think should be a duplicate of some another bug, will try to find it).

This problem occurs also if Alt-Gr works in normal X apps, only kdm and KDE
"quick launch" don't treat them correctly.

Comment 20 Bernhard Rosenkraenzer 2000-08-23 09:44:06 EDT
This seems to be a very weird X problem:
It happens in kdm, gdm and the KDE quicklaunch, and stops happening as soon as
you do anything (e.g. in kdm, click on the selection combobox and it works, in
gdm click on the menu and it works).

Since it's happening both in kdm and gdm, it's almost certainly some weird Xlib
issue.
Seems to happen in all unmanaged windows requiring input.
Comment 21 Bernhard Rosenkraenzer 2001-03-15 08:57:34 EST
*** Bug 31810 has been marked as a duplicate of this bug. ***
Comment 22 Bernhard Rosenkraenzer 2001-03-15 08:58:21 EST
*** Bug 31811 has been marked as a duplicate of this bug. ***
Comment 23 Bernhard Rosenkraenzer 2001-03-15 08:58:52 EST
*** Bug 18792 has been marked as a duplicate of this bug. ***
Comment 24 Bernhard Rosenkraenzer 2001-03-15 09:00:39 EST
Changing the summary to match the portion of the problem that is still present.
Comment 25 Mike A. Harris 2001-05-04 03:12:32 EDT
After consulting all of the bug reports linked to in this one I am
almost certain that this was the bug in the installer calling setxkbmap
incorrectly when enabling/disabling deadkeys.  This problem is now fixed
in anaconda in rawhide.

try:

setxkbmap -model de -layout basic

  and/or

setxkbmap -model de -layout nodeadkeys

If either fixes the problem, this is definitely the deadkeys bug from
the installer under a different guise.

Another as of yet uncorrected bug is that disabling deadkeys doesn't always
disable ALL dead keys due to bugs in the keyboard layout tables.
Comment 26 Michael Redinger 2001-07-06 07:39:48 EDT
Seems to work fine in Fairfax. Changing to CURRENT.
Comment 27 Larry Troan 2003-11-07 08:05:40 EST
*** Bug 18792 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.