Bug 136005 - udev segfault on boot
Summary: udev segfault on boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 136058 136083 136111 136391 136745 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-10-16 17:34 UTC by Neal Becker
Modified: 2007-11-30 22:10 UTC (History)
7 users (show)

Fixed In Version: udev-039-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-15 12:25:13 UTC


Attachments (Terms of Use)

Description Neal Becker 2004-10-16 17:34:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
After updating to kernel-2.6.8-1.624, system won't boot.  I got:

udev segfault @ 30, rip 424d6c rsp 7fbfffc8e0 error 4


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.624


How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
    

Additional info:

Comment 1 Bill Nottingham 2004-10-18 03:15:03 UTC
*** Bug 136083 has been marked as a duplicate of this bug. ***

Comment 2 Michal Jaegermann 2004-10-18 03:53:12 UTC
A segfault reported in bug #136083 was with kernel-2.6.8-1.610

Comment 3 Bojan Smojver 2004-10-18 10:22:22 UTC
*** Bug 136111 has been marked as a duplicate of this bug. ***

Comment 4 Bojan Smojver 2004-10-18 10:24:13 UTC
Just to mention that here, in my case (bug 136111, marked duplicate
here) does not cause systems not to boot. They just behave very
strange (i.e. a lot of stuff doesn't work).

Comment 5 Harald Hoyer 2004-10-18 11:46:53 UTC
*** Bug 136058 has been marked as a duplicate of this bug. ***

Comment 6 Harald Hoyer 2004-10-18 12:07:34 UTC
you have to remake your initrd with mkinitrd!

Comment 7 David Nielsen 2004-10-18 16:56:03 UTC
I updated to 18-10-04, which supposedly fixes this (?), did 
mkinitrd -f /boot/initrd-2.6.8-1.624.img 2.6.8-1.624 
and I still get the udevstart error and it fails to find the lvm2
volumes - rendering my system unbootable, it works perfectly fine on
.541 though.

Comment 8 Harald Hoyer 2004-10-19 08:40:16 UTC
> I updated to 18-10-04
I hope you mean udev-039-1 or udev-039-3


Comment 9 Barry K. Nathan 2004-10-19 09:11:26 UTC
Perhaps he meant a 20041018 rawhide snapshot; that still has udev-038-2.

Comment 10 Harald Hoyer 2004-10-19 20:12:18 UTC
*** Bug 136391 has been marked as a duplicate of this bug. ***

Comment 11 Dave Jones 2004-10-20 03:37:08 UTC
my x86-64 box has around 40 or so segfaults during boot.
udev[10]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff708 error 14
udev[11]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff708 error 14
udev[12]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff708 error 14
udev[14]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[15]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[16]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[17]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[18]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[19]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[20]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
udev[21]: segfault at ffffffffff600400 rip ffffffffff600400 rsp
0000007fbffff688 error 14
....

Using udev-039-3 with what will be the new rawhide kernel as of
tomorrow.  The kernel was installed /after/ the udev upgrade, so there
can't be any 'need to rebuild initrd' type problems.



Comment 12 Bojan Smojver 2004-10-20 04:44:19 UTC
Just an FYI, this particular problem (udevstart failing at boot time)
does go away with udev-0.39-3 after I removed kernel-2.6.8-1.624 and
then put it back on (i.e. the initrd was build by rpm itself).

However, the weird problems that I mentioed (e.g. Evolution can't get
Exchange/IMAP mail) are still there, which would point to this
particular kernel. The 2.6.8-1.610 kernel does all that with no
problems at all.

Comment 13 Harald Hoyer 2004-10-20 14:59:18 UTC
jeremy, please remove the hotplug symlink in the initrd and
echo -n "/sbin/udev" > /proc/sys/kernel/hotplug
instead of
echo -n "/sbin/hotplug" > /proc/sys/kernel/hotplug


Comment 14 Harald Hoyer 2004-10-20 15:05:49 UTC
best solution would be, if nash(hotplug) could spool the hotplug
events somehow and replay them (call /sbin/udev with the correct
environment variables), after /dev is mounted :)

Comment 15 Harald Hoyer 2004-10-20 15:07:12 UTC
even better would be, if nash could save the hotplug events in /dev
and the replay is done after ROOT is mounted..

Comment 16 Jeremy Katz 2004-10-20 15:22:48 UTC
gregkh was explicitly against setting the hotplug handler to be udev
when I talked to him at OLS...

Comment 17 Harald Hoyer 2004-10-20 17:23:27 UTC
davej, please retry with udev-093-4

Comment 18 Harald Hoyer 2004-10-20 17:27:15 UTC
udev segfaulted because of openlog(3) called in initramfs with an
empty /dev, so I disabled logging in udev-093-4

Comment 19 Michal Jaegermann 2004-10-21 20:32:44 UTC
Just updated to kernel-2.6.9-1.640 and udev-039-3 (that what is
available as of today) and on the top of 28 segfaults :-) I got
also
.....
Probing IDE interface ide0...
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
request_module: runaway loop modprobe net-pf-1
Probing IDE interface ide1...
.....

which seem to be coming from udev too.  Or this is initrd?

After all this excitment the machine started.

Comment 20 Harald Hoyer 2004-10-22 08:17:06 UTC
*** Bug 136745 has been marked as a duplicate of this bug. ***

Comment 21 Harald Hoyer 2004-10-22 08:19:23 UTC
Michal, please read comment #17 .. udev >= 039-4 should fix the issue
with the segfaults.
For the runaway loops, please file a seperate bugzilla for mkinitrd.

Comment 22 Neal Becker 2004-10-22 15:00:15 UTC
udev-0.39-6 seems to fix it for me 

Comment 23 Michal Jaegermann 2004-10-22 15:47:44 UTC
> Michal, please read comment #17 .. udev >= 039-4 should fix the issue
As you can read in comment #19 this was mentioned only as an aside.
Still twenty eight segfaults is an impressive number. :-)

> For the runaway loops, please file a seperate bugzilla for mkinitrd.
Will do. I was not sure where is the source of that problem.

Comment 24 Nadav Kavalerchik 2005-05-10 12:32:15 UTC
i'm getting the same "/sbin/udevstart exited abnormally" error on boot. 
using : "2.6.11-1.1287_FC4" kernel and "udev-057-4" udev rpm. 

Comment 25 Harald Hoyer 2005-05-10 16:08:06 UTC
Nadav, use "udev-057-5" rebuild your initrd with mkinitrd


Note You need to log in before you can comment on or make changes to this bug.