Bug 136914 - Launching evolution from a clean profile induces e-d-s to shower the user with hatred
Summary: Launching evolution from a clean profile induces e-d-s to shower the user wit...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: rawhide
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
: 136913 136915 137936 (view as bug list)
Depends On:
Blocks: 136912
TreeView+ depends on / blocked
 
Reported: 2004-10-23 00:44 UTC by Chris Lee
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: evolution-data-server-1.0.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 21:22:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lee 2004-10-23 00:44:30 UTC
Description of problem:
On a clean install of Rawhide on IA64, with no pre-existing user profile,
launching evolution will invoke the Evolution Setup Assistant and also bring
about the destruction of the free world^W^W^W^W^Wappearance of several error
dialogs courtesy of evolution-data-server.

Version-Release number of selected component (if applicable):
evolution-data-server-1.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. Log into GNOME
2. Launch evolution
3. Swat down the error dialogs like flies
  
Actual results:
An error dialog notifying the user of the evolution-data-server crash pops up
repeatedly.

Expected results:
The e-d-s process should not crash.

Comment 1 Dave Malcolm 2004-11-02 22:23:54 UTC
*** Bug 137936 has been marked as a duplicate of this bug. ***

Comment 2 Dave Malcolm 2004-11-03 22:38:06 UTC
I've tried selecting deleting .server files corresponding to the
various Evolution components, and the problem seems to be purely
associated with the Calendar component.  

I've found some suspicious-looking warnings in the e-d-s calendar
code; hopefully fixing them will fix these crashes; am investigating...

Comment 3 Dave Malcolm 2004-11-03 22:38:47 UTC
("selectively deleting", I meant to say)

Comment 4 Dave Malcolm 2004-11-04 00:54:38 UTC
Looks like a GINT_TO_POINTER/GPOINTER_TO_INT problem in the "kinds"
hash tables in e_data_cal_factory.c ; I'm trying a patched version of
the package...

Comment 5 Dave Malcolm 2004-11-04 21:55:46 UTC
It was stripping away the top 32 bits of the GType values, which is a
64-bit type - ultimately a pointer for the nonfundamental types.

OK, I've built a patched version as evolution-data-server-1.0.2-4 for
RHEL4; I've tested with it on an ia64 box and Evolution and the panel
clock's task list is now working; I can successfully view local and
web calendars, and edit the local ones.

I'll resolve this bug once the new package is in place.

Comment 6 Dave Malcolm 2004-11-04 21:57:34 UTC
*** Bug 136913 has been marked as a duplicate of this bug. ***

Comment 7 Dave Malcolm 2004-11-04 22:02:33 UTC
*** Bug 136915 has been marked as a duplicate of this bug. ***

Comment 8 Dave Malcolm 2004-11-04 22:20:36 UTC
(Looks like the code is already fixed in CVS HEAD upstream)

Comment 9 Dave Malcolm 2004-11-12 21:22:08 UTC
Closing, since the eds package is now in place


Note You need to log in before you can comment on or make changes to this bug.