Bug 1371605 - Content hosts show red untitled status from webui yet subscribed from command line, as well as green fully entitled with no subscription attached.
Summary: Content hosts show red untitled status from webui yet subscribed from command...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1388128 (view as bug list)
Depends On:
Blocks: 1399395 1530822
TreeView+ depends on / blocked
 
Reported: 2016-08-30 15:25 UTC by Kathryn Dixon
Modified: 2021-09-09 11:55 UTC (History)
38 users (show)

Fixed In Version: katello-installer-base-3.0.0.87
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1446706 1530822 (view as bug list)
Environment:
Last Closed: 2017-06-20 17:21:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
unentitled 1 (35.25 KB, image/png)
2017-06-09 23:49 UTC, jcallaha
no flags Details
unentitled 2 (42.87 KB, image/png)
2017-06-09 23:50 UTC, jcallaha
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 18812 0 High Closed Content hosts show red untitled status from webui yet subscribed from command line, as well as green fully entitled with... 2020-11-02 17:57:20 UTC
Red Hat Knowledge Base (Solution) 3106371 0 None None None 2017-07-06 09:07:41 UTC
Red Hat Product Errata RHBA-2017:1553 0 normal SHIPPED_LIVE Satellite 6.2.10 Async Bug Release 2017-06-20 21:19:07 UTC

Internal Links: 1496801

Description Kathryn Dixon 2016-08-30 15:25:44 UTC
Description of problem:

When looking at the webui, under hosts > content hosts > then searching for 

subscription_status != valid

all red content hosts show up, yet a number of these show errata/security updates in the webui, as well as can yum update

The below commands all confirm that the system is fully entitled.

# subscription-manager status

# subscription-manager list --consumed

Running a # subscription-manager refresh does not update the webui.

content hosts are using derived skus ( virt-who set up correctly)

Version-Release number of selected component (if applicable):


How reproducible: 100% in customers environment


Steps to Reproduce:
1. register system, with or without activation key
2. subscription-manager attach --auto or attach using pool id to valid subscription
3. # subscription-manager status shows fully entitled # yum update is successful.
4. confirmed not using 24 hour sku, 100% using proper subscription from hosts
5. subscription-manager fresh

Actual results: content host shows red, and unentitled 


Expected results: content hosts should show green with have a valid subscription. Same as hosts that have no subscription attached should be red.

Additional info: Satellite is also showing incorrect colors for content hosts that have only been registered and show no subscription attached.

Comment 19 Bryan Kearney 2017-01-11 14:49:05 UTC
Please attempt to re-create the issue on 6.2.6. We believe this was due to qpid issues which have beenb addressed

Comment 28 Chris Roberts 2017-03-06 18:34:16 UTC
PR Created:

https://github.com/Katello/katello-installer/pull/487

Comment 29 Satellite Program 2017-03-23 18:08:35 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18812 has been resolved.

Comment 30 Bryan Kearney 2017-04-04 13:57:45 UTC
*** Bug 1388128 has been marked as a duplicate of this bug. ***

Comment 33 Brad Buckingham 2017-06-01 00:11:58 UTC
*** Bug 1440057 has been marked as a duplicate of this bug. ***

Comment 34 Jason Dickerson 2017-06-05 21:52:04 UTC
This issue has recurred for my customer.  The first time the issue was noticed, was as I was using hammer to remove all subs from a host, and then assign correct subs to the host.  We since loaded the fix.  Now the issue has recurred when all of our subs expired, and then we imported a new manifest and used subscription-manager to auto attach.  We are looking at having to run the proposed fix again.  This customer has never run 6.1, only 6.2.

Comment 37 jcallaha 2017-06-09 23:49:44 UTC
Created attachment 1286561 [details]
unentitled 1

Comment 38 jcallaha 2017-06-09 23:50:10 UTC
Created attachment 1286562 [details]
unentitled 2

Comment 43 Satellite Program 2017-06-14 14:09:30 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18812 has been resolved.

Comment 45 jcallaha 2017-06-19 15:52:17 UTC
Verified in Satellite 6.2.10 Snap 6

The new event queue categories are in place

-bash-4.2# qpid-config --ssl-certificate=/etc/pki/katello/qpid_client_striped.crt -b amqps://localhost:5671 list binding|grep katello_event_queue
  katello_event_queue                                                                katello_event_queue                                                                0           {}         
  katello_event_queue                                                                compliance.created                                                                 4           {}         event
  katello_event_queue                                                                entitlement.created                                                                1           {}         event
  katello_event_queue                                                                entitlement.deleted                                                                1           {}         event
  katello_event_queue                                                                pool.created                                                                       0           {}         event
  katello_event_queue                                                                pool.deleted                                                                       0           {}         event

Also, there are no new issues currently identified by this fix, so marking as verified with no-break criteria.

Comment 47 errata-xmlrpc 2017-06-20 17:21:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1553


Note You need to log in before you can comment on or make changes to this bug.