Bug 138493 - s-c-printer doesn't work
Summary: s-c-printer doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyXML (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
: 138707 138719 138985 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2004-11-09 16:30 UTC by Bill Nottingham
Modified: 2014-03-17 02:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 22:54:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2004-11-09 16:30:58 UTC
PyXML-0.8.3-7.

$ system-config-printer
Traceback (most recent call last):
  File "/usr/sbin/system-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 57, in ?
    import printconf_conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
ImportError: No module named utils

Comment 1 Miloslav Trmač 2004-11-09 23:48:30 UTC
python 2.4b2 requires not-yet-released PyXML-0.8.4 :(

Comment 2 Bill Nottingham 2004-11-10 21:29:50 UTC
*** Bug 138707 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2004-11-10 21:30:53 UTC
*** Bug 138719 has been marked as a duplicate of this bug. ***

Comment 4 Miloslav Trmač 2004-11-11 21:25:07 UTC
Building PyXML-0.8.4-0.cvs20041111.1.
There are no Python testsuite regressions.
There are two PyXML testsuite regressions
(http://sourceforge.net/tracker/?func=detail&aid=1064741&group_id=6473&atid=106473),
but having a mostly-working PyXML is still better than no PyXML at all.

I'll keep the bug open as a reminder to update to a released version
of 0.8.4 as soon as it is available.

Comment 5 Tim Waugh 2004-11-12 12:12:46 UTC
*** Bug 138985 has been marked as a duplicate of this bug. ***

Comment 6 Mickey Stein 2004-11-13 18:46:13 UTC
I can see that there's a number of problems with python 2.4 just by
keeping rawhide up to date, but hacked a few of the problems anyway.

I'm fairly sure this is obvious to all here, but I'm new to these
things and thought I saw the problem and put this patch together. For
all I know, it may cause holes in the ozone layer and should be
discarded immediately:


--- /usr/share/printconf/util/printconf_conf.py.sav     2004-11-13
10:32:41.1602
44713 -0800
+++ /usr/share/printconf/util/printconf_conf.py 2004-11-13
10:29:41.354044284 -0
800
@@ -80,7 +80,8 @@
 import signal

 # Used for parsing foomatic and printer test files
-from xml.utils import qp_xml
+#from xml.utils import qp_xml
+from _xmlplus.utils import qp_xml

 #
=============================================================================
====================
 # Debugging Functions



Comment 7 Tim Waugh 2004-11-14 10:11:21 UTC
That patch may obscure the symptom, but the real problem was that:

  python -c "from xml.utils import qp_xml"

failed, and this was due to PyXML being an older release than required
by the new Python.  Please try the current PyXML package instead of
using the above patch.

Comment 8 Mickey Stein 2004-11-14 12:36:13 UTC
It was only a temporary workaround. The version of PyXML is the latest
from the rawhide tree (PyXML-0.8.3-7). Which package are you referring
to as the 'current PyXML'? 

Thanks.


Comment 9 Miloslav Trmač 2004-11-14 12:41:50 UTC
See comment #4.

Comment 10 Miloslav Trmač 2004-11-30 22:54:04 UTC
PyXML-0.8.4-1 should be in rawhide soon.

Comment 11 Nicolas Scheibling 2005-02-22 16:32:59 UTC
i have updated sc-printer and PyXML to the latest available release
and i always have this error: 

rpm -q PyXML
PyXML-0.8.4-1
rpm -q system-config-printer
system-config-printer-0.6.123-1

system-config-printer
Traceback (most recent call last):
  File "/usr/sbin/system-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 70, in ?
    import gnome.ui
ImportError: No module named gnome.ui


Note You need to log in before you can comment on or make changes to this bug.