Bug 142908 - bugs you care about may disappear from My Front Page
bugs you care about may disappear from My Front Page
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Mike MacKenzie
: FutureFeature
Depends On:
Blocks: 158638
  Show dependency treegraph
 
Reported: 2004-12-14 18:00 EST by Geoff Gustafson
Modified: 2013-06-23 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 14:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2004-12-14 18:00:46 EST
Description of problem:
It seems dangerous to me the way that bugs move off of "My Front Page" without
you doing it yourself, or necessarily realizing it. For instance, if a bug is
closed and you don't notice and don't agree that it should be closed, it could
drop off your radar because it's not on your front page.

Similarly if bugs are reassigned, even if you maybe still care about the bug and
want to make sure it's fixed, it drops out of your list. I'd prefer to make that
decision myself, but this may be only because I have a special role here
representing Intel, and I am involved in fewer bugs than other people so I
wouldn't mind a bit more manual work to safeguard me from dropping things.

Here's how I would probably implement what I'm talking about: each time My Front
Page is generated, according to whatever rules, save the list of bugs that were
included in a "cache" of bugs grgustaf is watching. Then next time the page is
generated, diff the new list with the old list, and any bugs that are no longer
on the list get added to a new section at the bottom, "Watched Bugs" or some
more clever, sensible description. For a bug to leave that section, I have to
select a checkbox by each bug to be cleared and submit the form; at that time it
is removed from the cache.

This probably also implies a "Watch This Bug" feature on each bug, similar to
the cc: list feature. I definitely think this would be a big help for anyone
like me who comes at bugzilla from a third party point of view.

It is possible to achieve this safety by adding yourself to cc: lists and
carefully monitoring every bug mail, which I am able to do with my somewhat low
volume, but I'm not sure I can keep that up forever.
Comment 1 Joachim Frieben 2005-03-01 04:58:40 EST
I seem to encounter the same problem, as the set of active bugs shown by old
style bugzilla and the current beta version are *different*. For example, bug
#55223 does not appear in the "active" section of the new style "My front page"
any more, whereas it is still displayed under "My bugs" of old style bugzilla. I
do not even know why it has disappeared, unless it is simply a bug!
Comment 2 David Lawrence 2005-03-15 14:50:00 EST
I have done some fixes/improvements to the frontpage recently. Can you verify
for me that the problem still exists?
Comment 3 Joachim Frieben 2005-03-16 07:10:22 EST
No, bug #55223 does still not appear in the "active" section of the new style
"My front page". The old style "My bugs" page is not accessible any more, but
the bug status is "assigned", so it should still be visible which it is not.
Comment 4 Joachim Frieben 2005-03-16 07:34:51 EST
Ok, I have managed to find old Bz. The only visible bug #127574 is
qualified as "NEEDINFO", bugs #55223 and #130541 which are not
displayed belong to the category "ASSIGNED".
Comment 5 Geoff Gustafson 2005-06-16 18:30:51 EDT
The problem I was talking about at least is still there. For instance, today
katzj marked my bug 160216 as "closed/notabug". This is because it _may_ be a
hardware problem, but that's not certain. If I hadn't specifically looked for
it, I might have missed that it got closed, which makes Bugzilla much less
useful for me. I can't be sure I won't forget about issues if I rely on it.

(Now I did get cc:'d and eventually would have seen that.)

What I would like is another section on My Front Page, for bugs that otherwise
would disappear from the page, but I'm not sure it's reasonable to implement
that feature so feel free to close this bug.
Comment 6 Alex Lancaster 2005-12-27 10:05:01 EST
Bug #158638 (bugs that ASSIGNED disappear from the front page) appears to be
related to this one.
Comment 7 Alex Lancaster 2008-01-27 03:10:42 EST
Another similar case is ON_QA bugs disappearing from "My Front Page": bug #430383.
Comment 8 David Lawrence 2008-09-16 12:51:51 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Note You need to log in before you can comment on or make changes to this bug.