Bug 1476863 - packaging: /var/lib/glusterd/options should be %config(noreplace)
packaging: /var/lib/glusterd/options should be %config(noreplace)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
3.12
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1476861 1476867 1476873 1478499
Blocks: glusterfs-3.12.0
  Show dependency treegraph
 
Reported: 2017-07-31 12:15 EDT by Kaleb KEITHLEY
Modified: 2017-09-05 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1476861
Environment:
Last Closed: 2017-09-05 13:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-07-31 12:15:10 EDT
+++ This bug was initially created as a clone of Bug #1476861 +++

Description of problem:

/var/lib/glusterd/options is erased when glusterfs-server is removed or updated.

This is where cluster.enable-shared-storage, among other things, is persisted.

When /var/lib/glusterd/options is erased then shared storage may not be enabled after an upgrade.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-07-31 12:26:31 EDT
REVIEW: https://review.gluster.org/17931 (packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on release-3.12 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Worker Ant 2017-08-02 11:38:47 EDT
COMMIT: https://review.gluster.org/17931 committed in release-3.12 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 10da7c37b30f7995bf65dbb4babbbb5216bcc925
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Jul 31 12:25:26 2017 -0400

    packaging: /var/lib/glusterd/options should be %config(noreplace)
    
    /var/lib/glusterd/options is where cluster.enabled-shared-storage is
    persisted. If the file is removed as part of an uninstall/reinstall
    or update then the state of shared storage could be lost.
    
    Change-Id: Ie18c3d883df71c1857fd6996d9c03ab247580b70
    BUG: 1476863
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/17931
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:38:10 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.