Bug 1478499 - packaging: /var/lib/glusterd/options should be %config(noreplace)
packaging: /var/lib/glusterd/options should be %config(noreplace)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
3.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1476861
Blocks: glusterfs-3.10.5 1476863 1476867 1476873
  Show dependency treegraph
 
Reported: 2017-08-04 13:18 EDT by Kaleb KEITHLEY
Modified: 2017-08-21 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.10.5
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1476861
Environment:
Last Closed: 2017-08-21 09:42:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-08-04 13:18:13 EDT
+++ This bug was initially created as a clone of Bug #1476861 +++

Description of problem:

/var/lib/glusterd/options is erased when glusterfs-server is removed or updated.

This is where cluster.enable-shared-storage, among other things, is persisted.

When /var/lib/glusterd/options is erased then shared storage may not be enabled after an upgrade.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-07-31 12:24:48 EDT ---

REVIEW: https://review.gluster.org/17930 (packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Worker Ant on 2017-08-02 11:38:28 EDT ---

COMMIT: https://review.gluster.org/17930 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit f17eefb6d9a91cfccc3bef3aa3ba08a9128b046e
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Jul 31 12:22:46 2017 -0400

    packaging: /var/lib/glusterd/options should be %config(noreplace)
    
    /var/lib/glusterd/options is where cluster.enabled-shared-storage is
    persisted. If the file is removed as part of an uninstall/reinstall
    or update then the state of shared storage could be lost.
    
    Change-Id: Ie18c3d883df71c1857fd6996d9c03ab247580b70
    BUG: 1476861
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/17930
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 1 Worker Ant 2017-08-04 13:34:21 EDT
REVIEW: https://review.gluster.org/17979 ( packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Worker Ant 2017-08-11 06:53:36 EDT
COMMIT: https://review.gluster.org/17979 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit e605d4f6f8807546eb1730e4e5a4c51d7cfe6e6f
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Fri Aug 4 13:33:20 2017 -0400

     packaging: /var/lib/glusterd/options should be %config(noreplace)
    
    /var/lib/glusterd/options is where cluster.enabled-shared-storage is
    persisted. If the file is removed as part of an uninstall/reinstall
    or update then the state of shared storage could be lost.
    
    Change-Id: Ie18c3d883df71c1857fd6996d9c03ab247580b70
    BUG: 1478499
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/17979
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-08-21 09:42:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.5, please open a new bug report.

glusterfs-3.10.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000079.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.