Bug 1476873 - packaging: /var/lib/glusterd/options should be %config(noreplace)
packaging: /var/lib/glusterd/options should be %config(noreplace)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
3.11
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1476861 1478499
Blocks: glusterfs-3.11.2 glusterfs-3.11.3 1476863 1476867
  Show dependency treegraph
 
Reported: 2017-07-31 12:47 EDT by Kaleb KEITHLEY
Modified: 2017-08-24 10:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.11.3
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1476861
Environment:
Last Closed: 2017-08-24 10:46:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-07-31 12:47:05 EDT
+++ This bug was initially created as a clone of Bug #1476861 +++

Description of problem:

/var/lib/glusterd/options is erased when glusterfs-server is removed or updated.

This is where cluster.enable-shared-storage, among other things, is persisted.

When /var/lib/glusterd/options is erased then shared storage may not be enabled after an upgrade.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-07-31 12:24:48 EDT ---

REVIEW: https://review.gluster.org/17930 (packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 1 Worker Ant 2017-07-31 12:50:12 EDT
REVIEW: https://review.gluster.org/17934 (packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on release-3.11 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Worker Ant 2017-08-12 09:40:39 EDT
COMMIT: https://review.gluster.org/17934 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 0b099fc4b38edd9d6af187bbee23af29a874b640
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Mon Jul 31 12:49:16 2017 -0400

    packaging: /var/lib/glusterd/options should be %config(noreplace)
    
    /var/lib/glusterd/options is where cluster.enabled-shared-storage is
    persisted. If the file is removed as part of an uninstall/reinstall
    or update then the state of shared storage could be lost.
    
    Change-Id: Ie18c3d883df71c1857fd6996d9c03ab247580b70
    BUG: 1476873
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/17934
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Comment 3 Shyamsundar 2017-08-24 10:46:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.3, please open a new bug report.

glusterfs-3.11.3 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-August/000081.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.