Bug 1476867 - packaging: /var/lib/glusterd/options should be %config(noreplace)
packaging: /var/lib/glusterd/options should be %config(noreplace)
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.3.0
Assigned To: Milind Changire
Manisha Saini
: Triaged
Depends On: 1476861 1476873 1478499
Blocks: 1417151 1476863
  Show dependency treegraph
 
Reported: 2017-07-31 12:28 EDT by Kaleb KEITHLEY
Modified: 2017-09-21 01:04 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-38
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1476861
Environment:
Last Closed: 2017-09-21 01:04:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2017-07-31 12:28:00 EDT
+++ This bug was initially created as a clone of Bug #1476861 +++

Description of problem:

/var/lib/glusterd/options is erased when glusterfs-server is removed or updated.

This is where cluster.enable-shared-storage, among other things, is persisted.

When /var/lib/glusterd/options is erased then shared storage may not be enabled after an upgrade.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-07-31 12:24:48 EDT ---

REVIEW: https://review.gluster.org/17930 (packaging: /var/lib/glusterd/options should be %config(noreplace)) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 9 Manisha Saini 2017-08-09 07:09:40 EDT
Verified this bug on 

# rpm -qa | grep ganesha
glusterfs-ganesha-3.8.4-38.el7rhgs.x86_64
nfs-ganesha-2.4.4-16.el7rhgs.x86_64
nfs-ganesha-gluster-2.4.4-16.el7rhgs.x86_64


Steps:
1.Create ganesha cluster on RHGS 3.2
2.Create a volume and export the volume via ganesha
3.Set some cluster level options

#gluster  v  set all  cluster.server-quorum-ratio 88

4.Check the entry in /var/lib/glusterd/options

# cat /var/lib/glusterd/options
global-option-version=4
cluster.enable-shared-storage=enable
nfs-ganesha=enable
cluster.server-quorum-ratio=88

5.Upgrade ganesha cluster to 3.3 

6.Again check for cluster options in /var/lib/glusterd/options whether they are persistent after upgrade

# cat /var/lib/glusterd/options 
global-option-version=4
cluster.enable-shared-storage=enable
nfs-ganesha=enable
cluster.server-quorum-ratio=88


# gluster v info
 
Volume Name: ganesha
Type: Replicate
Volume ID: 07faab68-3e77-4dff-bfbc-c757ee688eb6
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: dhcp42-37.lab.eng.blr.redhat.com:/gluster/brick1/1
Brick2: dhcp42-220.lab.eng.blr.redhat.com:/gluster/brick1/1
Options Reconfigured:
nfs.disable: on
performance.readdir-ahead: on
transport.address-family: inet
features.cache-invalidation: on
ganesha.enable: on
cluster.server-quorum-ratio: 88
nfs-ganesha: enable
cluster.enable-shared-storage: enable
 
Volume Name: gluster_shared_storage
Type: Replicate
Volume ID: 8491000b-112d-4fdf-a5db-cb952debda1f
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: dhcp42-220.lab.eng.blr.redhat.com:/var/lib/glusterd/ss_brick
Brick2: dhcp42-37.lab.eng.blr.redhat.com:/var/lib/glusterd/ss_brick
Options Reconfigured:
nfs.disable: on
performance.readdir-ahead: on
transport.address-family: inet
cluster.server-quorum-ratio: 88
nfs-ganesha: enable
cluster.enable-shared-storage: enable
Comment 11 errata-xmlrpc 2017-09-21 01:04:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.