Bug 150839 - sound-juicer crashes clicking 'Extract'
sound-juicer crashes clicking 'Extract'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 151092 151829 152473 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 21:15 EST by Rodd Clarkson
Modified: 2013-03-13 00:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 12:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from running ''gconftool-2 --makefile-install-rule /etc/gconf/schemas/sound-juicer.schemas 2&> /tmp/gconftool.output (355.96 KB, text/plain)
2005-03-22 18:40 EST, Rodd Clarkson
no flags Details
Commands asked for by J^HD5 (786 bytes, text/plain)
2005-04-04 11:26 EDT, Ryan Skadberg
no flags Details

  None (edit)
Description Rodd Clarkson 2005-03-10 21:15:24 EST
Description of problem:

sound-juicer crashes trying to extract CDs.


Version-Release number of selected component (if applicable):

sound-juicer-2.9.91-3


How reproducible:

Always


Steps to Reproduce:
1. Open Sound Juicer with CD in the drive
2. Click 'Extract'

  
Actual results:

sound-juicer disappears, having crashed


Expected results:

sound-juicer begins to extract the CD.
Comment 1 Zuirdj 2005-03-14 16:18:16 EST
Same problem here with sound-juicer-2.10.0-1 from devel, when clicking "extract"
or "preferences". 
Comment 2 John (J5) Palmieri 2005-03-18 16:23:07 EST
Can either of you get the sound-juicer and nautilus-cd-burner debuginfo packages
and run sound-juicer in a gdb session to get me a stack trace of the crash.  I
am seeing a different crash related to the kernel not allowing cd media to
mount.  I can get to preferences fine.
Comment 3 Zuirdj 2005-03-19 09:40:16 EST
(gdb) run sound-juicer
Starting program: /usr/bin/sound-juicer sound-juicer
[Thread debugging using libthread_db enabled]
[New Thread -1208158528 (LWP 3608)]

(sound-juicer:3608): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified
are supported and host-based authentication failed.
Detaching after fork from child process 3611.
[New Thread -1210651728 (LWP 3613)]
Detaching after fork from child process 3614.
[New Thread -1221768272 (LWP 3621)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208158528 (LWP 3608)]
0x08051688 in file_pattern_changed_cb (client=0x8a14170, cnxn_id=4294967295,
    entry=0x8a9cf38, user_data=0x0) at sj-prefs.c:355
355       g_return_if_fail (entry->value->type == GCONF_VALUE_STRING);


[root@x1-6-00-11-09-7b-ad-db zuirdj]# rpm -q sound-juicer
sound-juicer-2.10.0-1
[root@x1-6-00-11-09-7b-ad-db zuirdj]# rpm -q nautilus-cd-burner
nautilus-cd-burner-2.10.0-1
Comment 4 David Nielsen 2005-03-20 05:31:22 EST
I get the following backtrace when I press "preferences" in a gdb controlled
session.

(gdb) run -d
Starting program: /usr/bin/sound-juicer -d
[Thread debugging using libthread_db enabled]
[New Thread -1208863040 (LWP 3140)]
[New Thread -1211270224 (LWP 3143)]
[New Thread -1222161488 (LWP 3144)]
[New Thread -1222972496 (LWP 3145)]
[Thread -1222972496 (LWP 3145) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208863040 (LWP 3140)]
0x08051688 in file_pattern_changed_cb (client=0x88ee4f0, cnxn_id=4294967295,
    entry=0x8aba6c8, user_data=0x0) at sj-prefs.c:355
355       g_return_if_fail (entry->value->type == GCONF_VALUE_STRING);
(gdb) bt
#0  0x08051688 in file_pattern_changed_cb (client=0x88ee4f0,
    cnxn_id=4294967295, entry=0x8aba6c8, user_data=0x0) at sj-prefs.c:355
#1  0x080519fa in on_edit_preferences_cb (item=0x897f8f8, user_data=0x0)
    at sj-prefs.c:429
#2  0x006d36f7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#3  0x006c8172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0x006d79bb in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x006d9107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6  0x006d947b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0x00cd55dd in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x00c07bcf in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#9  0x00c07e85 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x00bff340 in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x00bf9e72 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x006c7c86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#13 0x006c8172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x006d7b47 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#15 0x006d8e7b in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x006d947b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x00cd57e3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x00bf85d7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x00bf8a14 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x001bcce4 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#21 0x008cc46e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0x008cf476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#23 0x008cf763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#24 0x00bf7cd5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x08050c05 in main (argc=2, argv=0x2) at sj-main.c:1088
Comment 5 David Nielsen 2005-03-20 05:34:16 EST
Just for reference this is what happens when I click extract:

(gdb) run -d
Starting program: /usr/bin/sound-juicer -d
[Thread debugging using libthread_db enabled]
[New Thread -1208334656 (LWP 3156)]
[New Thread -1210741840 (LWP 3159)]
[New Thread -1221633104 (LWP 3160)]
[New Thread -1222440016 (LWP 3161)]
[Thread -1222440016 (LWP 3161) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208334656 (LWP 3156)]
0x00697820 in gm_audio_profile_get_extension ()
   from /usr/lib/libgnome-media-profiles.so.0
(gdb) bt
#0  0x00697820 in gm_audio_profile_get_extension ()
   from /usr/lib/libgnome-media-profiles.so.0
#1  0x080561d5 in pop_and_extract () at sj-extracting.c:121
#2  0x006d36f7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#3  0x006c8172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0x006d79bb in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#5  0x006d9107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6  0x006d947b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0x00b409bc in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x00b42141 in gtk_button_get_alignment () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x006d36f7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#10 0x006c7c86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#11 0x006c8172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#12 0x006d7610 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#13 0x006d9107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#14 0x006d947b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#15 0x00b40938 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x00b41834 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x00bf9e72 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#18 0x006c7c86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#19 0x006c8172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#20 0x006d7b47 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#21 0x006d8e7b in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#22 0x006d947b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#23 0x00cd57e3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x00bf85d7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x00bf8a14 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x001bcce4 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#27 0x008cc46e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x008cf476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0x008cf763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0x00bf7cd5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x08050c05 in main (argc=80, argv=0x50) at sj-main.c:1088

Gee I hope I did that right, seeing as I have no gdb skills what so ever.
Comment 6 John (J5) Palmieri 2005-03-22 17:56:59 EST
*** Bug 151092 has been marked as a duplicate of this bug. ***
Comment 7 John (J5) Palmieri 2005-03-22 17:57:26 EST
*** Bug 151829 has been marked as a duplicate of this bug. ***
Comment 8 John (J5) Palmieri 2005-03-22 18:24:34 EST
Can you guys run these commands as root and tell me if they solve the problem:

export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule /etc/gconf/schemas/sound-juicer.schemas
Comment 9 Rodd Clarkson 2005-03-22 18:38:27 EST
Mmm, trying to run the second command I get enormous amounts of output on the
terminal.

I've run 

gconftool-2 --makefile-install-rule /etc/gconf/schemas/sound-juicer.schemas 2&>
/tmp/gconftool.output

and will attach the output as a file.
Comment 10 Rodd Clarkson 2005-03-22 18:40:15 EST
Created attachment 112236 [details]
output from running ''gconftool-2 --makefile-install-rule /etc/gconf/schemas/sound-juicer.schemas 2&> /tmp/gconftool.output
Comment 11 John (J5) Palmieri 2005-03-22 19:43:14 EST
Ok, something is messed up.  Are you sure you are running as root?
Comment 12 Rodd Clarkson 2005-03-22 20:10:09 EST
Slap me upside the head and call me dopey.

Maybe just LART me.

Okay, I've run this as root (as requested, but for some reason ignored.)

Even after all this sound-juicer says bye bye baby!
Comment 13 Rodd Clarkson 2005-03-22 20:14:34 EST
Here's the gdb stuff you're about to ask for:

[rodd@jellyfish ~]$ gdb sound-juicer
GNU gdb Red Hat Linux (6.3.0.0-0.29rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db
library "/lib/tls/libthread_db.so.1".
(gdb) run
Starting program: /usr/bin/sound-juicer
[Thread debugging using libthread_db enabled]
[New Thread -1208711488 (LWP 4993)]
[New Thread -1208714320 (LWP 4996)]
[New Thread -1219204176 (LWP 4997)]
[New Thread -1219994704 (LWP 4998)]
[Thread -1219994704 (LWP 4998) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208711488 (LWP 4993)]
0x03b06820 in gm_audio_profile_get_extension () from
/usr/lib/libgnome-media-profiles.so.0
(gdb) bt
#0  0x03b06820 in gm_audio_profile_get_extension () from
/usr/lib/libgnome-media-profiles.so.0
#1  0x080561d5 in pop_and_extract () at sj-extracting.c:121
#2  0x0066b6f7 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#3  0x00660172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0x0066f9bb in g_signal_connect_closure_by_id () from
/usr/lib/libgobject-2.0.so.0
#5  0x00671107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6  0x0067147b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0x008b89bc in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#8  0x008ba141 in gtk_button_get_alignment () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x0066b6f7 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#10 0x0065fc86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#11 0x00660172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#12 0x0066f610 in g_signal_connect_closure_by_id () from
/usr/lib/libgobject-2.0.so.0
#13 0x00671107 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#14 0x0067147b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#15 0x008b8938 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x008b9834 in gtk_button_set_relief () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x00971e72 in gtk_marshal_VOID__UINT_STRING () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x0065fc86 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#19 0x00660172 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#20 0x0066fb47 in g_signal_connect_closure_by_id () from
/usr/lib/libgobject-2.0.so.0
#21 0x00670e7b in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#22 0x0067147b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#23 0x00a4d7e3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x009705d7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x00970a14 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x007a2ce4 in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#27 0x005ec46e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x005ef476 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0x005ef763 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0x0096fcd5 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x08050c05 in main (argc=80, argv=0x50) at sj-main.c:1088
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[rodd@jellyfish ~]$

Comment 14 Ryan Skadberg 2005-03-22 20:15:34 EST
Yeah, same here, still crashes after running that.
Comment 15 John (J5) Palmieri 2005-03-29 15:49:35 EST
*** Bug 152473 has been marked as a duplicate of this bug. ***
Comment 16 Zuirdj 2005-03-31 20:07:52 EST
Problem persist in sound-juicer-2.10.0-2
Comment 17 John (J5) Palmieri 2005-04-04 10:37:32 EDT
Can you guys run these commands and post the output.  Also note if you upgraded
or did a fresh install of sound-juicer:

gconftool-2 --get "/apps/sound-juicer/audio_profile"
gconftool-2 --get-type "/apps/sound-juicer/audio_profile"
gconftool-2 --get "/apps/sound-juicer/base_path"
gconftool-2 --get-type "/apps/sound-juicer/base_path"
gconftool-2 --get "/apps/sound-juicer/file_pattern"
gconftool-2 --get-type "/apps/sound-juicer/file_pattern"
gconftool-2 --get "/apps/sound-juicer/path_pattern"
gconftool-2 --get-type "/apps/sound-juicer/path_pattern"

Thanks
Comment 18 Ryan Skadberg 2005-04-04 11:26:15 EDT
Created attachment 112654 [details]
Commands asked for by J^HD5

Here's the output of the gconftool commands asked for by J^HD5
Comment 19 David Nielsen 2005-04-04 11:47:55 EDT
[dnielsen@localhost ~]$ gconftool-2 --get "/apps/sound-juicer/audio_profile"
No value set for `/apps/sound-juicer/audio_profile'
[dnielsen@localhost ~]$ gconftool-2 --get-type "/apps/sound-juicer/audio_profile"
No value set for `/apps/sound-juicer/audio_profile'
[dnielsen@localhost ~]$ gconftool-2 --get "/apps/sound-juicer/base_path"
/home/dnielsen/Musik
[dnielsen@localhost ~]$ gconftool-2 --get-type "/apps/sound-juicer/base_path"
string
[dnielsen@localhost ~]$ gconftool-2 --get "/apps/sound-juicer/file_pattern"
No value set for `/apps/sound-juicer/file_pattern'
[dnielsen@localhost ~]$ gconftool-2 --get-type "/apps/sound-juicer/file_pattern"
No value set for `/apps/sound-juicer/file_pattern'
[dnielsen@localhost ~]$ gconftool-2 --get "/apps/sound-juicer/path_pattern"
No value set for `/apps/sound-juicer/path_pattern'
[dnielsen@localhost ~]$ gconftool-2 --get-type "/apps/sound-juicer/path_pattern"
No value set for `/apps/sound-juicer/path_pattern'
[dnielsen@localhost ~]$

The problem has presisted since FC4 test1, which was a clean install. System is
updated to 04-03-05 Development
Comment 20 John (J5) Palmieri 2005-04-04 18:21:52 EDT
New 2.10.1-1 should fix the extract crash.  Preference dialog crash may or may
not be fixed.  Please test out new packages when they hit rawhide tomorrow and
report back if it fixes your problems.
Comment 21 David Nielsen 2005-04-05 11:47:57 EDT
J5... you are a god amongst men, it works as it's supposed to, preferences and
extracting..
Comment 22 John (J5) Palmieri 2005-04-05 12:17:09 EDT
Yay, closing.
Comment 23 Zuirdj 2005-04-05 13:14:44 EDT
Thanks for the work!

Note You need to log in before you can comment on or make changes to this bug.