Bug 150887 - can't install from ISOs tree (nfs, hd; exploded isos work)
can't install from ISOs tree (nfs, hd; exploded isos work)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 151203 151895 152121 154480 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 12:46 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-06 22:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
(untested) patch that fixes the likely cut&pasto (609 bytes, patch)
2005-03-11 12:49 EST, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2005-03-11 12:46:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6)
Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Anaconda fails if it's given a directory containing ISOs to install
from, as opposed to one containing an exploded tree.  The problem is
that, when looking for the iso image containing disc1, it
loopback-mounts the iso, then loopback-mounts a stage file in there
into /mnt/runtime, but then, instead of umounting /mnt/runtime, it
umounts /tmp/runtime, so the loopback device remains busy, and the iso
loopback mount can't be umounted.  Then, when it proceeds to mount the
iso and the stage image for the install, it fails because the loop
devices are busy.

Version-Release number of selected component (if applicable):
anaconda-10.2.0.27-1

How reproducible:
Always

Steps to Reproduce:
1.Point anaconda at a tree containing install isos

Actual Results:  It claims the directory tree does not contain an
installable tree.  VT3 shows the failure to umount and the failure to
re-mount.

Expected Results:  It worked in FC3.

Additional info:

I have a patch that I'll attach momentarily.
Comment 1 Alexandre Oliva 2005-03-11 12:49:33 EST
Created attachment 111899 [details]
(untested) patch that fixes the likely cut&pasto
Comment 2 Chris Lumens 2005-03-11 13:59:21 EST
Thanks for the patch - it's applied and will go into the next anaconda build.
Comment 3 Jeremy Katz 2005-03-15 19:16:13 EST
*** Bug 151203 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2005-03-28 13:56:27 EST
*** Bug 151895 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2005-03-28 13:58:04 EST
*** Bug 152121 has been marked as a duplicate of this bug. ***
Comment 6 Jim McElwaine 2005-04-06 12:50:33 EDT
If you download the anacdonda files from
http://download.fedora.redhat.com/pub/fedora/linux/core/test/3.90/i386/os/isolinux/
they are still broken and you can't do a hardisk install. There don't seem to be
any new ones in the updates tree. Where do I get them from ? 
Comment 7 Alexandre Oliva 2005-04-06 22:02:15 EDT
Did you try the `development' tree (fedora/linux/core/development/...)?  It
should be there.  And then, there's the upcoming FC4test2, in which this is
going to work (confirmed with an internal compose last night).
Comment 8 Jeremy Katz 2005-04-12 11:26:11 EDT
*** Bug 154480 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.