Bug 1536401 - [Tracker] RHCS 2.5 Release Notes
Summary: [Tracker] RHCS 2.5 Release Notes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 2.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.5
Assignee: Aron Gunn
QA Contact: ceph-qe-bugs
Aron Gunn
URL:
Whiteboard:
Depends On: 1444139 1458007 1461581 1488389 1489060 1489063 1491723 1491739 1496509 1500100 1500904 1502780 1505561 1507120 1507645 1508935 1509359 1509584 1511139 1514210 1515275 1518968 1522881 1523447 1525209 1527548 1530938 1533266 1535906 1537035 1537390 1537505 1538124 1538319 1538331 1541303 1546127 1546175 1548071 1548481 1550892 1554963 1568897 1573656 1574231 1576487 1578401 1578670 1581579 1584218 1584829 1591455 1595374 1595383 1595386 1599507
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-19 11:04 UTC by Anjana Suparna Sriram
Modified: 2018-07-24 21:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-23 08:50:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anjana Suparna Sriram 2018-01-19 11:04:21 UTC
This tracker bug is not a tracker just for known issues but for every change that should appear in the Release Notes - major updates, technical previews, deprecated functions, and so on.

If there is a change that does not have a separate bug (for example it is a change introduced in a rebase), add that rebase bug as a blocker and specify the nature of the change in the doc text field of that bug.

**How to let us know that a bug should be documented in the Release Notes**

1) Add the BZ number of the bug that needs to be documented to the "Depends On" field in the Release Notes tracker bug. Alternatively, add the tracker bug BZ number to the "Blocks" field in the bug that needs to be documented.

2) In the bug that needs to be documented, set the doctype to one of the following:

* bug fix - for notable bug fixes that have significant impact on customers

* enhancement - for new features and major enhancements, RFE bugs

* technology preview - for new features shipped as tech previews

* known issues - for the known issues found in this release

3) In the bug that needs to be documented, fill in the Doc Text field with the initial information. Use the template that is in the field.

----

**Candidates for inclusion**

* Bugs with a customer case attached

* Major new features and enhancements

* Bugs with significant impact on users

* Urgent or high priority bugs

* Fixed known issues

----

**How a good initial description looks like**

* Use the cause-consequence-fix-result (CCFR) format for bug fixes:

  Cause – what user action or circumstances trigger this bug 
    
  Consequence – what the user experiences when the bug occurs 
   
  Fix – what has been changed to fix the bug (overly technical details are not necessary)
    
  Result – what happens now with the fix applied

* Use the feature-reason-result (FFR) format for major updates:

    Feature – describes the enhancement from the user's point of view
    
    Reason – why was the enhancement implemented
    
    Result – what is the current user experience (may also be compared to the previous user experience)

----

**I want to document a change that does not have bug - how to do it?**

Add a comment here, we will add that description manually.

Comment 3 Vasishta 2018-01-30 04:36:31 UTC
Hi,

Issue mentioned in BZ 1509279 needs to be release noted as known issue.


Regards,
Vasishta


Note You need to log in before you can comment on or make changes to this bug.