Bug 1555931 - Installation fails due to a scriptlet failure of tex-fonts-hebrew [NEEDINFO]
Summary: Installation fails due to a scriptlet failure of tex-fonts-hebrew
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-base
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1621922 1644753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 21:22 UTC by George R. Goffe
Modified: 2018-11-23 05:02 UTC (History)
20 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-11-08 03:15:58 UTC
awilliam: needinfo? (tcallawa)


Attachments (Terms of Use)
Anaconda abort (175.04 KB, image/jpeg)
2018-10-31 14:20 UTC, Leslie Satenstein
no flags Details
Anaconda What caused the abort. (167.95 KB, image/jpeg)
2018-10-31 14:21 UTC, Leslie Satenstein
no flags Details
packaging.log from anaconda (1.15 MB, text/plain)
2018-11-13 03:03 UTC, Ian Donaldson
no flags Details
dnf install tex-fonts-hebrew output (38.77 KB, text/plain)
2018-11-13 04:20 UTC, Ian Donaldson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1398847 None CLOSED Fedora 25 Install from DVD ISO Fails DNF error: Non-fatal POSTIN scriptlet failure ... dovecot 2019-05-22 13:29 UTC

Internal Trackers: 1398847

Description George R. Goffe 2018-03-14 21:22:57 UTC
Description of problem: 

Where is the category for this bug? I guessed at anaconda.

Attempting to install from an iso image fails repeatedly. 
Fedora-Everything-netinst-x86_64-Rawhide-20180312.n.0.iso

message reads: DNF error: non-fatal POSTIN scriptlet failure in rpm package tex-fonts-hebrew

I booted in recovery mode from this same iso image and did a "dnf reinstall tex-fonts-hebrew" (why hebrew when this systems language is english?) There were two prompts. The first one asked if it was ok to do the operation, the second one asked if it was ok to install a GPG key. Perhaps this is what causes the failure?

There are other problems with this UI.
1) The advertisements at the bottom of the screen are truncated on the right, even in full screen mode.
2) White on yellow (or orange) messages during root password and user creation are VERY difficult to read, perhaps black on yellow (or orange) would resolve this?
3) I had trouble with push buttons on the far right during hdd configuration. During one attempt I had to scroll up/down left/right to see the buttons, even in full screen mode. I would suggest moving the buttons closer to where the user is typing.

Version-Release number of selected component (if applicable):
see above

How reproducible:
always

Steps to Reproduce:
1.I selected customized hdd config
2.I selected KDE Plasma workstation and selected all pkgs available
3.All of this activity has worked on several older versions of this install methodology.

Actual results:
failed installation

Expected results:
successful/clean installation

Additional info:

Installation was done under several different versions of VirtualBox with the same results.

Comment 1 Jiri Konecny 2018-03-15 12:47:41 UTC
Hello,

First problem is problem in RPM file and duplicate of bug 1398847. For the second part of this bug it is hard to create design which works for everyone but if you really want those changes please create a new bug for them, they are not related to the first issue at all.

Jirka

Comment 2 George R. Goffe 2018-04-05 15:42:33 UTC
This problem STILL exists with the latest iso image. It appears that NONE of the changes required for this install to succeed have been resolved. This was with the latest Fedora-Everything-netinst-x86_64-Rawhide-20180402.n.0.iso file which is the SAME file as reported by this bug.

Here's the path to the iso image. https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/iso/

Comment 3 Vendula Poncova 2018-04-06 10:14:38 UTC
Reassigning to tex-fonts-hebrew to fix the scriptlet failure.
Please, open a separate bug for the UI issues.

Comment 4 George R. Goffe 2018-04-07 06:13:33 UTC
Vendula,

Thanks for your help with these problems. I made a bug for the UI issues I found, it's at "https://bugzilla.redhat.com/show_bug.cgi?id=1557538"

George...

Comment 5 Bruce Jerrick 2018-05-26 01:06:14 UTC
This is a copy of my Comment 21 to RHBZ 1398847:

I get the same fatal non-fatal POSTIN scriptlet errors on the following packages
during an F28 kickstart installation:

  clamav-update-0.99.4-3.fc28 (also happened in F25)
  dpkg-1.18.24-6.fc28
  starplot-gliese3-0.95-15.fc28
  starplot-yale5-0.95-15.fc28

And the same thing in the past with these:

  mozplugger (during F26 kickstart installation)
  lirc-core (during F27 Kickstart installation)

All of these are repeatable.
Even if the packages themselves are faulty, anaconda and dnf need to settle their
differences about whether this is fatal or non-fatal.  (In any case, it would be
nice if anaconda could wait until all packages are tried before croaking; as it
is, one has to re-run the installation to get to the next fatality.)

As others have reported, the package installations succeed when done in the
running system (after excluding them from the kickstart installation).

UPDATE: According to https://kb.vmware.com/s/article/2040939 :

  By default, the RPM installer unpacks a temporary JRE to the /tmp directory,
  which is used for the remainder of the installation process.
  The error Non-fatal POSTIN scriptlet failure is the result of an SElinux
  policy that prevents executables from running in the /tmp directory. Even
  though the directory and unpacked files may have execute permissions, the
  system prevents the executables from running.

That article provides a workaround (setting an alternative TMPDIR).

Comment 6 Jiri Konecny 2018-05-28 07:32:32 UTC
Hello Bruce,

We have already done that. Look on the bug 1565123 which is result of this decision. In short, these errors will be fatal when that patch will be applied.

Comment 7 Leslie Satenstein 2018-06-09 03:56:15 UTC
I am trying to install F28 KDE from the network installation iso and 
have encountered this bug.

Anaconda dies before it can complete the installation.

iso=Fedora-Workstation-netinst-x86_64-28-1.1.iso

From anaconda.log
17:35:45,287 DBG ui.common: Left spoke: UserSpoke
17:50:10,987 INF progress: Preparing transaction from installation source
22:16:19,147 WRN misc: /usr/lib64/python3.6/site-packages/gi/overrides/GObject.py:553: Warning: gsignal.c:2641: instance '0x55a2de81e630' has no handler with id '371704'
  return func(*args, **kwargs)

22:16:19,147 WRN misc: /usr/lib64/python3.6/site-packages/gi/overrides/GObject.py:553: Warning: gsignal.c:2641: instance '0x55a2de81e630' has no handler with id '371705'
  return func(*args, **kwargs)



If it is relevant, I have a separate 10gig  ext4  formatted partition for /var

Comment 8 George R. Goffe 2018-08-09 15:27:00 UTC
Hi,

This problem still exists in the .iso file from https://dl.fedoraproject.org/pub/fedora/linux/releases/28/Workstation/x86_64/iso/Fedora-Workstation-netinst-x86_64-28-1.1.iso.

I thought we put a spike in this one but apparently(?) the problem still exists. Did the .iso get rebuilt after the fix hit the fan?

Best regards,

George...

Comment 9 Jan Kurik 2018-08-14 10:26:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 10 Leslie Satenstein 2018-08-27 12:41:38 UTC
Please add the following...


Fatal Error:  DNF error: Error in POSTIN scriptlet in rpm package 
container-selinux 

Trying to install a minimal Gnome F29 Developement, LibreOffice, Editors and Games.

Comment 11 Leslie Satenstein 2018-09-04 14:23:42 UTC
Similar problem with  Fedora 29 for the Testing that is to take place this week.


container-selinux-2.71-1.git5721d74.fc29.noarch.rpm
tex-fonts-hebrew-0.1-28.fc29.noarch.rpm

 621805568 Sep  3 04:37 Fedora-Everything-netinst-x86_64-29-20180903.n.0.iso
1901068288 Sep  3 09:10 Fedora-Workstation-Live-x86_64-29-20180903.n.0.iso
 621805568 Sep  3 04:30 Fedora-Workstation-netinst-x86_64-29-20180903.n.0.iso

Comment 12 Leslie Satenstein 2018-09-22 01:58:14 UTC
I cannot run any of the betas (network or Everything-network installation.

Obviously, cannot go live with F29 if we cannot complete an installation.

Comment 13 Leslie Satenstein 2018-09-25 18:38:12 UTC
Needs to be addressed.

The txtfonts issue is created when the user selects 

Gnome and Authoring tools from the Anaconda pick list.

LATEX is the software that appears to need 

See   1621922

My guess

Authoring tools, Latex Fedora 29 Beta-1-5

Comment 14 George R. Goffe 2018-09-26 18:37:16 UTC
There is another bug(?) lurking around here.

I try to install on a VM provided by VirtualBox and get strange errors. Anaconda just stops and abandons the installation. The last situation I looked at showed me an "out of memory" message. I had been installing on a 1G VM. I raised the memory to 2G and tried again. I was successful in the installation. I won't swear to it but I think the options I chose were the same as those for the failure to install.

I'm not sure just how the above affects these other bugs that people are seeing.

George...

Comment 15 Leslie Satenstein 2018-10-13 00:25:52 UTC
This problem is for the GO GOLD decision for Fedora 29.  


tex-fonts-hebrew"  

Category is anaconda

I tested today with the following ISOs.
Fedora-Everything-netinst-aarch64-29-20181011.n.0.iso
Fedora-Everything-netinst-x86_64-29-20181011.n.0.iso
Fedora-Workstation-netinst-x86_64-29-20181011.n.0.iso

I do not have a VM system, I install on hardware. Ergo, I cannot have the network install versions active while I write this bug report. But

Choose Fedora Workspace as left index  and 

**Programming and authoring** group.

Note Initial entry and Comment 13.

Comment 16 Leslie Satenstein 2018-10-18 13:40:13 UTC
This problem is for the GO GOLD decision for Fedora 29.  


tex-fonts-hebrew"  

Category is anaconda  Fails with
Fedora-Everything-netinst-aarch64-29-20181016.n.0.iso
Fedora-Everything-netinst-x86_64-29-20181016.n.0.iso
Fedora-Workstation-netinst-x86_64-29-20181016.n.0.iso

The anaconda menu choice is:  Authoring and Publishing

I would like to test this group within Anaconda.

Manually, when doing 

          sudo dnf group install "Authoring and Publishing", 

the syntax error is presented, but partial installation takes place, skipping some item(s) or another.

Comment 17 Jiri Konecny 2018-10-19 08:53:49 UTC
These groups are loaded from the comps file. Anaconda only presents this file to a user. Similar is true for DNF. So if there is bad package set then the comps file needs to be changed.

Comment 18 Leslie Satenstein 2018-10-31 14:20 UTC
Created attachment 1499426 [details]
Anaconda abort

Fedora 29  Anaconda crash, The go live and this bug that was reported initially in August, with reminders....

Comment 19 Leslie Satenstein 2018-10-31 14:21 UTC
Created attachment 1499427 [details]
Anaconda What caused the abort.

The dnf group that is at the cause.  F28 was working.

Comment 20 Leslie Satenstein 2018-10-31 14:22:46 UTC
This problem is in the Fedora GOLD  for Fedora 29.

Comment 21 Edgar Hoch 2018-11-01 00:01:04 UTC
I think package tex-fonts-hebrew should be excluded from group "Authoring and Publishing" because of missing updates and no response of the maintainer since Fedora 25. I reported bug 1421542 in early 2017, no responce. Excluding the package from the group would help new admins to not run into the same problem.

Package tex-fonts-hebrew still contains the old, wrong scriptlets. When installing on Fedora 29, I get the following error:

Running transaction
  Preparing        :                                                                      1/1 
Installed: tex-fonts-hebrew-0.1-28.fc29.noarch
  Installing       : tex-fonts-hebrew-0.1-28.fc29.noarch                                  1/1 
  Running scriptlet: tex-fonts-hebrew-0.1-28.fc29.noarch                                  1/1 
/usr/bin/texconfig-sys: line 33: exec: texconfig: not found
Option cnffile requires an argument
Try "updmap --help" for more information.
warning: %post(tex-fonts-hebrew-0.1-28.fc29.noarch) scriptlet failed, exit status 255

Error in POSTIN scriptlet in rpm package tex-fonts-hebrew

Comment 22 George R. Goffe 2018-11-01 00:46:02 UTC
Edgar,

Good catch.

FIY: There's also a ".iso" installation failure bug in Virtual Machines with 1G memory defined... Going up to 2G seems to resolve the problem.

George...

Comment 23 Bruce Jerrick 2018-11-01 05:55:54 UTC
(In reply to George R. Goffe from comment #22)
> Edgar,
> 
> Good catch.
> 
> FIY: There's also a ".iso" installation failure bug in Virtual Machines with
> 1G memory defined... Going up to 2G seems to resolve the problem.
> 
> George...

This sounds like RHBZ 1470909 -- not enough working space in anything listed in DOWNLOAD_MPOINTS in dnfpayload.py (which includes /tmp; being tmpfs, its size increases with more memory).

Comment 24 Vendula Poncova 2018-11-01 12:47:10 UTC
Reassigning to comps based on the comment 21.

Comment 25 Stephen Gallagher 2018-11-01 12:53:12 UTC
If this doesn't work at all and the maintainer has disappeared, please follow https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers to have the package orphaned and announced for a new maintainer.

Comment 26 Vendula Poncova 2018-11-01 12:56:11 UTC
*** Bug 1644753 has been marked as a duplicate of this bug. ***

Comment 27 Adam Williamson 2018-11-01 17:40:54 UTC
Note, it's not really possible to remove a package from comps for any released distro. The comps for the base repo are frozen; there's no way to send a comps 'update' that says 'tex-fonts-hebrew is no longer in this group', AFAIK. We should just fix the scriptlet, for still-supported releases.

Comment 28 Adam Williamson 2018-11-01 17:41:43 UTC
*** Bug 1621922 has been marked as a duplicate of this bug. ***

Comment 29 Edgar Hoch 2018-11-01 17:49:29 UTC
(In reply to Adam Williamson from comment #27)
> Note, it's not really possible to remove a package from comps for any
> released distro. The comps for the base repo are frozen; there's no way to
> send a comps 'update' that says 'tex-fonts-hebrew is no longer in this
> group', AFAIK. We should just fix the scriptlet, for still-supported
> releases.

I know that comps are frozen for a released distro, but removal would be an option for the next release.

Another, perhaps better way would be to fix the bug and get a working package again.

Comment 30 Adam Williamson 2018-11-01 18:02:34 UTC
This actually appears to be a bug in texlive-tetex.

tex-fonts-hebrew tries to do this:

%post
conffile="$(/usr/bin/texconfig-sys conf | /bin/grep updmap.cfg)"
if [ "$1" = "1" ]; then
  /usr/bin/updmap-sys --quiet --nohash --cnffile ${conffile} --enable Map=culmus.map
fi

it has appropriate requirements for this in place:

Requires(post): /usr/bin/texhash /usr/bin/updmap-sys /usr/bin/texconfig-sys

However, it fails, because texconfig-sys fails:

/usr/bin/texconfig-sys: line 33: exec: texconfig: not found

This is because texlive-tetex is missing a dependency, seemingly. texconfig-sys is shipped in texlive-tetex, and - per that error message - clearly needs /usr/bin/texconfig to be present to work. But /usr/bin/texconfig is shipped in texlive-texconfig , and texlive-tetex does not require texlive-texconfig.

Comment 31 Fedora Update System 2018-11-01 20:46:05 UTC
texlive-base-20180414-25.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3ebbeee8fc

Comment 32 Fedora Update System 2018-11-01 20:46:17 UTC
texlive-base-20170520-42.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b9042e90eb

Comment 33 Fedora Update System 2018-11-02 23:41:36 UTC
texlive-base-20170520-42.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b9042e90eb

Comment 34 Fedora Update System 2018-11-03 00:54:46 UTC
texlive-base-20180414-25.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3ebbeee8fc

Comment 35 Adam Williamson 2018-11-03 03:52:26 UTC
*** Bug 1621922 has been marked as a duplicate of this bug. ***

Comment 36 Leslie Satenstein 2018-11-05 04:33:47 UTC
(In reply to Edgar Hoch from comment #21)
> I think package tex-fonts-hebrew should be excluded from group "Authoring
> and Publishing" because of missing updates and no response of the maintainer
> since Fedora 25. I reported bug 1421542 in early 2017, no responce.
> Excluding the package from the group would help new admins to not run into
> the same problem.
> 
> Package tex-fonts-hebrew still contains the old, wrong scriptlets. When
> installing on Fedora 29, I get the following error:
> 
> Running transaction
>   Preparing        :                                                        
> 1/1 
> Installed: tex-fonts-hebrew-0.1-28.fc29.noarch
>   Installing       : tex-fonts-hebrew-0.1-28.fc29.noarch                    
> 1/1 
>   Running scriptlet: tex-fonts-hebrew-0.1-28.fc29.noarch                    
> 1/1 
> /usr/bin/texconfig-sys: line 33: exec: texconfig: not found
> Option cnffile requires an argument
> Try "updmap --help" for more information.
> warning: %post(tex-fonts-hebrew-0.1-28.fc29.noarch) scriptlet failed, exit
> status 255
> 
> Error in POSTIN scriptlet in rpm package tex-fonts-hebrew


It is also appearing in other groups. You would have to exclude them. (Other groups in KDE, Gnome and I suppose, in spins). 

With Fedora28 I ran distrosync, as some kind individual migrated the F27 version to F28.

Can someone migrate the F28 distro-sync'd version to F29.

Comment 37 Fedora Update System 2018-11-08 03:15:58 UTC
texlive-base-20180414-25.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 38 Ian Donaldson 2018-11-13 00:06:02 UTC
texlive-base-20180414-25.fc29 was in the fc29 release (in Everything);
I presume you mean texlive-base-20180414-26.fc29.x86_64.rpm which
just turned up on the mirrors.

Anyway that package update hasn't solved this issue for me 
in kickstart; I suspect you meant to update the requires
of texlive-tetex to include texlive-texconfig rather than
modify textlive-base.

Comment 39 Ian Donaldson 2018-11-13 00:09:45 UTC
However I do see texlive-tetex-20180414-26.fc29.noarch.rpm has also been released
which does have a requires of texlive-texconfig ... hmmm.

Comment 40 Ian Donaldson 2018-11-13 00:13:38 UTC
Of course kickstart only uses Everything; not the updates.... which is
why I'm still seeing the issue.   (texlive-tetex ... -24 is there)

Comment 41 Adam Williamson 2018-11-13 00:13:46 UTC
Does your kickstart actually include the updates repository?

Comment 42 Ian Donaldson 2018-11-13 00:24:51 UTC
Not sure how to specify that for anaconda; the %post does a yum update but thats
too late for anaconda.
 
I'm trying adding textlive-texconfig earlier in the package list
(before @authoring-and-publishing; it didn't work when added after...)

Comment 43 Ian Donaldson 2018-11-13 00:28:04 UTC
Oh, trying 'repo' now; overlooked that...

Comment 44 Edgar Hoch 2018-11-13 00:33:34 UTC
(In reply to Ian Donaldson from comment #42)
> Not sure how to specify that for anaconda

Just put these lines in your kickstart file:

repo --name=fedora
repo --name=updates

Comment 45 Ian Donaldson 2018-11-13 03:01:55 UTC
I added a repo line for updates and now it loads the latest
version of these packages but still falls over at tex-fonts-hebrew
with the same error.

Anaconda has this on its screen:

DNF error: Error in POSTIN scriptlet in rpm package text-fonts-hebrew

and anaconda stalls with that package name at the bottom in the progress bar.

Using a CTRL-ALT-F5 while anaconda is stuck and a chroot /mnt/sysimage 
I see that these are installed:


[anaconda root@cc02 /]# rpm -q texlive-texconfig tex-fonts-hebrew
texlive-texconfig-20180414-26.fc29.noarch
tex-fonts-hebrew-0.1-28.fc29.noarch


and anaconda's /tmp/packaging.log (outside the chroot) shows this:

----
13:00:40,029 INF dnf.rpm: Installed: texlive-texconfig-7:20180414-26.fc29.noarch
13:00:40,030 INF packaging: Installed: texlive-texconfig-7:20180414-26.fc29.noarch 1541690087 2be16a3059a934a291be6e1cc5609e12a69a43167fa0bcd264d2c69a9a2a54a5
13:00:40,060 INF dnf.rpm: Installed: texlive-texconfig-7:20180414-26.fc29.noarch
----
 ..
----
13:15:38,007 INF dnf.rpm: Installed: texlive-kerkis-8:svn15878.0-21.fc29.noarch
13:15:38,041 INF dnf.rpm: Installed: tex-fonts-hebrew-0.1-28.fc29.noarch
13:15:38,042 INF packaging: Installed: tex-fonts-hebrew-0.1-28.fc29.noarch 1531661689 9e6abd1fd629e6ae04cf949e15169d7b35872f0a7f4d7389c72b6034e85627e3
13:15:38,281 INF packaging: Configuring (running scriptlet for): tex-fonts-hebrew-0.1-28.fc29.noarch 1531661689 9e6abd1fd629e6ae04cf949e15169d7b35872f0a7f4d7389c72b6034e85627e3
13:15:39,940 ERR dnf.rpm: Error in POSTIN scriptlet in rpm package tex-fonts-hebrew
13:15:39,942 INF dnf.rpm: Installed: tex-fonts-hebrew-0.1-28.fc29.noarch
----

and there are  a bunch of packages installed after this according to
the log (for another 4 mins), but Anaconda thinks things have stopped.

this is the end of the log:


----
13:19:13,201 INF dnf.rpm: Installed: atmel-firmware-1.3-19.fc29.noarch
13:19:13,289 INF dnf.rpm: Installed: atmel-firmware-1.3-19.fc29.noarch
13:25:23,481 Level 8 dnf: RPM transaction over.
13:26:30,560 Level 8 dnf: timer: verify transaction: 66912 ms
13:26:30,566 Level 8 dnf: timer: transaction: 2441367 ms
13:26:30,575 Level 8 dnf: Cleaning up.
----

Reinstalling tex-fonts-hebrew under the chroot shows no errors though,
so clearly something changed between the first attempt by anaconda and now.


----
[anaconda root@cc02 ~]# chroot /mnt/sysimage
[anaconda root@cc02 /]# dnf reinstall tex-fonts-hebrew
Last metadata expiration check: 0:14:22 ago on Tue Nov 13 02:42:47 2018.
Dependencies resolved.
=================================================================================================================
 Package                         Arch                  Version                       Repository             Size
=================================================================================================================
Reinstalling:
 tex-fonts-hebrew                noarch                0.1-28.fc29                   fedora                 66 k

Transaction Summary
=================================================================================================================

Total download size: 66 k
Installed size: 220 k
Is this ok [y/N]: y
Downloading Packages:
tex-fonts-hebrew-0.1-28.fc29.noarch.rpm                                          494 kB/s |  66 kB     00:00    
-----------------------------------------------------------------------------------------------------------------
Total                                                                             22 kB/s |  66 kB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                         1/1 
Reinstall: tex-fonts-hebrew-0.1-28.fc29.noarch
  Reinstalling     : tex-fonts-hebrew-0.1-28.fc29.noarch                                                     1/2 
  Running scriptlet: tex-fonts-hebrew-0.1-28.fc29.noarch                                                     1/2 
Reinstall: tex-fonts-hebrew-0.1-28.fc29.noarch
Reinstalled: tex-fonts-hebrew-0.1-28.fc29.noarch
  Cleanup          : tex-fonts-hebrew-0.1-28.fc29.noarch                                                     2/2 
Reinstalled: tex-fonts-hebrew-0.1-28.fc29.noarch
  Running scriptlet: tex-fonts-hebrew-0.1-28.fc29.noarch                                                     2/2 
  Verifying        : tex-fonts-hebrew-0.1-28.fc29.noarch                                                     1/2 
  Verifying        : tex-fonts-hebrew-0.1-28.fc29.noarch                                                     2/2 

Reinstalled:
  tex-fonts-hebrew-0.1-28.fc29.noarch                                                                            

Complete!

I'll attach the complete packaging.log if thats of any use...

Comment 46 Ian Donaldson 2018-11-13 03:03 UTC
Created attachment 1505085 [details]
packaging.log from anaconda

as mentioned...

Comment 47 Ian Donaldson 2018-11-13 04:19:12 UTC
I've managed to reproduce some errors by installing tex-fonts-hebrew
on another system running fc29 (distro-sync'd from fc28)

I'm attaching the long from that install but the jist of it
is that updmap is complaining a lot...

updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]:         Acorn.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
updmap [ERROR]:         Alegreya.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
updmap [ERROR]:         AnnSton.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
updmap [ERROR]:         AnonymousPro.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
...
updmap [ERROR]: Did you run mktexlsr?

        You can disable non-existent map entries using the option
          --syncwithtrees.

warning: %post(tex-fonts-hebrew-0.1-28.fc29.noarch) scriptlet failed, exit status 1

Error in POSTIN scriptlet in rpm package tex-fonts-hebrew
Installed: tex-fonts-hebrew-0.1-28.fc29.noarch


So this could be a clue...

Comment 48 Ian Donaldson 2018-11-13 04:20 UTC
Created attachment 1505099 [details]
dnf install tex-fonts-hebrew output

Comment 49 Ian Donaldson 2018-11-13 04:34:56 UTC
https://lists.debian.org/debian-tex-maint/2013/06/msg00070.html  seems
to be suspiciously similar to this issue; however the fix there
was to install texlive-lang-other (debian) but there is no fedora
package of that name; perhaps its called something else?

Comment 50 Ian Donaldson 2018-11-13 04:43:57 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1595278 also seems related
but I know very little about tex

Comment 51 Ian Donaldson 2018-11-14 02:14:09 UTC
IMHO the Status of this issue should not be CLOSED

Comment 52 Edgar Hoch 2018-11-14 03:08:28 UTC
I have still excluded package tex-fonts-hebrew, so I had no problem with it. So I thought I should test it now.

I confirm that there are still scriptlet errors in package
texlive-base-20180414-26.fc29.x86_64

The error differs from the one originally reported, because now there is no program missing, but a config file contains wrong values (missing map). May be we need to create a separate bug report for this.

The errors are similar to comment #47, but it seams that it depends on the installed packages which map files could not found. My list on one test system is shorter:

updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]: 	Coelacanth.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
updmap [ERROR]: Did you run mktexlsr?

	You can disable non-existent map entries using the option
	  --syncwithtrees.

Warnung: %post(tex-fonts-hebrew-0.1-28.fc29.noarch) Scriptlet fehlgeschlagen, Beenden-Status 1

Error in POSTIN scriptlet in rpm package tex-fonts-hebrew

Comment 53 Ian Donaldson 2018-11-14 04:00:25 UTC
Is there a way to make Anaconda ignore packages with install errors and just
keep going?

Comment 54 Martin Kolman 2018-11-14 04:21:37 UTC
(In reply to Ian Donaldson from comment #53)
> Is there a way to make Anaconda ignore packages with install errors and just
> keep going?
There is no way to make Anaconda ignore package scriptlet errors. This is by design as many scriptlets (such as those run by the kernel package) are critical and their failure will result in a broken system.

Comment 55 Adam Williamson 2018-11-14 05:19:12 UTC
Please do file a new bug with details of the new failure, I'll try and help take a look at it if I get a chance. I just did a drive by on this one.

Comment 56 Ian Donaldson 2018-11-14 05:45:39 UTC
I'm  just looking at way to avoid anaconda falling over with this...

if I removed the @authoring-and-publishing from tha package list and replace that
with a 'dnf -y installgroup 'Authoring and Publishing' in %post 
will that be equivalent?

(presumably preceding that with a dnf install tex-something to avoid
the missing dependency... need to know what something is but)

Comment 57 Adam Williamson 2018-11-14 19:07:57 UTC
As best as I can tell, the new error seems to suggest a file in texlive-lib (/usr/share/texlive/texmf-config/web2c/updmap.cfg) has a reference to a font that isn't actually shipped in Fedora (Coelacanth). That's definitely a different bug, so it really should be filed separately. spot, any idea what's going on there?

Comment 58 Fedora Update System 2018-11-23 05:02:18 UTC
texlive-base-20170520-42.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.