Bug 1564210 - 18.0.0-3.fc28 build causes llvmpipe fallback on GNOME (Wayland)
Summary: 18.0.0-3.fc28 build causes llvmpipe fallback on GNOME (Wayland)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tom Stellard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
: 1564356 1564653 1565741 (view as bug list)
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-05 16:47 UTC by fednuc
Modified: 2018-04-11 23:03 UTC (History)
28 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-11 23:03:00 UTC


Attachments (Terms of Use)
glxinfo stdout (68.29 KB, text/plain)
2018-04-06 18:38 UTC, fednuc
no flags Details
glxinfo stderr (21.54 KB, text/plain)
2018-04-06 18:38 UTC, fednuc
no flags Details
glxinfo full (89.95 KB, text/plain)
2018-04-07 08:43 UTC, Mikhail
no flags Details
$ journalctl -u gdm (6.05 KB, text/plain)
2018-04-07 08:44 UTC, Mikhail
no flags Details

Description fednuc 2018-04-05 16:47:26 UTC
With the above build of mesa, hardware accel seems to be completely unavailable for 4 of 4 tested machines (3 intel gfx, 1 AMD gfx), at least in GNOME Wayland:

* Intel GMA 4500MHD
* Intel Ivy Bridge (HD 4000)
* Intel Haswell (HD 5000)
* Radeon 300 series


Example symptoms:

* totem fails with Clutter error including "Missing Cogl context"
* gnome-mpv fails with "Failed to initialize opengl-cb"
* glxinfo | grep OpenGL shows "OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)" etc.
* Gradual fade-in of GNOME's "night light" colour temperature change (on GDM start and session login) is very slow and jerky on a system with a 4k display (suggests software rendering)

All previous versions (F27, and all F28 builds from 18.0.0-0.3.rc4.fc28 to 18.0.0-2.fc28.1) work fine.

Presumably this is directly related to "Disable build of wayland packages" from the changelog.

mesa-libwayland-egl remains installed, on whatever the previous version was before upgrading all the other mesa packages to 18.0.0-3.

Comment 1 Tom Stellard 2018-04-06 05:05:42 UTC
Igor can you take a quick look at this.  I dropped the wayland packages from mesa after you added the obsoletes for mesa-libwayland to the wayland spec file.  Did I miss something?

Comment 2 fednuc 2018-04-06 10:05:46 UTC
Today the most recent build of wayland appeared in the repos (it wasn't there using dl.fedoraproject.org directly yesterday) and that build actually obsoleted mesa-libwayland-egl with libwayland-egl (per the changelog - "Make mesa-libwayland-egl obsoleting actually work").

However, upgrading to wayland-*-1.14.93-2 with that replacement libwayland-egl package (and to mesa-*-18.0.0-3) also/still results in software rendering (only tested on one machine, but I'm presuming it'll be the same on the others).

Comment 3 Tom Stellard 2018-04-06 14:27:16 UTC
Can you attach the output from this command:

LD_DEBUG=files LIBGL_DEBUG=verbose glxinfo

Comment 4 Tom Stellard 2018-04-06 14:46:23 UTC
What version of libdrm do you have installed?

Comment 5 Tom Stellard 2018-04-06 14:52:50 UTC
The mesa package is not requiring a new enough version of libdrm.  That could be the issue here.

Comment 6 fednuc 2018-04-06 18:26:11 UTC
libdrm-2.4.91-1.fc28

Do you still need/want the glxinfo debug info?

Comment 7 Tom Stellard 2018-04-06 18:27:16 UTC
(In reply to Stephen from comment #6)
> libdrm-2.4.91-1.fc28
> 
> Do you still need/want the glxinfo debug info?

Yes.

Comment 8 fednuc 2018-04-06 18:38 UTC
Created attachment 1418259 [details]
glxinfo stdout

Comment 9 fednuc 2018-04-06 18:38 UTC
Created attachment 1418260 [details]
glxinfo stderr

Comment 10 fednuc 2018-04-06 18:39:51 UTC
(In reply to Tom Stellard from comment #7)
> > Do you still need/want the glxinfo debug info?
> 
> Yes.


Attached.

So you're not able to reproduce?

Comment 11 Tom Stellard 2018-04-06 18:45:48 UTC
(In reply to Stephen from comment #10)
> (In reply to Tom Stellard from comment #7)
> > > Do you still need/want the glxinfo debug info?
> > 
> > Yes.
> 
> 
> Attached.
> 
> So you're not able to reproduce?

No, I need to get the right kind of system setup.  Can you post your xorg.log and/or any wayland logs?

Comment 12 fednuc 2018-04-06 18:51:12 UTC
> No, I need to get the right kind of system setup.

That's very surprising, I was able to reproduce this on 3 different generations of Intel graphics as well as amdgpu.

I also managed to reproduce it on a fresh vanilla install of F28 Beta from live workstation ISO with all default settings (doesn't result in software rendering fallback initially) then upgraded to latest packages incl. mesa-*-18.0.0-3 (fallback occurs).

Comment 13 fednuc 2018-04-06 19:03:27 UTC
> Can you post your xorg.log

None since 2015 ;)

> and/or any wayland logs?

Which logs? I'm using GNOME Wayland.

There's nothing relevant in /var/log, and the only thing that might be relevant in journald containing either 'wayland' or 'mutter' is pairs of messages like this for a few applications (Evolution, Epiphany etc.):

WaylandCompositor requires eglBindWaylandDisplayWL, eglUnbindWaylandDisplayWL and eglQueryWaylandBuffer.
Nested Wayland compositor could not initialize EGL

And possibly this (not sure if this was when I was trying the above upgrade to libwayland-egl):

gnome-shell[2031]: JS WARNING: [resource:///org/gnome/shell/ui/windowManager.js 1468]: reference to undefined property "MetaWindowXwayland"

Comment 14 Mikhail 2018-04-07 08:43 UTC
Created attachment 1418518 [details]
glxinfo full

Comment 15 Mikhail 2018-04-07 08:44 UTC
Created attachment 1418519 [details]
$ journalctl -u gdm

Comment 16 David Abdurachmanov 2018-04-08 08:21:13 UTC
I fresh installed Fedora 28 Beta yesterday on i7-8550U (Kabylake GT1.5) laptop and see exact same  issues as mentioned in the first post.

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL version string: 2.1 Mesa 18.0.0

Installed a fresh Fedora 27 Live Image on USB and it boots with proper HW acceleration:

$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Kabylake GT1.5
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.2

Comment 17 Fedora Blocker Bugs Application 2018-04-08 08:27:34 UTC
Proposed as a Blocker and Freeze Exception for 28-final by Fedora user mikhail using the blocker tracking app because:

 Many users with Intel and AMD GPU experience this bug.
Consequences of this problem:
* totem fails with Clutter error including "Missing Cogl context"
* gnome-mpv fails with "Failed to initialize opengl-cb"
* glxinfo | grep OpenGL shows "OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)" etc.
* Gradual fade-in of GNOME's "night light" colour temperature change (on GDM start and session login) is very slow and jerky on a system with a 4k display (suggests software rendering)
* Not working games from steam store

Comment 18 Mikhail 2018-04-08 17:00:24 UTC
+ cheese also crashed
https://bugzilla.redhat.com/show_bug.cgi?id=1564796


$ cheese 

(cheese:20007): Clutter-CRITICAL **: 21:56:10.401: Unable to initialize Clutter: Unable to initialize the Clutter backend: no available drivers found.

** (cheese:20007): ERROR **: 21:56:10.401: cheese-application.vala:86: Unable to initialize libcheese-gtk
Trace/breakpoint trap (core dumped)

Comment 19 Nicolas Berrehouc 2018-04-09 07:12:55 UTC
Confirm regression, hardware acceleration seems to be completely unavailable.

$ lspci -nnk |grep -iA3 "VGA"
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood PRO [Radeon HD 5550/5570/5630/6510/6610/7570] [1002:68d9]
	Subsystem: ASUSTeK Computer Inc. Device [1043:036c]
	Kernel driver in use: radeon
	Kernel modules: radeon

Comment 20 Kalev Lember 2018-04-09 09:43:31 UTC
Could it be that disabling wayland support in mesa regressed this? I suspect the wayland support check does more than just controlling whether libwayland-egl gets built.

If that's the case, then instead of completely disabling wayland support, should just rm the libwayland-egl library files in %install.

Comment 21 Tom Atkinson 2018-04-09 11:33:11 UTC
I tested Kalev's suggestion and it fixed the issue for me.

Comment 22 Kalev Lember 2018-04-09 14:42:01 UTC
Should be fixed now in https://src.fedoraproject.org/rpms/mesa/c/9f97135799d23da89c2c802f140e4880873ac2de

Comment 23 Tom Stellard 2018-04-09 14:46:05 UTC
*** Bug 1564653 has been marked as a duplicate of this bug. ***

Comment 24 Tom Stellard 2018-04-09 14:56:46 UTC
*** Bug 1564356 has been marked as a duplicate of this bug. ***

Comment 25 Adam Williamson 2018-04-09 15:05:04 UTC
Kalev: can you please submit an update ASAP? This is breaking things for lots of people. Thanks.

Comment 26 Fedora Update System 2018-04-09 15:47:59 UTC
mesa-18.0.0-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-10fbc1fcf6

Comment 27 Kalev Lember 2018-04-09 15:51:15 UTC
(In reply to Adam Williamson from comment #25)
> Kalev: can you please submit an update ASAP? This is breaking things for
> lots of people. Thanks.

Sure, was just waiting for mesa to finish building. Submitted now.

Comment 28 fednuc 2018-04-09 16:04:17 UTC
18.0.0-4 (Koji build 1067643) works for me. I also upgraded libwayland-*, which I was holding back to be able to remain on the working mesa-*-18.0.0-2.fc28.1 build previously. Thanks Kalev!

Comment 29 David Vásquez 2018-04-09 17:19:47 UTC
If the update in koji works fine, please give karma for a fastly update...

Comment 30 Geoffrey Marr 2018-04-09 18:01:37 UTC
Discussed during the 2018-04-09 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-04-09/f28-blocker-review.2018-04-09-16.01.txt

Comment 31 Fedora Update System 2018-04-10 22:50:56 UTC
mesa-18.0.0-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-10fbc1fcf6

Comment 32 Michael Catanzaro 2018-04-11 01:06:24 UTC
*** Bug 1565741 has been marked as a duplicate of this bug. ***

Comment 33 Fedora Update System 2018-04-11 23:03:00 UTC
mesa-18.0.0-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.