Bug 1697211 - [abrt] imsettings: g_hash_table_lookup_node(): imsettings-daemon killed by SIGABRT
Summary: [abrt] imsettings: g_hash_table_lookup_node(): imsettings-daemon killed by SI...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c4df6f808c8e833fc02448adc17...
: 1649396 1665761 1668120 1671451 1696357 1697016 1713985 1717190 1722851 1723814 1738227 1740106 1745234 1753042 1760098 1766829 1768311 1769059 1779077 1782436 1786739 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-08 05:51 UTC by Milan Kerslager
Modified: 2020-01-12 01:41 UTC (History)
27 users (show)

Fixed In Version: imsettings-1.8.2-1.fc30 imsettings-1.8.2-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-11 01:09:33 UTC


Attachments (Terms of Use)
File: backtrace (22.18 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: cgroup (369 bytes, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: core_backtrace (10.67 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: cpuinfo (1.47 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: dso_list (2.67 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: environ (653 bytes, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: limits (1.29 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: maps (17.17 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: mountinfo (3.98 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: open_fds (456 bytes, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details
File: proc_pid_status (1.32 KB, text/plain)
2019-04-08 05:51 UTC, Milan Kerslager
no flags Details

Description Milan Kerslager 2019-04-08 05:51:04 UTC
Version-Release number of selected component:
imsettings-1.7.3-6.fc29

Additional info:
reporter:       libreport-2.10.0
backtrace_rating: 4
cmdline:        /usr/libexec/imsettings-daemon
crash_function: g_hash_table_lookup_node
executable:     /usr/libexec/imsettings-daemon
journald_cursor: s=25e9e854390e4073b28b24d7c7aa8774;i=5a91;b=036096806eb64446a528e45c95a91bef;m=25b8918;t=5858478b4ec7d;x=4599a78d8c33b842
kernel:         5.0.5-200.fc29.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Milan Kerslager 2019-04-08 05:51:07 UTC
Created attachment 1553393 [details]
File: backtrace

Comment 2 Milan Kerslager 2019-04-08 05:51:08 UTC
Created attachment 1553394 [details]
File: cgroup

Comment 3 Milan Kerslager 2019-04-08 05:51:09 UTC
Created attachment 1553395 [details]
File: core_backtrace

Comment 4 Milan Kerslager 2019-04-08 05:51:10 UTC
Created attachment 1553396 [details]
File: cpuinfo

Comment 5 Milan Kerslager 2019-04-08 05:51:11 UTC
Created attachment 1553397 [details]
File: dso_list

Comment 6 Milan Kerslager 2019-04-08 05:51:12 UTC
Created attachment 1553398 [details]
File: environ

Comment 7 Milan Kerslager 2019-04-08 05:51:13 UTC
Created attachment 1553399 [details]
File: limits

Comment 8 Milan Kerslager 2019-04-08 05:51:14 UTC
Created attachment 1553400 [details]
File: maps

Comment 9 Milan Kerslager 2019-04-08 05:51:16 UTC
Created attachment 1553401 [details]
File: mountinfo

Comment 10 Milan Kerslager 2019-04-08 05:51:17 UTC
Created attachment 1553402 [details]
File: open_fds

Comment 11 Milan Kerslager 2019-04-08 05:51:18 UTC
Created attachment 1553403 [details]
File: proc_pid_status

Comment 12 Akira TAGOH 2019-04-09 09:25:56 UTC
*** Bug 1649396 has been marked as a duplicate of this bug. ***

Comment 13 Akira TAGOH 2019-09-03 08:17:35 UTC
*** Bug 1697016 has been marked as a duplicate of this bug. ***

Comment 14 Akira TAGOH 2019-09-03 08:18:58 UTC
*** Bug 1723814 has been marked as a duplicate of this bug. ***

Comment 15 Akira TAGOH 2019-09-03 08:19:31 UTC
*** Bug 1738227 has been marked as a duplicate of this bug. ***

Comment 16 Akira TAGOH 2019-09-03 08:20:13 UTC
*** Bug 1745234 has been marked as a duplicate of this bug. ***

Comment 17 Akira TAGOH 2019-09-03 08:20:21 UTC
*** Bug 1740106 has been marked as a duplicate of this bug. ***

Comment 18 Akira TAGOH 2019-09-24 10:39:24 UTC
*** Bug 1753042 has been marked as a duplicate of this bug. ***

Comment 19 Akira TAGOH 2019-09-24 10:39:58 UTC
*** Bug 1717190 has been marked as a duplicate of this bug. ***

Comment 20 Akira TAGOH 2019-09-24 10:43:50 UTC
*** Bug 1696357 has been marked as a duplicate of this bug. ***

Comment 21 Akira TAGOH 2019-09-24 10:44:14 UTC
*** Bug 1671451 has been marked as a duplicate of this bug. ***

Comment 22 Akira TAGOH 2019-09-24 10:44:54 UTC
*** Bug 1668120 has been marked as a duplicate of this bug. ***

Comment 23 Akira TAGOH 2019-09-24 10:46:10 UTC
*** Bug 1665761 has been marked as a duplicate of this bug. ***

Comment 24 Anders Andersson 2019-10-28 17:43:01 UTC
Similar problem has been detected:

Logged in and the message appeared.

reporter:       libreport-2.10.1
backtrace_rating: 4
cmdline:        /usr/libexec/imsettings-daemon
crash_function: g_mutex_lock
executable:     /usr/libexec/imsettings-daemon
journald_cursor: s=9d60156f2c5745f1b24ced5b5316cfea;i=17fd;b=b49e6b309b464378a2676dfe6f4c52cd;m=5171da89;t=595fb91acbba2;x=4fed66abdfdf6407
kernel:         5.0.9-301.fc30.x86_64
package:        imsettings-1.8.1-1.fc30
reason:         imsettings-daemon killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1337

Comment 25 Bill Crawford 2019-11-19 11:53:34 UTC
Similar problem has been detected:

I logged into my desktop. A notification appeared saying there had been a problem and asking if I wanted to report it ...

reporter:       libreport-2.11.3
backtrace_rating: 4
cmdline:        /usr/libexec/imsettings-daemon
crash_function: g_mutex_lock
executable:     /usr/libexec/imsettings-daemon
journald_cursor: s=b6f029e65975492a9baedefc01380593;i=7849;b=729ed2b8153e4f968d49af0b30e60eb9;m=2f12e08;t=597b17ee0e3b2;x=6542731f8d5533c8
kernel:         5.3.11-200.fc30.x86_64
package:        imsettings-1.8.1-1.fc30
reason:         imsettings-daemon killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 26 Bill Crawford 2019-11-19 12:09:20 UTC
This morning's updates included:

glib2-2.60.7-2.fc30.x86_64
glib2-devel-2.60.7-2.fc30.x86_64
gtk2-2.24.32-6.fc30.x86_64
gtk2-devel-2.24.32-6.fc30.x86_64
gtk2-immodule-xim-2.24.32-6.fc30.x86_64

Whereas imsettings was last updated on the 9th. It's possible this is exposing a bug in imsettings-daemon though.

Comment 27 Akira TAGOH 2019-12-24 12:19:15 UTC
*** Bug 1713985 has been marked as a duplicate of this bug. ***

Comment 28 Akira TAGOH 2019-12-24 12:19:57 UTC
*** Bug 1722851 has been marked as a duplicate of this bug. ***

Comment 29 Akira TAGOH 2019-12-24 12:20:37 UTC
*** Bug 1760098 has been marked as a duplicate of this bug. ***

Comment 30 Akira TAGOH 2019-12-24 12:20:59 UTC
*** Bug 1766829 has been marked as a duplicate of this bug. ***

Comment 31 Akira TAGOH 2019-12-24 12:21:21 UTC
*** Bug 1768311 has been marked as a duplicate of this bug. ***

Comment 32 Akira TAGOH 2019-12-24 12:21:38 UTC
*** Bug 1769059 has been marked as a duplicate of this bug. ***

Comment 33 Akira TAGOH 2019-12-24 12:21:48 UTC
*** Bug 1779077 has been marked as a duplicate of this bug. ***

Comment 34 Akira TAGOH 2019-12-24 12:22:03 UTC
*** Bug 1782436 has been marked as a duplicate of this bug. ***

Comment 35 Fedora Update System 2019-12-25 06:50:27 UTC
FEDORA-2019-b370ef6421 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b370ef6421

Comment 36 Fedora Update System 2019-12-25 06:50:58 UTC
FEDORA-2019-0b16b7a9b7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0b16b7a9b7

Comment 37 xzj8b3 2019-12-27 16:15:15 UTC
*** Bug 1786739 has been marked as a duplicate of this bug. ***

Comment 38 Sam P 2020-01-02 20:48:17 UTC
Similar problem has been detected:

ABRT notified me of this error as I was logging in. Freshly kicked workstation.

reporter:       libreport-2.11.3
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/dbus\x2d:1.2\x2dcom.redhat.imsettings.slice/dbus-:1.2-com.redhat.imsettings@0.service
cmdline:        /usr/libexec/imsettings-daemon
crash_function: g_mutex_lock
executable:     /usr/libexec/imsettings-daemon
journald_cursor: s=79362a0a3fc04ab9b4c7b5be9ac335a8;i=8ae;b=f88260dd1e324a00833571dbb6bcfad3;m=2ac1aa1;t=59b2b993ef657;x=488a847542f6e94d
kernel:         5.3.14-300.fc31.x86_64
package:        imsettings-1.8.1-2.fc31
reason:         imsettings-daemon killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 39 Fedora Update System 2020-01-03 21:32:25 UTC
imsettings-1.8.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b370ef6421

Comment 40 Fedora Update System 2020-01-04 22:23:14 UTC
imsettings-1.8.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0b16b7a9b7

Comment 41 Fedora Update System 2020-01-11 01:09:33 UTC
imsettings-1.8.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2020-01-12 01:41:34 UTC
imsettings-1.8.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.