Bug 171543 - update twisted-python from 1.3 to 2.4 stack
update twisted-python from 1.3 to 2.4 stack
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-twisted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
:
: 185726 188133 (view as bug list)
Depends On: 207265 208169 216102 216103 216104 216105 216106 221307 221308 221309 221310
Blocks: FE6Target poker-network
  Show dependency treegraph
 
Reported: 2005-10-22 15:12 EDT by Ryan Skadberg
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 19:27:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2005-10-22 15:12:22 EDT
Twisted is currently at version 2.1 and extras only has 1.3.  Any chance it
could get updated?
Comment 1 Thomas Vander Stichele 2005-11-12 14:14:31 EST
It's at 2.0.1, but yes, I'd like to get it updated at some point.  It' s a
tricky update though because upstream has split into subprojects.  Some of us
have been trying out various approaches, but we're not there yet I think.
Comment 2 Nicolas Mailhot 2005-12-11 12:10:11 EST
Also twisted is currently broken in devel since in installs in 2.3 while rawhide
uses python 2.4
Comment 3 Pekka Pietikäinen 2006-02-07 06:26:49 EST
pyvault ( http://www.python.org/pyvault/SRPMS/index.html ) has rpms of twisted
2.1.0 that work pretty well, wonder if that work could be used to
come up with some rpms that conform to the extras guidelines (pyvault does
things their own way, alas, but their packages are of very good quality
otherwise :-) )
Comment 4 Paul Howarth 2006-05-11 11:15:07 EDT
For anyone that's interested, I took the packages from pyvault referenced in
Comment #3, changed some of the dependencies to refer to the names used in
current Extras versions (e.g. SOAPpy instead of python-soappy), updated to
latest versions, fixed most rpmlint issues and tested that they built in mock.
The results are available here:

http://www.city-fan.org/ftp/contrib/bittorrent/Twisted/

I don't use most of these packages myself so beware that they may not work, or
be incompatible with other things that depend on Twisted.

Perhaps Thomas could consider this approach for a new release in Extras development?
Comment 5 Thomas Vander Stichele 2006-06-07 05:12:24 EDT
*** Bug 188133 has been marked as a duplicate of this bug. ***
Comment 6 Thomas Vander Stichele 2006-06-07 05:12:39 EDT
*** Bug 185726 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Vander Stichele 2006-06-15 05:30:16 EDT
http://thomas.apestaart.org/download/pkg/fedora-5-i386-extras/

has a list of new src.rpm's.  I've also added part of the divmod stack for
people to play with.

Main change is that all of the packages are arch-specific, so they are actually
all in the same import space.  The mixing of noarch and arch packages completely
breaks importing.

I will start filing these packages as new package requests if someone can test them.
Comment 8 Thomas Vander Stichele 2006-07-02 07:30:03 EDT
Did anyone try these ? I would like to start pushing them in.

SAVE THE WHALES !
Comment 9 Nicolas Mailhot 2006-07-02 08:03:59 EDT
Could someone *please* change this bug summary so people know what it's all
about when they receive bugzilla CC?
Comment 10 Pekka Pietikäinen 2006-07-09 15:09:01 EDT
I did some (limited) testing, and the packages worked a-ok for me for the one
inhouse app I tested them with. YMMV.
Comment 11 Andy Burns 2006-07-10 11:57:51 EDT
I installed 

pyOpenSSL (from rawhide)
python-zope-interface (from apestaart)
python-twisted-core (from apestaart)

binary RPMs (even though I'm acually running fc6/rawhide) to enable me to look
at elisa-0.0.1 and it worked ok (if a little slowly).

Comment 12 Paul Howarth 2006-09-06 06:46:27 EDT
I'm using python-twisted-core and python-twisted-web packages that are very
close to yours (main difference is that the .pyo files are not ghosted) with
bittorrent 4.20.9 and they work for me. Can get get these packages submitted for
review so that there's a chance of them getting into Extras before FC6 is released?

I think all of the new packages can be released safely in parallel with the old
python-twisted package, and then when they're all ready, release the new
python-twisted metapackage to upgrade and pull in all the new ones for existing
users.
Comment 13 Matthias Saou 2006-09-08 05:54:01 EDT
Thomas, please submit those packages for review, as it doesn't seem you have.
I think that you'll unfortunately need to create a new bugzilla entry for each
an every package... you can start gently with a handful, then another, then... etc.

Note that as Paul just pointed out, %ghost'ing *.pyo files isn't considered the
proper thing to do anymore, see the wiki page for the details :
http://www.fedoraproject.org/wiki/Packaging/Python#pyos

I'm willing to review a few or even all, so really, do go ahead ASAP :-)
Comment 14 Paul Howarth 2006-09-20 02:47:55 EDT
The old python-twisted paclage was removed from Extras development today as it
hadn't been rebuilt (no surprise there). So FE6 is currently without any Twisted
implementation at all. I'm also willing to review some of these packagesl please
do submit them ASAP.
Comment 15 Paul Howarth 2006-09-20 06:07:25 EDT
As a start towards moving this forward, I've submitted the dependency package
python-zope-interface for review (Bug #207265).
Comment 16 Thomas Vander Stichele 2007-01-03 14:00:23 EST
adding for more deps
Comment 17 Christopher Stone 2007-01-24 19:27:15 EST
Closing bug, if there is any reason this bug should *not* be closed, then reopen
explaining why or add a dependency.

Note You need to log in before you can comment on or make changes to this bug.