Bug 182242 - Gnucash does not start
Summary: Gnucash does not start
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: guile   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
: 183006 183139 183372 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-21 12:20 UTC by Eskil Bylund
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 09:24:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eskil Bylund 2006-02-21 12:20:47 UTC
Description of problem:
When starting gnucash, I get the following error:

/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: In procedure dynamic-link in
expression (load-extension "libguile-srfi-srfi-13-14-v-1" "scm_init_srfi_13"):
/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: file:
"libguile-srfi-srfi-13-14-v-1", message: "libguile-srfi-srfi-13-14-v-1.so:
cannot open shared object file: No such file or directory"

> ll /usr/lib/libguile-srfi-*
/usr/lib/libguile-srfi-srfi-13-14-v-1.so.1
/usr/lib/libguile-srfi-srfi-13-14-v-1.so.1.0.0
/usr/lib/libguile-srfi-srfi-4-v-1.so.1
/usr/lib/libguile-srfi-srfi-4-v-1.so.1.0.0

Version-Release number of selected component (if applicable):
gnucash-1.8.12-3
guile-1.6.7-5.2

Comment 1 Bill Nottingham 2006-02-21 17:11:03 UTC
Does installing guile-devel fix it?

Comment 2 Bill Nottingham 2006-02-21 17:14:06 UTC
This code is all within guile, so presumably the .so files need to be moved from
guile-devel to guile itself. Probably some 'feature' of libguile-ltdl.

Comment 3 Eskil Bylund 2006-02-21 20:12:42 UTC
Yes, installing guile-devel fixes this.

I've got the following versions on FC4, where it works. Perhaps it could help
narrowing the bug down...

gnucash-1.8.12-3
guile-1.6.7-5.2

Comment 4 Eskil Bylund 2006-02-21 20:14:21 UTC
Sorry, that was supposed to be:
gnucash-1.8.12-0.fc4
guile-1.6.7-2

Comment 5 Phil Anderson 2006-02-26 00:14:21 UTC
I had fixed it by:
cd /usr/lib
ln -s libguile-srfi-srfi-13-14-v-1.so.1 libguile-srfi-srfi-13-14-v-1.so


Comment 6 Bill Nottingham 2006-02-27 19:09:47 UTC
*** Bug 183139 has been marked as a duplicate of this bug. ***

Comment 7 Bill Nottingham 2006-02-27 19:10:18 UTC
*** Bug 183006 has been marked as a duplicate of this bug. ***

Comment 8 Bill Nottingham 2006-02-28 03:00:58 UTC
This appears to be because of guile's use of libtool to load its modules - you
need either the .so or the .la files in the main package.

Comment 9 Bill Nottingham 2006-02-28 03:20:32 UTC
Easily reproduced outside of gnucash with:

# guile -c "(use-modules (srfi srfi-13)) (exit ((lambda () 0)))"
ERROR: In procedure dynamic-link:
ERROR: file: "libguile-srfi-srfi-13-14-v-1", message:
"libguile-srfi-srfi-13-14-v-1.so: cannot open shared object file: No such file
or directory"


Comment 10 Miroslav Lichvar 2006-02-28 09:24:08 UTC
Ok, I moved the .la files to the main package. Thanks for the help. Fixed in
guile-1.6.7-6.

Comment 11 Bill Nottingham 2006-02-28 18:29:39 UTC
*** Bug 183372 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.