Bug 18225 - Users not logged on when using kdm
Summary: Users not logged on when using kdm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 18311 23890 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-03 15:53 UTC by Ian Pilcher
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-08 04:30:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Pilcher 2000-10-03 15:53:28 UTC
When kdm is used as the X display manager, users are not properly logged
in.  At a minimum, /etc/profile is not being run, so any scripts in
/etc/profile.d are not run either.  In addition to leaving users' PATHs and
other environment variables incorrect, this prevents the Delete key from
functioning on my system.

I have traced this problem to a change in /etc/X11/xdm/Xsession.  In Red
Hat 6.2, the first line of this script was "#!/bin/bash -login"; it has
been changed to "#!/bin/sh".

(Note:  I believe that bug #17873 was caused by an initial workaround to
the PATH symptom.)

Comment 1 Michael Schwendt 2000-10-08 04:30:05 UTC
Same here.

Comment 2 Ngo Than 2000-10-11 13:56:03 UTC
it's fixed in xinitrc-3.1-1

Comment 3 Michael Schwendt 2000-10-13 05:31:01 UTC
What the heck is xinitrc-3.1-1? In current rawhide there is no such package
version, but just xinitrc-3.0-1.

Comment 4 Bernhard Rosenkraenzer 2000-11-03 10:04:03 UTC
Rawhide is always a couple of days behind our internal builds, it should be there now.

Comment 5 Bernhard Rosenkraenzer 2000-11-03 10:04:12 UTC
*** Bug 18311 has been marked as a duplicate of this bug. ***

Comment 6 Bernhard Rosenkraenzer 2001-01-15 21:28:28 UTC
*** Bug 23890 has been marked as a duplicate of this bug. ***

Comment 7 Ian Pilcher 2001-01-21 19:50:21 UTC
I have updated to xinitrc-3.1-1, and PATH is still not set correctly when I log
in as root via kdm.

Changing the first line of Xsession from "#!/bin/sh -login" to "#!/bin/bash
-login" fixes the problem.

I don't understand why this is the case, because /bin/sh is a symlink to
/bin/bash on my system.
Perhaps bash behaves differently when it is run as 'sh'?


Note You need to log in before you can comment on or make changes to this bug.