Bug 182992 - Inability to type Greek, old xkb files
Inability to type Greek, old xkb files
Status: CLOSED DUPLICATE of bug 181313
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2006-02-24 18:53 EST by Simos Xenitellis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-24 19:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Simos Xenitellis 2006-02-24 18:53:41 EST
Description of problem:
There is a general inability to write Greek

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open gnome-terminal
2. Type "setxkbmap us,gr  -option grp:alt_shift_toggle"
Actual results:
The command fails with a generic error.

Expected results:
The command should succeed (no output to console).

Additional info:
It appears that Fedora (core 5 test 3) has old xkbdata file, they are not
updated to a recent xkeyboard-config. Some files list the Greek keyboard as "el"
while others list it as "gr". The current convention is to call it "gr" (there
has been a switch 20 months ago).

Updating to xkeyboard-config also fixed a bug in the GNOME Keyboard Settings.
Comment 1 Mike A. Harris 2006-02-24 19:02:28 EST
Always run "yum update" before filing, in case your bug/problem has been
fixed already...

*** This bug has been marked as a duplicate of 181313 ***
Comment 2 Simos Xenitellis 2006-02-25 15:11:19 EST
I verify that "gr" is now working, thanks to the last two package updates of

There are a few other bugs around this issue, namely
1a. bug 174133 (several options in the Keyboard Preferences are not present).
1b. bug 176876 (provides workaround to above, reported this upstream)
2. bug 173267 (discusses issue with xorg7. actually, Xorg has been slow to
update xkeyboard-config)

and most importantly,
3. bug 183058 (default keyboard switching, Both Shift keys, does not work.
Please change to Alt-Shift).

Note You need to log in before you can comment on or make changes to this bug.