Bug 18406 - Failure to load support for ncr53c8xx
Failure to load support for ncr53c8xx
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 11:14 EDT by Bob Bell
Modified: 2007-03-26 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 14:02:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Bell 2000-10-05 11:14:49 EDT
I'm installing Red Hat Linux 7.0 on an old dual P-90 with 16 MB of RAM. 
I'm doing an NFS install.  The only hard drive in the system is a SCSI
drive (which apparently has an old Red Hat 6.X on it) contected to a
ncr53c8xx SCSI card.  I boot the install with "linux dd", and have a driver
disk (with I also use for my Etherworks 3 network card).  I eventually get
a "No Drives Found".  I think the problem is not with the drives, but with
the SCSI driver kernel module.  In the screen accessible by ALT-F2, I see
the following:
* probing buses
* finished bus probing
* found suggestion of ncr53c8xx
* found nothing

And then a few "insmod"s.  What I am missing is a "insmod ncr53c8xx".  I
don't think the appropriate module is getting loaded.

Also, I don't totally know what this means, but ALT-F4 includes:
<4> scsi : 0 hosts
<4> scsi : detected total.

Your help in getting Red Hat Linux 7.0 to install properly on this system
is appreciated.
Comment 1 Bob Bell 2000-10-05 12:11:12 EDT
I have now verified that the problem is indeed that the installer fails to load
the module.  I switched to the shell at ALT-F2 during the "Welcome to Red Hat"
screen.  Then I dug around and figured out how to extract the ncr53c8xx driver
and manually insert it.  I switched back, and was able to continue the install.
Comment 2 Bob Bell 2000-10-05 15:44:06 EDT
Similar (though perhaps different, I can't tell) problems have been reported
before.  Cross-reference bugs 8364, 7567, 6407, 852.  Some may be a different
problem.  As stated, I have determined that mine is simply a matter of failing
to load the module even after it is detected.
Comment 3 Michael Fulbright 2000-10-05 17:47:42 EDT
Brock please reproduce.
Comment 4 Brock Organ 2000-11-01 16:20:10 EST
reassigning these to dale@redhat.com for further review ...
Comment 5 Dale Lovelace 2000-11-02 15:25:48 EST
  I have verified this. If you boot with "linux dd", then choose your ethernet
card from the drivers.img disk and have scsi the scsi driver will never get
loaded, so you can not install.
Comment 6 Erik Troan 2000-11-20 14:02:51 EST
Good spot -- fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.