Bug 186365 - scim-libs should prereq libstdc++so7
scim-libs should prereq libstdc++so7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jens Petersen
: EasyFix, i18n
: 186368 186697 (view as bug list)
Depends On:
Blocks: SCIM FC5Update
  Show dependency treegraph
 
Reported: 2006-03-23 01:53 EST by Qingyu Wang
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4.4-9.1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 01:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qingyu Wang 2006-03-23 01:53:30 EST
Description of problem:
With scim starting, when rename a filename/directoryname, in the rename window,
SCIM can't be activate and then even lead to no responding of the window. Uses
can't rename file/directory with SCIM.

Version-Release number of selected component (if applicable):
scim-1.4.4-9.i386

How reproducible:
Always

Steps to Reproduce:
1. Select a file/directory, choose "Rename" item from right-button mouse to
rename a file/directory
2. Move cursor in rename window, Activate SCIM 
3. Input anything, English letters or chinese letters
  
Actual results:
SCIM isn't activated, and the user can't input anything else in the rename
window after using "ctrl+space" to active SCIM

Expected results:
SCIM can be activated and the user can input Chinese words or English letters in
rename window.

Additional info:
Comment 1 Qingyu Wang 2006-03-23 03:15:16 EST
I removed all scim rpms which were installed in FC5 installation process and
installed scim from "add/remove packages" again and found this bug disappear.
After checking the install log I found there was an error when installed
scim-libs in FC5 installation process, the error is "Cannot load module
/usr/lib/gtk-2.0/immodules/im-scim.so: libstdc++-20060203.so.7: cannot open
shared object file: No such file or directory
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
libstdc++- 20060203.so.7: cannot open shared object file: No such file or directory 
error: %post(scim-libs-1.4.4-9.i386) scriptlet failed, exit status 1". 

So I think it's not a scim bug but a release bug. As my guess, probably the
reason of this error/bug is the mis-order of installation of scim-libs and
libstdc++-20060203.so.7(libstdc++-20060203.so.7 is installed after scim-libs
when FC5 install) in FC5 installation process.
Comment 2 Qingyu Wang 2006-03-23 05:10:27 EST
After testing it further, I found if I install scim-libs withoud
libstdc++-20060203.so.7 installation in "add/remove package"(then "add/remove
package" will check dependency of scim-libs and install libstdc++-20060203.so.7
for scim-libs), this bug will produce again. But if I install scim-libs after
the installation of libstdc++-20060203.so.7, this bug disappear. So it's the
problem of installation of scim-libs and libstdc++-20060203.so.7. 
Comment 3 Jens Petersen 2006-03-23 08:54:42 EST
This sounds similar to a yum bug that pnasrat was looking into it after fc5test3.
Comment 4 Jens Petersen 2006-03-23 08:59:14 EST
Are you testing on x86_64 or i386 btw?
Comment 5 Qingyu Wang 2006-03-23 21:16:39 EST
on i386
Comment 6 Jens Petersen 2006-03-23 22:02:19 EST
Was this a fresh install or upgrade?

I only see a similar error when upgrading from fc4.
Comment 7 Jens Petersen 2006-03-23 22:09:31 EST
And the program you're describing is in a nautilus window?
Comment 8 Qingyu Wang 2006-03-24 00:05:06 EST
It's a fresh install for FC5, and the program I described is not in a nautilus
window but on the Desktop. Yet in nautilus window this problem still occurs.
Comment 9 Qingyu Wang 2006-03-24 00:06:29 EST
Did you try it on fresh installed FC5?
Comment 10 Jens Petersen 2006-03-24 02:46:00 EST
I mean that I haven't seen any install errors for scim
when doing a fresh install (on x86_64).
Comment 11 Jens Petersen 2006-03-24 03:51:12 EST
*** Bug 186368 has been marked as a duplicate of this bug. ***
Comment 12 Qingyu Wang 2006-03-24 04:25:30 EST
Just after the fresh installation of FC5, with the error info in install.log,
also I found there isn't scim entry in
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules. And I tried install scim
without libstdc++-20060203.so.7 installation through yum, no problem happen. The
log of yum is as followings:
Mar 24 16:33:59 Installed: libstdc++so7.i386 4.2.0-0.3.20060203.2
Mar 24 16:33:59 Installed: scim-libs.i386 1.4.4-9
Mar 24 16:34:01 Installed: scim.i386 1.4.4-9
Comment 13 Qingyu Wang 2006-03-24 05:34:10 EST
As I mentioned above, the reason install scim through yum is no problem is that
the order of installation is correct--it should install libstdc++so7.i386 before
scim-lib and other scim package. The order in install.log is wrong, it install
scim before libstdc++so7.i386, leading to the occurence of this bug.
Comment 14 Jens Petersen 2006-03-27 04:26:29 EST
Reassigning to anaconda.
Comment 15 Paul Nasrat 2006-03-27 07:36:01 EST
If things are required for %pre scripts they need to be explicit

libstdc++-20060203.so.7 16384
libstdc++-20060203.so.7(CXXABI_1.4) 16384
libstdc++-20060203.so.7(GLIBCXX_4.2) 16384

16384 == RPMSENSE_FIND_REQUIRES

Please attach /root/install.log and /root/anaconda.*log
Comment 16 Jens Petersen 2006-03-27 22:17:26 EST
Ok, I see you're right, so we need to prereq libstdc++so7. <sigh/>

But why does yum get it right but not pirut and anaconda?
If scim-libs requires libstdc++so7 anyway, doesn't it make sense
to install that before scim-libs anyway, like yum does?
Comment 17 Jens Petersen 2006-03-27 22:49:31 EST
*** Bug 186697 has been marked as a duplicate of this bug. ***
Comment 18 Paul Nasrat 2006-03-28 08:27:00 EST
pirut uses yum, yum uses rpm ordering (tsort).  Different correct partial orders
can occur depending on the transaction set.  It's not yum is getting it right. 
You need to be explicit, as the requires only specify runtime requirements.
Comment 19 Jens Petersen 2006-03-29 07:54:10 EST
(Naively it still seems to me that it would make more sense to prefer
partial orders where deps are installed first, but you're of course
quite right about the missing requires, Paul.)

This seems to affect all fresh installs with scim of fc5 on i386,
rising severity and priority.
Comment 20 Fedora Update System 2006-03-29 13:40:37 EST
scim-1.4.4-9.1.fc5 has been pushed for FC5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 21 Giuseppe Castagna 2006-04-01 08:31:39 EST
I do not know whether what I have, is the same as this bug. However, the
solution given here does not work for me.

I have the latest version of scim on a x86_64 architecture. 

[beppe@lampone ~]$ rpm -qa | grep scim
scim-1.4.4-9.1.fc5
scim-m17n-0.2.0-2
scim-libs-1.4.4-9.1.fc5
scim-anthy-1.0.0-1.fc5
scim-libs-1.4.4-9.1.fc5


When I launch scim under gnome the icon appears in the icon tray but clicking it
does not give me the list of input modes and ctr+space has no effect (note that
it worked perfectly with FC5t2 and FC5t3, but stopped working after my fresh
install of FC5).

I removed the current version and yum reinstalled all:

$ sudo rpm -e scim-libs scim scim-m17n scim-anthy

Very bizarre the command above works, no warning for the dependency
ofscim-anthy-1.0.0-1.fc5


$ sudo yum install scim-libs scim scim-m17n scim-anthy


Quite interestengly it now installs the i386 libstdc++ library (thus there is
some dependency problem).


=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 scim                    x86_64     1.4.4-9.1.fc5    updates-released  270 k
 scim-anthy              x86_64     1.0.0-1.fc5      updates-released  389 k
 scim-libs               x86_64     1.4.4-9.1.fc5    updates-released  751 k
 scim-libs               i386       1.4.4-9.1.fc5    updates-released  756 k
 scim-m17n               x86_64     0.2.0-2          core               48 k
Installing for dependencies:
 libstdc++so7            i386       4.2.0-0.3.20060203.2  core              309 k
=============================================================================


I rebooted, tried to launch scim from a fresh account. But same problem, the
icon appears and no input mode menus. No tool bar, no effect with ctr+space.

I've no idea on how to carry on.
Comment 22 Jens Petersen 2006-04-02 04:04:18 EDT
Does running:

# /usr/bin/update-gtk-immodules x86_64-redhat-linux-gnu
# /usr/bin/update-gtk-immodules i386-redhat-linux-gnu

help?


In response to your comments:

> Very bizarre the command above works, no warning for the dependency
> of scim-anthy-1.0.0-1.fc5

What dependency?  You removed scim too, it seems, right?

> Quite interestengly it now installs the i386 libstdc++ library

Yep, yum tends to do that: it will install both multilibs if available.

Presumably libstdc++so7.x86_64 is installed, right?
Comment 23 Giuseppe Castagna 2006-04-02 04:45:34 EDT
> Does running:
> 
> # /usr/bin/update-gtk-immodules x86_64-redhat-linux-gnu
> # /usr/bin/update-gtk-immodules i386-redhat-linux-gnu
> 
> help?

Unfortunatly it does not. Right clicking on the icon works but left-clicking
does nothing (and Anthy, latin-pre and post are marked in the Global setup of
the engine). Toolbar not displayed (though I set to have it always displayed).

> 
> In response to your comments:
> 
> > Very bizarre the command above works, no warning for the dependency
> > of scim-anthy-1.0.0-1.fc5
>
> What dependency?  You removed scim too, it seems, right?
>

Yeah, sorry my mistake.

> > Quite interestengly it now installs the i386 libstdc++ library
>
> Yep, yum tends to do that: it will install both multilibs if available.
> 
> Presumably libstdc++so7.x86_64 is installed, right?

right
Comment 24 Jens Petersen 2006-04-02 05:43:35 EDT
Strange.  It sounds like a different problem: I haven't experienced or
heard of any problems yet on x86_64 either.

How about XIM, does it work at all under X (eg xterm) or KDE (eg kedit)?
Comment 25 Jens Petersen 2006-04-02 05:45:42 EDT
Probably better to file a separate bug I think.

But also which application(s) have you been testing in?
Comment 26 Giuseppe Castagna 2006-04-02 07:52:00 EDT
> How about XIM, does it work at all under X (eg xterm) or KDE (eg kedit)?

Ahem, ... what is XIM? A search for xim with pirut did not give any interesting
result. Before I used IIIMF (and it was more than enough for what I need), and
with FC5t2 I passed to scim. What am I supposed to do? 

> But also which application(s) have you been testing in?

thunderbird, gedit. What is really stange is that it worked perfectly with fc5t2

I'll open a new bug report and post the number here.
Comment 27 Giuseppe Castagna 2006-04-02 08:00:34 EDT
Added new bug report.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187660

Note You need to log in before you can comment on or make changes to this bug.