Bug 187620 - selinux does not allow firefox plugin for Shockwave Flash Player libflashplayer.so to run
selinux does not allow firefox plugin for Shockwave Flash Player libflashplay...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
bzcl34nup
:
: 196203 196751 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 18:06 EST by John Griffiths
Modified: 2008-08-02 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 21:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2006-04-01 18:06:11 EST
DDescription of problem:
firefox plugin for Flash Player libflashplayer.so will not run.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install Shockwave Flash Player plugin (libflashplayer.so) in firefox.
2. Run firefox
3. check plugins using about:plugins
4. Shockwave Flash is not listed.
  
Actual results:
Shockwave Flash is not listed. flash files cannot be opened.

Expected results:
Shockwave Flash should be listed. flash files should be opened.


Additional info:
This can be worked around by using:
    chcon -t textrel_shlib_t libflashplayer.so
in the firefox plugins directory.
Comment 1 John Griffiths 2006-04-10 18:13:24 EDT
Forgot to post that I have the tar ball installed and not the rpm from RedHat,
so Firefox is in /usr/local/firefox .
Comment 2 Daniel Walsh 2006-04-11 17:13:24 EDT
Where is the libflashplayer installed?


chcon -t textrel_shlib_t libflashplayer.so 

should fix the problem.

Comment 3 John Griffiths 2006-04-12 09:27:19 EDT
Notice my workcaround in Additional Info.

libflashplayer.so is installed in /usr/local/firefox/plugins
Comment 6 Alessandro Volpi 2006-05-05 17:28:51 EDT
The same behaviour is obtained with Mozilla ; I also installed from the tarball
taken from www.adobe.com
Comment 7 Daniel Walsh 2006-05-07 06:25:41 EDT
Fixed in selinux-policy-2.2.38-1.fc5
Comment 8 John Griffiths 2006-05-08 12:05:32 EDT
Currently using selinux-policy-2.2.34-3.fc5 which is current release. It is not
fixed in that.

Checked development repository for FC5 and the latest is 2.2.35-2 as of Mon May
 8 12:09:49 EDT 2006. I tried to update, but got:

Error: failure: Fedora/RPMS/selinux-policy-targeted-2.2.35-2.noarch.rpm from
development: [Errno 256] No more mirrors to try.

I'll keep looking for selinux-policy-2.2.38-1.fc5 or some
selinux-policy-2.2.38-X.fc5 to show up, so I can test.
Comment 9 Aaron Luchko 2006-06-19 02:08:12 EDT
I encountered this bug using selinux-policy-2.2.43-4.fc5

The workaround worked for me
Comment 10 Zack Cerza 2006-06-21 16:40:35 EDT
*** Bug 196203 has been marked as a duplicate of this bug. ***
Comment 11 Warren Togami 2006-06-21 16:57:29 EDT
Adobe has indicated that text relocations will be fixed in the next version of
Flash Player for Linux, release date yet undetermined.  You can follow this
progress in Bug #189622.
Comment 12 Warren Togami 2006-06-26 17:35:24 EDT
*** Bug 196751 has been marked as a duplicate of this bug. ***
Comment 13 Warren Togami 2006-06-27 09:05:28 EDT
*** Bug 196861 has been marked as a duplicate of this bug. ***
Comment 14 petrosyan 2008-03-14 01:44:50 EDT
Fedora Core 5 is no longer maintained. Is this bug still present in Fedora 7 or
Fedora 8?
Comment 15 Bug Zapper 2008-04-03 22:30:43 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.