Bug 188192 - error creating "C/C++" project
error creating "C/C++" project
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 15:42 EDT by Victor Bogado
Modified: 2008-03-11 12:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 12:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.log from two failed attempt to save a file. (12.52 KB, text/plain)
2006-04-10 09:04 EDT, Victor Bogado
no flags Details

  None (edit)
Description Victor Bogado 2006-04-06 15:42:06 EDT
+++ This bug was initially created as a clone of Bug #152027 +++

From the File->New Project menu:

-> select "Standard Make C Project", hit Next
-> enter "foo", hit "Finish" button

this pops up an error dialog:

"Error Creating Project", "Reason: Internal error"

after being returned the the new project dialog and hitting Cancel, a new dialog
pops up: "An internal error occurred during CDT Project async save"

if I go through the same process again, it seems to work.



"

-- Additional comment from jorton@redhat.com on 2005-03-24 10:24 EST --
Created an attachment (id=112291)
backtrace

This backtrace was printed to the console whilst I was doing this; may be
relevant.

-- Additional comment from jorton@redhat.com on 2005-03-24 10:25 EST --
Not to forget important details; this is a fresh Raw Hide install as of this
morning:

$ rpm -qf /usr/bin/eclipse
eclipse-platform-3.1.0_fc-0.M5.13.i386


-- Additional comment from kms@passback.co.uk on 2005-03-28 13:37 EST --
*** Bug 152206 has been marked as a duplicate of this bug. ***

-- Additional comment from bkonrath@redhat.com on 2005-03-29 14:25 EST --
This looks like a libgcj bug. A fix is in classpath and will be moved over to
libgcj soon. I will report back when new gcc rpms are available.

-- Additional comment from bkonrath@redhat.com on 2005-03-29 22:02 EST --
I built gcc with the fix and it solved this problem. I will request a new gcc4 rpm.

-- Additional comment from bkonrath@redhat.com on 2005-03-31 12:40 EST --
This problem is fixed with gcc-java-4.0.0-0.38.

-- Additional comment from bogado@bogado.net on 2006-04-06 11:14 EST --
I am having this same problem with the gcc-java-4.1.0-3 from FC5. I already
tried to erase all the eclipse data I found, so I could rule out a "trashed"
environment (I removed ~/.eclipse and the workspace dir). 

I first noticed a problem similar to the Bug 181510, but it didn't gave me no
clear backtrace. So I performed the cleanup and tried to recreate my project,
and got this result, also with no backtrace at all. 

For information I have the following packages installed, and I am running in a
i686 with hyperthreading enabled (smp): 

$ rpm -qa | grep eclipse
eclipse-rcp-3.1.2-1jpp_13fc
eclipse-pydev-0.9.3_fc-14
eclipse-ecj-3.1.2-1jpp_13fc
eclipse-platform-3.1.2-1jpp_13fc
eclipse-cdt-3.0.2-1jpp_2fc
eclipse-platform-devel-3.1.2-1jpp_13fc
eclipse-pde-3.1.2-1jpp_13fc
eclipse-jdt-3.1.2-1jpp_13fc
eclipse-rcp-devel-3.1.2-1jpp_13fc
eclipse-jdt-devel-3.1.2-1jpp_13fc
eclipse-bugzilla-0.2.2-2

$ rpm -qa | grep gcj
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh
libgcj-devel-4.1.0-3
libgcj-src-4.1.0-3
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_83rh
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_83rh
libgcj-4.1.0-3
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_83rh
Comment 1 Victor Bogado 2006-04-06 15:44:22 EDT
Created a new bug, I don't know if that is the correct procedure. :-/ 
Comment 2 Victor Bogado 2006-04-07 09:16:21 EDT
Installing the VM from sun (java-1.5.0-sun-1.5.0.06-1jpp) fixed the problem, so
I guess the problem is with the gcc java engine or libraries.

After successufully creating a C++ project while using the sun VM the problem
converts into the on described in Bug 181510. So I guess they are in fact the
same bug. :-/
Comment 3 Ben Konrath 2006-04-07 10:02:23 EDT
I can't reproduce this on x86. What arch are you using?
Comment 4 Victor Bogado 2006-04-07 10:09:23 EDT
I am using x86, a Pentium 4 with hyperthreads. I will try with hyperthreading
disablesad to see what happens. 
Comment 5 Victor Bogado 2006-04-07 10:26:59 EDT
I disabled the hyperthreads and had no luck, the system simply gives me "save
failed: null" when I try to save a first time and "save failed:
org.eclipse.core.internal.utils.UniversalUniqueIdentifier".

When attempting to create a new c++ project I get "project cannot be created \n
reason: internal error (details:
org.eclipse.core.internal.utils.UniversalUniqueIdentifier)". 

I would bet that this class has something that is subtly not working that it
would  be ok in 90% of the time, but for some lucky it would simply go crazy.

I installed eclipse in this environment after the system was properly installed,
 using yum, for some reason the installer took too long with custom packages
selected.
Comment 6 Victor Bogado 2006-04-07 14:19:22 EDT
I just remembered that even though I did disable hyperthreads, I only have the
smp kernel installed. Maybe this information is useful, probably not. :-/ 
Comment 7 Victor Bogado 2006-04-07 14:40:52 EDT
I am more and more inclined to believe that this is a problem with the order I
installed the RPMs, do you have a list of witch RPMs have to be installed and in
witch order? 

I just found out that my instalation does not seam to have the knowledge that
the cvs plugin is installed.
Comment 8 Ben Konrath 2006-04-09 21:29:16 EDT
The order of installation shouldn't matter. Can you look in:

Help -> About Eclipse SDK -> Plugin Detials 

and see if you can find the org.eclipse.team.cvs plugins. Can you also post your
workspace/.metadata/.log file? Thanks. 
Comment 9 Victor Bogado 2006-04-10 09:04:15 EDT
Created attachment 127545 [details]
.log from two failed attempt to save a file.

I found the CVS plugin, it was that old problem with the component between the
monitor and the chair. :-) 

But the problem with the gcj native stack continue. I made the following
changed the "alternatives" to use the java and javac from the gcj java. Removed
the .log file and started the eclipse platform. I then tried to save a file
twice, since the first give "save failed: Null" and the second gives a bit more
information. 

The stdout read: 

--------------
$ eclipse
Save Failed
Reason:
Save Failed
Save Failed
Reason:
Save Failed
--------------

And the .log I will attach.
Comment 10 Victor Bogado 2006-04-10 09:13:08 EDT
In a attempt to do the same thing while a creation of a new project, it don't
creates a new '.log' file and also don't print anything to the stdout. It does
create the directory of the project and it also creates the files .cdtproject
and .project in there. 

but the dialog keeps coming back and no project is added to the user interface.

---- .project ----
<?xml version="1.0" encoding="UTF-8"?>
<projectDescription>
        <name>testing</name>
        <comment></comment>
        <projects>
        </projects>
        <buildSpec>
        </buildSpec>
        <natures>
        </natures>
</projectDescription>
------------------

---- .cdtproject ----
<?xml version='1.0'?>
<?eclipse-cdt version="2.0"?>
<cdtproject id='org.eclipse.cdt.make.core.make'>
    <extension point='org.eclipse.cdt.core.CIndexer'
id='org.eclipse.cdt.core.domsourceindexer'/>
    <extension point='org.eclipse.cdt.core.BinaryParser'
id='org.eclipse.cdt.core.ELF'/>
</cdtproject>
---------------------
Comment 11 Jeff Johnston 2006-11-06 16:20:50 EST
I also could not reproduce this.  I now have FC6 installed and it also works
fine.  Do you have access to an FC6 system to try it out?  The level of
eclipse-cdt in FC6 is now based on 3.1.1 which includes a number of bug fixes.
Comment 12 Victor Bogado 2008-03-11 12:11:20 EDT
I am closing this, as I were the original reporter and it is not happening in
newer version. 

Note You need to log in before you can comment on or make changes to this bug.