Bug 188524 - Soundcard SB64 (ISA) not detected
Soundcard SB64 (ISA) not detected
Status: CLOSED DUPLICATE of bug 191651
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
: 209925 218398 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-04-10 16:57 EDT by Piergiorgio Sartor
Modified: 2008-02-19 09:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-19 09:56:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-04-10 16:57:31 EDT
Description of problem:
I've a not-so-new PC, K6 + VIA MVP3 MB, with a nice Creative SB64 ISA.
After upgrading from FC4 to FC5 the card is not working anymore, reason
is that the proper modules are not loaded.
I guess this is an udev issue, maybe I'm wrong, so please, in that case,
route the problem to proper place.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Ugrade from FC4 to FC5 (maybe important)
Type "lsmod"
Actual results:
No snd-* modules appear at all.

Expected results:
Some snd-* modules should be shown, specifically snd-sbawe and many others.

Additional info:
kernel is 2.6.16-1.2080_FC5.

kudzu shows correctly:

class: OTHER
detached: 0
desc: "Creative SB AWE64  PnP - CTL0022"
deviceId: CTL0022
pdeviceId: CTL00e4
class: OTHER
detached: 0
desc: "Creative SB AWE64  PnP - CTL7002"
deviceId: CTL7002
pdeviceId: CTL00e4
compat: PNPb02f

/etc/modprobe.conf (maybe last 3 lines are not OK, nevertheless this worked before).

alias char-major-116* snd
alias snd-card-0 snd-sbawe
alias char-major-14* soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
install snd-sbawe /sbin/modprobe --first-time --ignore-install snd-sbawe && {
/usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-sbawe { /usr/sbin/alsactl store >/dev/null 2>&1 || :; } ;
/sbin/modprobe -r --first-time --ignore-remove snd-sbawe
Comment 1 Piergiorgio Sartor 2006-04-10 17:00:24 EDT
Forgot something thing, sorry.

The command "udevinfo -e" does not give a clue about the soundcard.

Extract from "dmesg":

isapnp: Scanning for PnP cards...
isapnp: checksum for device 1 is not valid (0x58)
pnp: SB audio device quirk - increasing port range
pnp: AWE32 quirk - adding two ports
isapnp: Card 'Creative SB AWE64  PnP'
isapnp: 1 Plug & Play card detected total
Comment 2 Daryl Hochhalter 2006-05-09 12:26:12 EDT
I've got a similar problem with crystal cs4235 card and snd-cs4236 driver which
is an installed module with all dependencies in kernel 2.6.15-1 fresh install FC5.
When I run system-config-soundcard, I get the driver and card shoing in the
dialog, but no pcm device. I have isapnp and /sys/devices/pnp0 so the system
knows the card is there. I have tried various setting in modprobe.conf and get
wrong card index 0.... in the scsound.log. Along with soundcard.py:273
deprecationWarning: use gtk.combobox
soundcard.py:308: GtkDeprecationWarning gtk.timeout_add, use gobject.timeout
soundcard.py:548: GtkDeprecationWarning: gtk.TRUE, use True instead gtk.main()
ALSA lib pcm_hw.c:1305: (_snd_pcm_hw_open)Invalid value for card
aplay: main:547: audio open error: No such device
Read config:
card 0
device 0
HW 0

Also, I've had problems with modprobe snd-cs4236 index=0
error messages along the chain saying that there is an invalid symbol in the
module starting with snd.ko
a dry run works fine, but when it actually tries to add the required modules to
the kernel, I get insmod snd-page-alloc.ko & insmod soundcore.ko, but errors
start at insmod snd.ko (error inserting snd (path) Input/Output error. Then bad
symbol errors in the rest of the insmod trace. 
Also, I've noticed that the s-c-soundcard dialog returns warning like can't open
device for writing. There is never an asound in /proc and proc has permissions
set to ro. I look in /etc/makedev.d and find devices are listed in the alsa file
but never show up in /dev. I believe they are created in hidden mode but have no
idea how one could access these devices if they are actually being created, or
when they are created. It seems all too complicated for just a simple soundcard
Comment 3 Harald Hoyer 2006-05-09 14:50:01 EDT
Is this a kernel problem? Reassigning to kernel for help...
Comment 4 Piergiorgio Sartor 2006-05-09 15:43:10 EDT
I think it is an udev problem, in fact all the other "hints" (from dmesg
to kudzu) reveal the soundcard perfectly, only udev "forgets" to load the
proper kernel module(s).
I mean, the kernel reports all the information correctly, and if I load
the module "by hand", it even works!
Of course, I cannot say anything about the cs4235 case.
BTW, I experienced the same problem on two different PCs, with FC5, and
ISA soundcard, one is the SB 64, the other is a similar SB 64 GOLD.
It seems to me the ISA bus is ignored by udev.
If you don't mind, I'll reassign the bug back (anyway the kernel people
will see it, I guess).
Comment 5 Piergiorgio Sartor 2006-05-09 15:46:03 EDT
Waaa, sorry, I try it again...
Comment 6 Harald Hoyer 2006-05-10 00:53:49 EDT
Daryl Hochhalter, please open a seperate bugzilla against component kernel.

Piergiorgio Sartor:
> udev "forgets" to load the proper kernel module

Udev mostly relies on kernel events and "dev" files provided by the kernel, so
if the kernel does not provide such events and/or files, there is nothing udev
can/should do.

Please run the command:
# find /sys/ -name modalias
one of these files should contain a string which should match the alias strings of:

# modinfo snd-sbawe
alias:          pnp:cCTL0035dCTL0031dCTL0021*
alias:          pnp:cCTL0039dCTL0031dCTL0021*
alias:          pnp:cCTL0042dCTL0031dCTL0021*
alias:          pnp:cCTL0043dCTL0031dCTL0021*
alias:          pnp:cCTL0044dCTL0031dCTL0021*
alias:          pnp:cCTL0045dCTL0031dCTL0021*
alias:          pnp:cCTL0046dCTL0031dCTL0021*
alias:          pnp:cCTL0047dCTL0031dCTL0021*
alias:          pnp:cCTL0048dCTL0031dCTL0021*
alias:          pnp:cCTL0054dCTL0031dCTL0021*
alias:          pnp:cCTL009adCTL0041dCTL0021*
alias:          pnp:cCTL009cdCTL0041dCTL0021*
alias:          pnp:cCTL009fdCTL0041dCTL0021*
alias:          pnp:cCTL009ddCTL0042dCTL0022*
alias:          pnp:cCTL009edCTL0044dCTL0023*
alias:          pnp:cCTL00b2dCTL0044dCTL0023*
alias:          pnp:cCTL00c1dCTL0042dCTL0022*
alias:          pnp:cCTL00c3dCTL0045dCTL0022*
alias:          pnp:cCTL00c5dCTL0045dCTL0022*
alias:          pnp:cCTL00c7dCTL0045dCTL0022*
alias:          pnp:cCTL00e4dCTL0045dCTL0022*
alias:          pnp:cCTL00e9dCTL0045dCTL0022*
alias:          pnp:cCTL00eddCTL0041dCTL0070*
alias:          pnp:cCTLXXXXdCTL0031dCTL0021*
alias:          pnp:cCTLXXXXdCTL0041dCTL0021*
alias:          pnp:cCTLXXXXdCTL0042dCTL0022*
alias:          pnp:cCTLXXXXdCTL0044dCTL0023*
alias:          pnp:cCTLXXXXdCTL0045dCTL0022*

If not, then reassign this bug to kernel.
Comment 7 Piergiorgio Sartor 2006-05-10 14:54:39 EDT
Thanks for the explanation, this makes thing more clear to me.

I checked the /sys/ filesystem, and, unless I miss something, I could
not find the any "modlias" file containing the snd-sbawe alias.
This using the latest FC5 kernel (2.6.16-1.2111_FC5) and using a custom, on two different PCs. Same results on all four cases:
no reference to the CTLxxx in the "modalias" files.
Actually, no reference to "pnp" or "isa" either, only "input", "pci",
"ide" and "serio".
This is the content of the "modalias" files of one of the two PCs:


So, I guess you were right, and the bug goes to the kernel...
Thanks again.
Comment 8 Daryl Hochhalter 2006-05-14 12:23:57 EDT
opened under kernel component as #191651
Comment 9 Dave Jones 2006-10-16 17:34:58 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 10 Piergiorgio Sartor 2006-10-17 12:51:07 EDT
I just tested the new kernel today and, as before, the proper modules for the
soundcard are not loaded by udev.
Comment 11 Dave Jones 2006-11-07 01:13:15 EST
For ISA devices, there will have to be some manual set up, as they cannot be
safely probed.

Maybe system-config-soundcard should offer a list of possible ISA cards that may
be present, and allow the user to pick from them, but whatever the case, the
kernel driver is there, and functional, so this is not a kernel bug.
Comment 12 Martin Stransky 2007-03-22 06:17:47 EDT
*** Bug 218398 has been marked as a duplicate of this bug. ***
Comment 13 Martin Stransky 2007-05-16 09:47:02 EDT
*** Bug 209925 has been marked as a duplicate of this bug. ***
Comment 14 Piergiorgio Sartor 2008-02-19 07:52:39 EST
The same goes for this one as per #191651, some solution, even just an howto,
should be provided and the bug closed.


Comment 15 Martin Stransky 2008-02-19 09:56:50 EST

*** This bug has been marked as a duplicate of 191651 ***

Note You need to log in before you can comment on or make changes to this bug.