Bug 18862 - Mouseconfig doesn't run when removing USB mouse...
Mouseconfig doesn't run when removing USB mouse...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 20335 29867 30174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 20:26 EDT by bc90021
Modified: 2014-03-16 22:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 10:40:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bc90021 2000-10-10 20:26:18 EDT
First off, I apologise if this is inappropriate, but I've come across
something which seems to be a bug.

I'm running RH 7 on an IBM ThinkPad (2645-9FU).  It's a 650MHz Intel
Pentium III, 320MB RAM, 12GB HDD.

If I attach a USB mouse (the optical one from Microsoft), and turn on the
machine, kudzu runs and finds the USB mouse, and I'm given the option to
configure it.  If I configure, it installs successfully.

It then asks if I wish to run mouseconfig to update my X information.  It
does this successfully, and I can run X/Gnome with no problems.

If I remove the mouse, and restart, kudzu runs, and I can remove the
configuration successfully.  However, it does not then ask me to run
mouseconfig!  (I was a bit puzzled as to why my X server kept crashing at
first, but when I read the messages generated, it told me that the "core
pointer" wasn't installed.)

This problem is easily fixed by running mouseconfig manually, but it seems
that if it runs mouseconfig when adding a mouse, it should also when it
removes it.

I haven't tested it on other platforms, or using other mice, but I can't
see the missing call to mouseconfig on removal being related to either my
machine itself or to the mouse, which is why I'm submitting this.  I can
replicate the problem consistently.

Thanks.
Comment 1 Andrew Bartlett 2001-01-06 18:54:52 EST
Or kudzu should at least put the machine back into run-level 3 (after
telling/asking the user), as a configured mouse is a requirement for X.  
It could even use the same ugly hack used to move the system into runlevel 5 in
the first place (bug 21061).
Comment 2 Sean Dilda 2001-01-08 22:44:25 EST
*** Bug 20335 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2001-02-27 17:13:19 EST
*** Bug 29867 has been marked as a duplicate of this bug. ***
Comment 4 Yu-Pa Ng 2001-02-28 16:04:21 EST
With RH71 Beta 4 (Wolverine) running, I added a USB mouse on Dell Latitude 
C600.  Upon bootup, kudzu failed to identify the mouse as a USB mouse, while in 
RH70 (Guninness), kudzu did the right thing.  The rest of the story is the same 
as in RH70 described above.
Comment 5 Bill Nottingham 2001-02-28 16:07:54 EST
Is the USB controller initializing correctly in the case where it
doesn't see the mouse?
Comment 6 Yu-Pa Ng 2001-02-28 16:19:17 EST
Yes, the USB controller is initialized correctly.  Kudzu did see a mouse added, 
but failed to identify it as a USB type of mouse.
Comment 7 Bill Nottingham 2001-02-28 16:31:18 EST
What does the /etc/sysconfig/hwconf look like?
Comment 8 Yu-Pa Ng 2001-02-28 16:44:16 EST
There are two MOUSE entri/etc/sysconfig/hwconf file: one with USB bus for the 
added USB mouse and the other one with PSAUX bus for generic PS/2 mouse.
Comment 9 Bill Nottingham 2001-02-28 16:52:14 EST
What *exactly* did it say about the mouse that was added?
Comment 10 Yu-Pa Ng 2001-02-28 16:57:55 EST
Here it is:

-
class: MOUSE
bus: USB
detached: 0
device: input/mice
driver: mousedev
desc: "Microsoft Corp. IntelliMouse"
usbclass: 3
usbsubclass: 1
usbprotocol: 2
usbbus: 1
usblevel: 1
usbport: 0
vendorId: 045e
deviceId: 0009
productrevision: unknown
-

Comment 11 Bill Nottingham 2001-02-28 17:00:36 EST
If the 'intellimouse' string is what it printed up, that's not a problem;
that's what the mouse is identified as.
Comment 12 Yu-Pa Ng 2001-02-28 17:09:29 EST
Is mouseconfig supposed to come up after the kudzu recognized a new mouse has 
been added then?  In Wolverine, it failed to invoke mouseconfig at bootup time 
while in Guinness it did.
Comment 13 Bill Nottingham 2001-02-28 17:12:30 EST
Yes, it *should* come up.
Comment 14 Bill Nottingham 2001-03-01 10:38:46 EST
*** Bug 30174 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2001-03-01 10:39:09 EST
*** Bug 30174 has been marked as a duplicate of this bug. ***
Comment 16 Bill Nottingham 2001-03-01 10:40:02 EST
*** Bug 30174 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2001-03-07 14:39:52 EST
Should be fixed in 0.97.5-1.

Note You need to log in before you can comment on or make changes to this bug.