Bug 191992 - [x86_64] i386 open office segfaults at startup: kernel 2096 ok, 2111 not ok
[x86_64] i386 open office segfaults at startup: kernel 2096 ok, 2111 not ok
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
:
: 192181 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 14:08 EDT by francois pepin
Modified: 2008-05-06 11:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description francois pepin 2006-05-16 14:08:50 EDT
Description of problem:
When trying to start any open office application, a segmentation fault happens.


Version-Release number of selected component (if applicable):
openoffice.org-calc.i386                 1:2.0.2-5.9.2 
openoffice.org-core.i386                 1:2.0.2-5.9.2
openoffice.org-draw.i386                 1:2.0.2-5.9.2
openoffice.org-graphicfilter.i386        1:2.0.2-5.9.2
openoffice.org-impress.i386              1:2.0.2-5.9.2
openoffice.org-math.i386                 1:2.0.2-5.9.2
openoffice.org-writer.i386               1:2.0.2-5.9.2
openoffice.org-xsltfilter.i386           1:2.0.2-5.9.2

kernel 2.6.16-1.2111_FC5-x86_64

How reproducible:
it happens all the time on 2 machines with the same configuration.

This thread (www.redhat.com/archives/rhl-list/2005-November/msg00515.html)
mentions the same problem.

Steps to Reproduce:
1. start any open office application

  
Actual results:
[francois@flims ~]$ oowriter
/usr/lib/openoffice.org2.0/program/soffice: line 151:  2927 Segmentation fault 
    "$sd_prog/$sd_binary" "$@"

The following logs in /var/log/message:
May 16 14:13:53 flims kernel: IA32 syscall 311 from javaldx not implemented
May 16 14:13:53 flims kernel: IA32 syscall 311 from swriter.bin not implemented
May 16 14:13:54 flims kernel: swriter.bin[2927]: segfault at 0000000000000000
rip 0000000000000000 rsp 00000000ffff8e44 error 14q

Expected results:
open office application would start


Additional info:
This post (http://lkml.org/lkml/2006/1/23/347) seems to be related to this
problem. There are indeed no IA32 syscall 311 defined when I look in my kernel
source (/usr/src/kernels/2.6.16-1.2111_FC5-x86_64/include/asm-x86_64/ia32_unistd.h)

This is would likely be a consquence of this bug 191565
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191565).
Comment 1 Caolan McNamara 2006-05-16 14:46:08 EDT
how long has this been happening for you, I've never heard of this problem all
through the FC-5 development cycle, did it just start to happen with the 2111
kernel ?
Comment 2 francois pepin 2006-05-16 18:09:06 EDT
This has always happened with those 2 machines (I only have the 2096 and 2111
kernel on it), as far as I can remember.

I have another machine which is based on the same configuration (cloned the
other 2 weeks or so ago) and almost identical hardware, but is not updated quite
as often (but they share the same kernel and openoffice) in which openoffice
works without any problems.
Comment 3 Caolan McNamara 2006-05-17 03:24:17 EDT
And to be sure, what is the output of 

/usr/sbin/sestatus

on the non-working vs working machines.
Comment 4 francois pepin 2006-05-17 14:31:02 EDT
I did not change anything regarding selinux on them:

Open office non-working:
[francois@flims ~]$ /usr/sbin/sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 20
Policy from config file:        targeted

Open office working:
[francois@lars ~]$ /usr/sbin/sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 20
Policy from config file:        targeted

I also just did an update and it stopped working on both. I was probably wrong
about it never working on the non-working machine. Would it be due to the
selinux or the glibc update?

Updating:
 NetworkManager          x86_64     0.6.2-2.fc5      updates           388 k
 NetworkManager-glib     x86_64     0.6.2-2.fc5      updates            25 k
 NetworkManager-gnome    x86_64     0.6.2-2.fc5      updates           170 k
 abiword                 x86_64     1:2.4.4-4.fc5    extras            6.1 M
 beagle                  x86_64     0.2.6-1.fc5.1    updates           1.3 M
 cups                    x86_64     1:1.2.0-1.1      updates           2.6 M
 cups-libs               x86_64     1:1.2.0-1.1      updates           165 k
 cups-libs               i386       1:1.2.0-1.1      updates           170 k
 dosfstools              x86_64     2.11-5.FC5       updates            47 k
 firefox                 x86_64     1.5.0.3-1.1.fc5  updates            16 M
 glibc                   i686       2.4-8            updates           4.9 M
 glibc                   x86_64     2.4-8            updates           4.6 M
 glibc-common            x86_64     2.4-8            updates            16 M
 glibc-devel             i386       2.4-8            updates           1.9 M
 glibc-devel             x86_64     2.4-8            updates           2.4 M
 glibc-headers           x86_64     2.4-8            updates           594 k
 hpijs                   x86_64     1:0.9.11-1.1     updates           174 k
 hplip                   x86_64     0.9.11-1.1       updates           6.7 M
 libbeagle               x86_64     0.2.6-1.fc5.1    updates            35 k
 libsane-hpaio           x86_64     0.9.11-1.1       updates           115 k
 nscd                    x86_64     2.4-8            updates           143 k
 sane-backends           x86_64     1.0.17-5.fc5.9   updates           3.0 M
 selinux-policy          noarch     2.2.38-1.fc5     updates           468 k
 selinux-policy-targeted  noarch     2.2.38-1.fc5     updates           461 k
 tzdata                  noarch     2006g-1.fc5      updates           488 k
 vnc                     x86_64     4.1.1-37.fc5     updates           159 k
 vnc-server              x86_64     4.1.1-37.fc5     updates           1.2 M
 wpa_supplicant          x86_64     1:0.4.8-10.fc5   updates           242 k
Installing for dependencies:
 gnutls                  i386       1.2.10-1         core              332 k

I tried to disable selinux using system-config-securitylevel, but it still gives
me the same error on both machines. sestatus output then:
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          disabled
Policy version:                 20
Policy from config file:        targeted
Comment 5 Caolan McNamara 2006-05-17 15:41:16 EDT
My leading contender for the culprit is glibc or kernel :-)
Comment 6 Caolan McNamara 2006-05-18 05:01:01 EDT
*** Bug 192181 has been marked as a duplicate of this bug. ***
Comment 7 francois pepin 2006-05-18 14:06:28 EDT
I think it might be a problem with both the kernel and glibc together.

I finally got to reboot one of the computer with kernel 2096 and I can use open
office properly on it.

Is there anything else for us to do but go back to the old kernel and hope for
the best with the next update?
Comment 8 Mike Olsen 2006-05-19 13:12:59 EDT
Folks, 

I had been able to use openoffice with earlier kernels also, but I went back to 
2096, and I still get a segfault in startup.  (I'm at 2111 also right now).  

I'm the person who called in but 192181 above, and other than not having luck
with going back to 2096, this does look like a duplicate of what I've got.  My
glibc's are:

glibc-common-2.4-8
glibc-headers-2.4-8
glibc-2.4-8
glibc-kernheaders-3.0-5.2
glibc-devel-2.4-8
glibc-2.4-8
glibc-devel-2.4-8

And I've tried both 2096 and 2111 kernels, and neither will work.  Just for
completeness, I've got kernels:
kernel-smp-devel-2.6.16-1.2069_FC4
kernel-smp-devel-2.6.15-1.1833_FC4
kernel-debuginfo-2.6.16-1.2111_FC5
kernel-doc-2.6.16-1.2111_FC5
kernel-2.6.16-1.2096_FC5
kernel-2.6.16-1.2107_FC5
kernel-2.6.16-1.2111_FC5
kernel-devel-2.6.16-1.2096_FC5
kernel-devel-2.6.15-1.1833_FC4
kernel-2.6.15-1.2054_FC5
kernel-devel-2.6.16-1.2069_FC4
kernel-devel-2.6.16-1.2107_FC5
kernel-devel-2.6.16-1.2111_FC5









Comment 9 Dave Jones 2006-10-16 15:24:52 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 10 Mike Olsen 2006-10-18 09:05:11 EDT
Folks,
 I just installed the kernel (kernel-2.6.18-1.2200.fc5) and tried oowriter and
oocalc.  

It still doesn't work! I get 
------------------ oowriter results -------------------------------------------
/usr/lib/openoffice.org2.0/program/soffice: line 151:  4921 Segmentation fault 
    "$sd_prog/$sd_binary" "$@"
-------------------------------------------------------------------------------

Just to be clear about what I've got, it's fc5, on a dual opteron, with the
uname -a returning:

---------------------- uname -a results ---------------------------------------
Linux kyzyl 2.6.18-1.2200.fc5 #1 SMP Sat Oct 14 16:59:56 EDT 2006 x86_64 x86_64
x86_64 GNU/Linux
------------------------------------------------------------------------------

rpm -q on openoffice.org-writer returns

----------------- rpm -q openoffice.org-writer  results -----------------------
openoffice.org-writer-2.0.2-5.19.2
--------------------------------------------------------------------------------

And my glibc rpms are:

-------------- rpm -qa glibc\* results -----------------------------------------
glibc-common-2.4-11
glibc-2.4-11
glibc-kernheaders-3.0-5.2
glibc-headers-2.4-11
glibc-devel-2.4-11
glibc-2.4-11
glibc-devel-2.4-11
-------------------------------------------------------------------------------

A final note which may or may not be relevant, is that I'm running with the
ati-fglrx X hardware accelerator driver (kmod-fglrx-8.29.6-1.2.6.18_1.2200.fc5).
Comment 11 Dave Jones 2006-10-21 03:47:12 EDT
I'm puzzled what's actually going on here.
syscall 311 is 'get_robust_list', which isn't *that* old, so ooffice should have
a fallback if this doesn't succeed.

Why it's segfaulting is a mystery. Unless there's a kernel oops in dmesg output
though after that segv, it's likely either an ooffice or glibc problem.
Comment 12 Bug Zapper 2008-04-03 22:54:00 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 13 Bug Zapper 2008-05-06 11:54:34 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.