Bug 421171 - [Indic Locales][scim] - scim is not working with Indic langs after installation
[Indic Locales][scim] - scim is not working with Indic langs after installation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 04:57 EST by Satyabrata Maitra
Modified: 2008-02-08 03:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 02:53:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2007-12-12 04:57:12 EST
IN FC8 Released version scim is behaving strangely for Indic Locale with gtk and
openoffice packages. Its not activating with Ctrl+Space button press. And more
with that, the IME "RAWCODE" not showing in scim global setup menu. 

Component Version -
scim-1.4.7-7.fc8
scim-bridge-0.4.13-4.fc8
scim-bridge-gtk-0.4.13-4.fc8
scim-libs-1.4.7-7.fc8
scim-m17n-0.2.2-2.fc8
scim-tables-0.5.7-3.fc7


+++ This bug was initially created as a clone of Bug #194573 +++

Description of problem:
when Installation is finished in Indic Langauge, SCIM is not working with
gnome/openoffice application, but working fine with 'kedit/kbabel'

Version-Release number of selected component (if applicable):
scim-1.4.4-18

How reproducible:
everytime after login with new installation

Steps to Reproduce:
1. Fresh install rawhide
2. login in Hindi Desktop
3. gedit
4.  Ctrl-SPACE (for scim active)

Actual results:
nothing happen

Expected results:
should be able to type in Hindi (any language)

Additional info:
for all supported Indic locale this is true (bn,gu,hi,mr,ml,or,pa,ta)

-- Additional comment from aalam@redhat.com on 2006-06-15 02:14 EST --
*** Bug 195428 has been marked as a duplicate of this bug. ***

-- Additional comment from jko@redhat.com on 2006-06-15 22:25 EST --
Ctrl-Space doesn't work in Korean
Version-Release number of selected component (if applicable):
scim-1.4.4-20


-- Additional comment from wtogami@redhat.com on 2006-06-16 10:45 EST --
What version of scim-bridge?


-- Additional comment from aalam@redhat.com on 2006-06-16 23:24 EST --
scim-bridge-0.1.12-2
(rawhide on 7th June 2006)


-- Additional comment from aalam@redhat.com on 2006-06-16 23:28 EST --
sorry, scim-bridge is not installed for any of these locales (by default
installation)

-- Additional comment from tagoh@redhat.com on 2006-06-18 22:51 EST --
I've heard from jko that the machine that he used is the same as you used. so it
looked like this issue may be caused by the installation failure of scim.
probably it needs to be correct first. I mean you need to remove the duplicated
scim-libs. see Bug#195633. if you see the scriptlet failed at removing, try it
with --noscripts then.


-- Additional comment from petersen@redhat.com on 2006-06-19 04:28 EST --
Could you please try again with a fresh install of fc6test1 or later rawhide?
Comment 1 Peng Huang 2007-12-13 00:13:22 EST
I can not reproduce this problem.
Please send $HOME/.xinputrc to me.
Comment 2 Satyabrata Maitra 2007-12-13 00:34:15 EST
Hi Huang

Actually for now I am closing this bug as it is a regression test bug and by
mistake this bug was cloned from its parent bug #194573.
So I am closing this bug now, and reopening the parent bug #194573. So pls
follow bug #194573 towards it's fix!

I am replying you there in the bug #194573 for your Comment #1.

*** This bug has been marked as a duplicate of 194573 ***
Comment 3 Jens Petersen 2007-12-13 02:43:48 EST
I am not sure this is related to 194573.  Let's clarify the problem first
before duplicating.

In reply to comment #0)
> IN FC8 Released version scim is behaving strangely for Indic Locale with gtk and
> openoffice packages. Its not activating with Ctrl+Space button press.

What is your desktop locale/language?  Or you using x86_64?
Did you try using im-chooser to turn on the Input Method?

> the IME "RAWCODE" not showing in scim global setup menu. 

The rawcode IME was moved to a separate subpackage scim-rawcode.
Please install that to get rawcode back.
Comment 4 Satyabrata Maitra 2007-12-13 04:30:09 EST
Hi Jens

As far as our conversation is concern, I am replying the queries :-

I did a fresh install of FC8 with hi_IN locale in i386 arch.

And Rest I shown you how exactly scim behaving. :)

Pls ask if anything more required. thanx a lot! :)
Comment 5 Peng Huang 2007-12-13 21:36:01 EST
(In reply to comment #0)

> Component Version -
> scim-1.4.7-7.fc8
> scim-bridge-0.4.13-4.fc8
> scim-bridge-gtk-0.4.13-4.fc8
> scim-libs-1.4.7-7.fc8
> scim-m17n-0.2.2-2.fc8
> scim-tables-0.5.7-3.fc7
Hi Satyabrata Maitra,

After read your report, I think you did not install all scim Indic packages. Did
you pasted all scim packages on this bug? If not, please paste output of `rpm
-qa scim\*`. 
Comment 6 Jens Petersen 2008-01-21 02:53:14 EST
Closing this for now - please reopen if you have more details
and still see a problem.
Comment 7 Jens Petersen 2008-02-06 21:38:02 EST
Satya, just for good measure, I did a fresh F8 install in Hindi now
and SCIM works just fine out of the box with gedit, oowriter, and kedit.

So I still don't understand what you were seeing.
Comment 8 Satyabrata Maitra 2008-02-08 01:55:06 EST
Hi Jens

Ok, thats excellent if it works fine! Please inform in which version of
components I have to test it to see it working fine! Please inform!
Comment 9 Jens Petersen 2008-02-08 03:40:23 EST
I tested with F8 final packages (no updates) FWIW.

I can provide more details next week.

Note You need to log in before you can comment on or make changes to this bug.